MozillaZine

This site not using HTTPS...Why?

Post a reply

:
In an effort to prevent automatic submissions, we require that you enter both of the words displayed into the text field underneath.
Smilies
:D :) :( :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: =D> #-o :^o [-X [-o< 8-[ [-( :-k ](*,) :-"
View more smilies
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: This site not using HTTPS...Why?

Re: This site not using HTTPS...Why?

Post by DanRaisch » November 18th, 2017, 5:23 am

Randomly generated for just this website ... but still.


Different passwords for each site (or type of site) is strongly recommended anyway. Sort of the opposite of using "password" as the password for every site.

Re: This site not using HTTPS...Why?

Post by Tony-E » November 18th, 2017, 4:49 am

I use different passwords for every site, if this one get's compromised, not much will happen other than somebody could answer Firefox questions whilst pretending to be me.

Sites that store confidential info need the extra security, for a sites like this it is not essential.

Re: This site not using HTTPS...Why?

Post by flip101 » November 18th, 2017, 3:19 am

Yeah this is a strange situation ... when mozilla tries to make firefox more secure. A forum about firefox has no security at all ... Now i have to send my password unencrypted over the internet :( Randomly generated for just this website ... but still. Certificates are free these days, and installation shouldn't be too difficult ..

Re: This site not using HTTPS...Why?

Post by Mark12547 » August 10th, 2017, 1:07 pm

This board could also serve as a regression check to make sure that Firefox still notifies us that we are providing a password on an unsecured page. :)

The expected behavior now is that we are warned when supplying our password for this site, but not when we are supplying a password to our gateway device, which is usually a router.

Re: This site not using HTTPS...Why?

Post by therube » May 28th, 2017, 5:00 am

(FWIW. Another board that recently went to the dark side, Please add SSL to the forum.)

Re: This site not using HTTPS...Why?

Post by barbaz » March 8th, 2017, 9:14 am

You're welcome. 8-)

Re: This site not using HTTPS...Why?

Post by BobbyPhoenix » March 8th, 2017, 6:29 am

Thanks for the explanation, and links.

Re: This site not using HTTPS...Why?

Post by barbaz » March 7th, 2017, 9:18 pm

This has come up before - viewtopic.php?f=11&t=2950805

The upshot is this. The admin is quite short on time. And this board has several other, more important issues, like people getting locked out -
viewtopic.php?f=11&t=3026494
viewtopic.php?f=11&t=3027921
viewtopic.php?f=11&t=2824277

As for feeling very insecure? Just know the risk and take some simple steps to protect yourself. All the usual advice applies. Plus,
- don't log in when you're connected to an untrusted network, such as any shared WiFi you don't control, or a network you don't know the admin.
- And make sure that your password is very different from those you use on HTTPS sites.

Do that and you can feel better, you'll be fine. :)

This site not using HTTPS...Why?

Post by BobbyPhoenix » March 7th, 2017, 7:43 pm

So with the new release today when I went to login Firefox gave me the new popup that said the username and password fields are not secure. So why is that? Shouldn't MozillaZine be using HTTPS instead of just HTTP? I did notice the padlock in the address bar with the line through it before, but the popup really brought it to my attention. I feel very insecure logging in on a non HTTPS site.

Top