MozillaZine

Updating the read-status not working!?

Talk about stuff specific to the site -- bugs, suggestions, and of course praise welcome.
johann_p

User avatar
 
Posts: 8479
Joined: November 5th, 2002, 3:05 am
Location: Sheffield, UK

Post Posted November 6th, 2002, 4:40 pm

It seems the icons are not reflecting the read status of a forum correctly, not after
actually reading the forum messages and not after using the function "mark all forums read".
Only logging out and a relogin will change the status.

shoestring

User avatar
 
Posts: 156
Joined: November 5th, 2002, 3:40 pm
Location: Geekhaven, MA, USA

Post Posted November 6th, 2002, 9:03 pm

Johann_P wrote:It seems the icons are not reflecting the read status of a forum correctly, not after
actually reading the forum messages and not after using the function "mark all forums read".
Only logging out and a relogin will change the status.


Worse yet, I just noticed that a bunch of topics (nearly all of them in fact) with <I>new</I> messages in them are not flagged as such ... I was amazed by the lack of new postings, and then I saw that there were plenty of them and it was the flags that were wrong.

Otherwise (barring other problems I haven't seen yet), the forums are really good!

asa

User avatar
 
Posts: 684
Joined: November 4th, 2002, 4:16 pm
Location: CA

Post Posted November 6th, 2002, 9:05 pm

worksforme. I notice that if I crash reading the forums that it wipes out cookies gathered during that sesson and the new forums reset your cookies everytime you visit. You might have spotted a cookie bug or you're rejecting cookies in some way which is affecting the read/unread status.

--Asa

shoestring

User avatar
 
Posts: 156
Joined: November 5th, 2002, 3:40 pm
Location: Geekhaven, MA, USA

Post Posted November 6th, 2002, 9:12 pm

asa wrote:worksforme. I notice that if I crash reading the forums that it wipes out cookies gathered during that sesson and the new forums reset your cookies everytime you visit. You might have spotted a cookie bug or you're rejecting cookies in some way which is affecting the read/unread status.

--Asa


Ah. This would not surprise me, as things are crashing here all the time ;-) ... so that could easily explain the problem. I'll just have to learn not to rely on the read/unread icons ...

shoestring

User avatar
 
Posts: 156
Joined: November 5th, 2002, 3:40 pm
Location: Geekhaven, MA, USA

Post Posted November 7th, 2002, 12:15 am

shoestring wrote:Ah. This would not surprise me, as things are crashing here all the time ;-) ... so that could easily explain the problem. I'll just have to learn not to rely on the read/unread icons ...



Hrrmf.

<I>Something</I> seems to be setting <I>nearly</I> (but perhaps not quite) everything to "read" status every time I come in here from a fresh browser (Phoenix) start. I've been doing this a lot ove the past hour or so, trying to get some tweaks to work ...

:(

leoz

User avatar
 
Posts: 131
Joined: November 4th, 2002, 8:28 pm
Location: Boston, MA, USA

Post Posted November 7th, 2002, 1:16 pm

shoestring wrote:
shoestring wrote:Ah. This would not surprise me, as things are crashing here all the time ;-) ... so that could easily explain the problem. I'll just have to learn not to rely on the read/unread icons ...



Hrrmf.

<I>Something</I> seems to be setting <I>nearly</I> (but perhaps not quite) everything to "read" status every time I come in here from a fresh browser (Phoenix) start. I've been doing this a lot ove the past hour or so, trying to get some tweaks to work ...

:(


I also have this problem - that's what made me post the other post in this forum. I hadn't
realized that it was due to me starting a new browser, but I did start a new browser. Could it
be that the problem is that the cookies that phpbb is using are session only?

I checked and found a cookie called
phpbb2mysql_t
from mozillazine, which seems like it could be the culprit - and it does expire at end of session.
Is this a customizable thing? It certainly seems as if the forum status should not expire at
end of session.

Thanks!

johann_p

User avatar
 
Posts: 8479
Joined: November 5th, 2002, 3:05 am
Location: Sheffield, UK

Post Posted November 8th, 2002, 3:55 am

somehow mozillazine.org got into my list of hosts for which to reject cookies ... I dont know how this could happen :oops:

Return to MozillaZine Site Discussion


Who is online

Users browsing this forum: No registered users and 2 guests