MozillaZine

Is our (Google) KB Search Failing, sometimes?

Talk about stuff specific to the site -- bugs, suggestions, and of course praise welcome.
therube

User avatar
 
Posts: 18172
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 25th, 2015, 7:55 am

Is our (Google) KB Search (http://kb.mozillazine.org/Knowledge_Base) Failing, sometimes?

See (& disregard the thread's Subject name), MacOsx- Something is preventing firefox from.

Code: Select all
GET
http://google.com/cse [HTTP/1.1 301 Moved Permanently 63ms]
GET
http://www.google.com/cse [HTTP/1.1 404 Not Found 78ms]
GET
http://www.google.com/images/errors/robot.png [HTTP/1.1 200 OK 31ms]
GET
http://www.google.com/images/errors/logo_sm_2.png [HTTP/1.1 200 OK 47ms]
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

barbaz
 
Posts: 1680
Joined: October 1st, 2014, 3:25 pm

Post Posted June 25th, 2015, 12:09 pm

Same problem here.

Seems like the board's google search isn't working at all either, just gives me a 404 no matter what I enter...

EDIT Clearing all history except for cookies on forums.mozillazine.org fixes it
EDIT2 well, it did yesterday, but not today.
see also viewtopic.php?f=11&t=2943287
*Always* check the changelogs BEFORE updating that important software!

therube

User avatar
 
Posts: 18172
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 11th, 2015, 4:50 am

Bump.

And to note that the Old Search works.
(I guess expected as its not using a CSE.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

LoudNoise
Moderator

User avatar
 
Posts: 40048
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted July 18th, 2015, 11:08 am

After suffering from a couple of weeks of not getting any results from the kb google search I discovered that, in my case, is was allowing googleapis.com in NoScript.
Post wrangler
"Choose between the Food Select Feature or other Functions. If no food or function is chosen, Toast is the default."

therube

User avatar
 
Posts: 18172
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 19th, 2015, 5:56 am

(And it gets even better, as kb.mozillazine.org won't even load at present, (110) Connection timed out, to even be able to test for googleapis.)

Loading now.


And something just changed. (12:38 PM 07/19/2015)

A moment ago, it was still 404.
Now, you get the "Ads by Google", but no actual search results.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

LoudNoise
Moderator

User avatar
 
Posts: 40048
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted July 19th, 2015, 12:37 pm

Have you tried safe mode?
Post wrangler
"Choose between the Food Select Feature or other Functions. If no food or function is chosen, Toast is the default."

therube

User avatar
 
Posts: 18172
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 19th, 2015, 1:26 pm

Safe. New Profile. SeaMonkey. FF. All think kind of good stuff.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

LoudNoise
Moderator

User avatar
 
Posts: 40048
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted July 19th, 2015, 3:42 pm

Weird. After allowing googleapis.com in NoScript everything worked fine for me. Does the problem happen when you are on different computer or at a different location?
Post wrangler
"Choose between the Food Select Feature or other Functions. If no food or function is chosen, Toast is the default."

therube

User avatar
 
Posts: 18172
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 20th, 2015, 6:35 am

Does the problem happen when you are on different computer or at a different location?


Yes.

And to be sure we're on the same page...

Start here: http://kb.mozillazine.org/Knowledge_Base
Search box: 'safe mode'
Search

Takes you (me) here: http://www.google.com/cse?cx=003258325049489668794%3Aru2dpahviq8&q=safe+mode&sa=Search&cof=FORID%3A0

404. That’s an error.

The requested URL /cse?cx=003258325049489668794%3Aru2dpahviq8&q=safe+mode&sa=Search&cof=FORID%3A0 was not found on this server.


Get the same with Google Chrome.
(Yesterday, different computer, location, I was at least getting the Google Ads. Now, simply the 404.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

LoudNoise
Moderator

User avatar
 
Posts: 40048
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted July 20th, 2015, 7:04 am

Works for me in both Firefox and Chromium. Clicking on the "Takes you" links works for me also.

AV maybe? Given the fact that you also have the problem on a different machine I'll admit this is a long shot at best.
Post wrangler
"Choose between the Food Select Feature or other Functions. If no food or function is chosen, Toast is the default."

therube

User avatar
 
Posts: 18172
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 20th, 2015, 7:24 am

> AV maybe?

Nope. Don't use such a beast.


Perhaps ... Fire up FF.
Ctrl+Shift+K, Network & see if that might show something different on your end URL-wise (& not that I'd really know what to look for), compared to what may have been noted here?

Code: Select all
http://www.google.com/cse?cx=003258325049489668794%3Aru2dpahviq8&q=safe+mode&sa=Search&cof=FORID%3A0

GET /cse?cx=003258325049489668794%3Aru2dpahviq8&q=safe+mode&sa=Search&cof=FORID%3A0 HTTP/1.1
Host: www.google.com
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Referer: http://kb.mozillazine.org/Knowledge_Base
Cookie: PREF=ID=1111111111111111:FF=0:TM=1434739617:LM=1435152612:S=DfrebwucsJ0w8b7s; NID=69=aHKxJP0Qv5bme_ffpwmK8hVH_oqlzSNrbWarSctzioShAbIa35__L5CB7mjZbMCoshMuMw5demmMk4hh8vC1c7s0NuSpzUI8MVVEB
Y4UKVwbVBetfPthWnTk0QGfiMfHuPfvTanIuKsZ6A; OGP=-5061451:; OGPC=5061451-1:5061617-1:
DNT: 1
Connection: keep-alive

HTTP/1.1 404 Not Found
Content-Type: text/html; charset=UTF-8
X-Content-Type-Options: nosniff
Date: Mon, 20 Jul 2015 14:28:38 GMT
Server: qfe
Content-Length: 1515
X-XSS-Protection: 1; mode=block
Alternate-Protocol: 80:quic,p=0
----------------------------------------------------------

(purposely broke NID= because code box was not being properly constrained on this board ???)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

LoudNoise
Moderator

User avatar
 
Posts: 40048
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted July 20th, 2015, 7:47 am

I'll try that this evening.
Post wrangler
"Choose between the Food Select Feature or other Functions. If no food or function is chosen, Toast is the default."

therube

User avatar
 
Posts: 18172
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 23rd, 2015, 6:05 pm

So I go here, http://www.freeware-guide.com/html/updates.html, & at the bottom of the page, the Search box, 'filezilla'.

http://www.google.com/cse?cx=partner-pu ... &sa=Search

404. That’s an error.

The requested URL /cse?cx=partner-pub-2663757276955518%3Auimepoge7iv&ie=ISO-8859-1&q=filezilla&sa=Search was not found on this server.


I don't use that search too often, but I have, successfully in the past.
So maybe its just a change on Google's end, that websites need to account for?

@LoudNoise, does the freeware-guide.com search work for you?
(You're not secretly using IE are you ;-).)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

LoudNoise
Moderator

User avatar
 
Posts: 40048
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted July 23rd, 2015, 6:47 pm

therube wrote:@LoudNoise, does the freeware-guide.com search work for you?


Yeah, works for me. I also tried a second search to make sure it had nothing to due with the link. I'll try again tomorrow on a windows machine at work.

(You're not secretly using IE are you ;-).)


I do have the ability to place 30 minute bans... :)
Post wrangler
"Choose between the Food Select Feature or other Functions. If no food or function is chosen, Toast is the default."

fredwehr
 
Posts: 16
Joined: February 14th, 2011, 8:54 am

Post Posted August 4th, 2015, 8:38 am

I also see this defect, evidenced by
"404. That’s an error.

The requested URL /cse?cx=003258325049489668794%3Adrr0nlojlas&ie=UTF-8&q=venire&sa=Go&siteurl=forums.mozillazine.org%2Fviewtopic.php%3Ff%3D48%26t%3D522643%26start%3D15&ref=forums.mozillazine.org%2Fviewtopic.php%3Ft%3D522643&ss=&siteurl=forums.mozillazine.org%2Fviewtopic.php%3Ff%3D48%26t%3D522643%26start%3D15&ref=forums.mozillazine.org%2Fviewtopic.php%3Ft%3D522643&ss= was not found on this server. That’s all we know. "

Return to MozillaZine Site Discussion


Who is online

Users browsing this forum: No registered users and 1 guest