MozillaZine

Spinning beach ball whenever I open Camino 2.0

Talk about the native Mac OS X browser.

Moderator: Camino Developers

Thingmaker
 
Posts: 38
Joined: February 8th, 2008, 7:18 pm
Location: Los Angeles

Post Posted November 30th, 2009, 9:05 am

Whenever I open Camino - Version 2.0Int (1.9.0.15 2009102617) - I get the spinning beachball and can do nothing until it goes away (usually about 1-2 minutes). If I try to force quit the message says "Camino Not Responding". Anyone else getting this?

Mac 10.5.8
2x2.8ghz quad core intel xeon

mem0
 
Posts: 129
Joined: May 3rd, 2009, 1:07 pm

Post Posted November 30th, 2009, 11:00 am

@Thingmaker: "Reset Camino..." - perhaps it helps

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted November 30th, 2009, 12:48 pm

Once it goes away, does Camino function normally?

Please get a sample of the hang: http://caminobrowser.org/documentation/bugzilla/#hang and post it somewhere we can download it (e.g., pastebin.mozilla.org).

cl

Thingmaker
 
Posts: 38
Joined: February 8th, 2008, 7:18 pm
Location: Los Angeles

Post Posted November 30th, 2009, 2:17 pm

Yes, it functions normally after a minute or so of hang time. I will try and get the info and post it.

paulc
 
Posts: 206
Joined: January 5th, 2003, 10:34 pm

Post Posted December 1st, 2009, 11:41 am

Do you have any specific page set as the default... it sounds like MAYBE you have a specific page that can cause some beachballing.

Thingmaker
 
Posts: 38
Joined: February 8th, 2008, 7:18 pm
Location: Los Angeles

Post Posted December 1st, 2009, 12:08 pm

It happens on any page I open as the default page.

Thingmaker
 
Posts: 38
Joined: February 8th, 2008, 7:18 pm
Location: Los Angeles

Post Posted December 1st, 2009, 12:11 pm


Thingmaker
 
Posts: 38
Joined: February 8th, 2008, 7:18 pm
Location: Los Angeles

Post Posted December 1st, 2009, 12:50 pm

Also, the spell check no longer works.

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted December 1st, 2009, 12:54 pm

Do you happen to have tons of fonts? In the first sample, the main thread is doing a bunch of stuff related to font lookup. The other samples are also doing some font stuff, but they're not as involved.
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

Thingmaker
 
Posts: 38
Joined: February 8th, 2008, 7:18 pm
Location: Los Angeles

Post Posted December 1st, 2009, 1:58 pm

Uncle Asad wrote:Do you happen to have tons of fonts? In the first sample, the main thread is doing a bunch of stuff related to font lookup. The other samples are also doing some font stuff, but they're not as involved.


I do have lots of fonts as I do graphic art quite often. But never had anything like this happen before. It's only since I've started using Camino 2.0.

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted December 1st, 2009, 4:16 pm

Do you often enable/disable fonts using Font Book (or any other font manager ?). I think that confuses the ATS font caches under 10.5.

Clearing font-caches may help. Utilities such as Onyx can do it; or if you're confortable with the command line, this article explains how to do it in Terminal.
Last edited by phiw13 on December 1st, 2009, 5:02 pm, edited 1 time in total.

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted December 1st, 2009, 4:50 pm

Gecko 1.9 and up do different (and additional) font lookup at startup, and from what I've read in bugs, there's more of it being done, causing slower startups for users with lots of fonts :-(
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

Thingmaker
 
Posts: 38
Joined: February 8th, 2008, 7:18 pm
Location: Los Angeles

Post Posted December 1st, 2009, 5:18 pm

phiw13 wrote:Do you often enable/disable fonts using Font Book (or any other font manager ?). I think that confuses the ATS font caches under 10.5.

Clearing font-caches may help. Utilities such as Onyx can do it; or if you're confortable with the command line, this article explains how to do it in Terminal.


I've never disabled any fonts using any method.

Thingmaker
 
Posts: 38
Joined: February 8th, 2008, 7:18 pm
Location: Los Angeles

Post Posted December 5th, 2009, 10:58 am

Just an update- cleared font caches, changed start up page to blank page, and no resolution to the problem. As discussed in the bug forum (link below), this identical problem was an issue in Firefox until they updated to Gecko 1.9.1 in the latest version of Firefox (3.5.5). It would be lovely if Camino followed suit and solved this issue as it's making working in Camino impossible.
https://bugzilla.mozilla.org/show_bug.cgi?id=532450

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted December 5th, 2009, 12:09 pm

Just out of curiosity, why do you have to re-launch Camino so often? If the problem only occurs on startup, seems to me like the solution is "don't relaunch the browser".

cl

Return to Camino


Who is online

Users browsing this forum: No registered users and 1 guest