MozillaZine

Camino 2.1 - cannot play sound clip at Myspace

Talk about the native Mac OS X browser.

Moderator: Camino Developers

QuentinHaslam
 
Posts: 7
Joined: December 6th, 2011, 11:25 am

Post Posted December 6th, 2011, 11:56 am

Further to my previous post, I now find that, with Camino 2.1, I cannot play sound clips at Myspace.

I checked using Safari and was able to play.

Any suggestions please

Can 2.1 be uninstalled?

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted December 6th, 2011, 1:19 pm

Camino 2.1 enables Flash blocking by default on PPC Macs, since the latest version of Flash for PPC contains widely-exploited security holes.

To view (hear) Flash sound clips on MySpace, you'll need to 1) make sure you are using the latest version of Flash 10.1 for PPC (because older versions will be blocked outright) 2) click the Flash placeholder for the sound player (you may need to add an exception for myspace.com if it still doesn't work, because myspace used to rely on some hidden Flash elements).

For more information about installing a later Flash version and configuring Flash exceptions, please see http://wiki.caminobrowser.org/QA:Camino_2.1.x_and_Flash
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

QuentinHaslam
 
Posts: 7
Joined: December 6th, 2011, 11:25 am

Post Posted December 6th, 2011, 2:08 pm

Uncle Asad

Thanks for the 2 replies

I have Mac OSX 10.4.11 and am using Adobe flash player 10.1

The Myspace music player works with Safari and Firefox, but no longer with Camino.

I don't quite understand what I need to do.

Does this mean that I cannot continue to use Camino. That would be disappointing because Safari and Firefox are both slower?

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted December 6th, 2011, 6:01 pm

QuentinHaslam,

1. Open the Camino preference window, and switch to the 'Web Features' pane
2. click on the Edit Flash Exception list… button
3. A sheet opens, in the textfield (focussed by default), enter the following (without the quotes): 'myspace.com' and click the add button.

the flash movies and music should now play automatically on myspace

(see http://caminobrowser.org/documentation/ ... list_flash in the documentation, 3rd paragraph in particular)

QuentinHaslam
 
Posts: 7
Joined: December 6th, 2011, 11:25 am

Post Posted December 7th, 2011, 5:32 am

phiw13

Thanks for your reply

Before I received it, I followed a link in Uncle Asad's reply, and then another link in that one.

I ended up in Camino/preferences/web features, and I unchecked the block flash animations box, which is similar but not exactly the same as you are suggesting.

That seems to have resolved it for the moment, but please let me know if what I have done has any security issues etc.

I would not want to have to go into preferences and unblock the flash application for individual repeated websites (if I am understanding it right). I hope that unblocking flash animations will cover everything.

It seems a pity that when you download a Camino update, it does not automatically remember your previous preferences.

Thanks to both you and Uncle Asad

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted December 7th, 2011, 10:45 am

QuentinHaslam wrote:It seems a pity that when you download a Camino update, it does not automatically remember your previous preferences.


It does, but re-read Uncle Asad's post one more time (emphasis mine):

Camino 2.1 enables Flash blocking by default on PPC Macs, since the latest version of Flash for PPC contains widely-exploited security holes.


We made a one-time choice that our users' security is more important than the minor inconvenience of turning off Flashblock (or setting up a Flashblock whitelist).

cl

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted December 7th, 2011, 10:07 pm

QuentinHaslam wrote:I ended up in Camino/preferences/web features, and I unchecked the block flash animations box, which is similar but not exactly the same as you are suggesting.

That seems to have resolved it for the moment, but please let me know if what I have done has any security issues etc.

Well, it does solves your problem in a way, but please bear in mind Uncle Asad’s and cflawson’s comments.

QuentinHaslam wrote:I would not want to have to go into preferences and unblock the flash application for individual repeated websites (if I am understanding it right). I hope that unblocking flash animations will cover everything.

You can leave Flashblock turned on and when you encounter a site with a Flash animation that you want to watch, you can click on the placeholder to unblock that one instance. If there are sites that you visit regularly, and that you trust, you can add and exemption (whitelist the site) as I explained in my previous post.

Return to Camino


Who is online

Users browsing this forum: No registered users and 1 guest