MozillaZine

Can't log into my Lufthansa Frequent Flyer Account

Talk about the native Mac OS X browser.

Moderator: Camino Developers

krs99
 
Posts: 21
Joined: July 16th, 2010, 8:24 am

Post Posted May 12th, 2012, 8:18 am

I can't log into my Lufthansa Frequent Flyer account at
http://www.miles-and-more.com

using Camino.
When I use Firefox or Safari, the two other browsers I tried, the log in works fine.

I get to the website no problem, then up to the point where I enter my member number and PIN,
But then with Camino nothing happens when I try to log in.
It's as if the account information is never sent when I click on the "Login" button.

Any idea what the problem might be?
I thought Camino was Mozilla based, so shouldn't that part of Camino work the same as Firefox?
I'm on Camino 2.1.2 which I think is the latest.

Thanks

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted May 12th, 2012, 11:21 am

Does Firefox 3.6.whatevertwentysomethingversionnumberthey'reuptonow work?

cl

krs99
 
Posts: 21
Joined: July 16th, 2010, 8:24 am

Post Posted May 12th, 2012, 12:00 pm

I was using Firefox 11.0.
Turns out that wasn't the latest version, so I just updated to Firefox 12.0

Tried the website again - it also works with FF 12.0, latest and greatest but not with Camino.

.....well the website itself comes up fine, it's just that when I try to log in nothing happens when I use Camino.

Maybe I should report this as a bug.

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted May 12th, 2012, 12:57 pm

Ahem.

That's most distinctly NOT what I just asked. Does *Firefox 3.6* work?

cl

krs99
 
Posts: 21
Joined: July 16th, 2010, 8:24 am

Post Posted May 12th, 2012, 1:28 pm

Sorry, wasn't clear why you wanted me to try an outdated version of Firefox.

But....I downloaded FF 3.6.19
The site works just fine with that version as well - that version of FF is actually quite fast and snappy compared to the current version.
But in any case, no problem - I enter the account number and password and the account pops up just like in the new versions of FF.

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted May 12th, 2012, 1:54 pm

OK, so we know it's (probably) not an issue of the site being written specifically for Gecko 2.0 or later.

Can you try a fresh profile in Camino and see if that works? It sounds like you might be blocking a JavaScript that the site needs (or you have JS turned off entirely, or there's a cookie involved somehow), and a fresh profile should show us if there's something specific to your current setup that's not working. Troubleshoot Camino, available from http://www.ardisson.org/smokey/moz/ , will help you automate that testing.

cl

krs99
 
Posts: 21
Joined: July 16th, 2010, 8:24 am

Post Posted May 12th, 2012, 2:29 pm

In Camino preferences,

I had the three options for Annoyance Blocking enabled, I turned all of those off ( ie deselected them)
Java Script is enabled normally, I left it like that because many web sites need it
Java had been disabled, but I enabled that for the time being.
Play animated images only once was enabled, I disabled that.

With those changes the site works with Camino.

I'm going to go through the process of elimination to see which particular option created the issue and once I know that, I can decide what steps to take next.

Thanks for the help.

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted May 12th, 2012, 2:40 pm

Wait, so you turned JS *off* and now it works, whereas it didn't work with JS turned *on*? (I highly doubt Java or the animated GIF pref have anything whatsoever to do with this.)

cl

krs99
 
Posts: 21
Joined: July 16th, 2010, 8:24 am

Post Posted May 12th, 2012, 4:44 pm

No, no

I always have JS enabled and I left it like that since many web sites do need it.

I went through the other settings one by one, turning each one on individually and then testing the site.

In the end it was blocking Flash animation that created the problem.
The site uses Flash but why the site is coded coded in such a way that one cannot log in with Flash animation blocked doesn't really make any sense to me.
I don't really want Flash on because it really slows some sites down terribly.

So I added this Lufthansa site to the Flash exception list in Camino (there was only one other web site in that list) and now things are fine.

Thanks again for your help.

Return to Camino


Who is online

Users browsing this forum: No registered users and 2 guests