MozillaZine

google keeps reverting to httpS

Talk about the native Mac OS X browser.

Moderator: Camino Developers

CMilwright
 
Posts: 17
Joined: January 8th, 2008, 9:49 am

Post Posted August 24th, 2012, 3:41 pm

I just downloaded Camino 2.1.2 yesterday. I have the quick search box in the top right corner, to the right of the address bar; and my default search engine is google. Whenever I enter anything in the search box, no matter if I've been on a secure or non secure site, the google results page comes up with an https address, not http. If I override it to http, the next time I go back to the search results it changes it to secure again. Where is the preference to stop this from happening, so that my search results page is plain http again like it was with my previous version?

Andrew`
 
Posts: 146
Joined: August 20th, 2011, 9:03 pm

Post Posted August 24th, 2012, 10:50 pm

This is not a browser setting. Google is automatically redirecting searches to use SSL/TLS.

If you prefer http:// you could try DuckDuckGo - they don't seem to redirect searches to SSL.

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted August 25th, 2012, 12:53 am

CMilwright wrote:Where is the preference to stop this from happening, so that my search results page is plain http again like it was with my previous version?

There is no preference. https is the default for google search; this has been the case for all Camino 2.1 versions. It guarantees more privacy and security. What is not to like?

If you absolutely want to have your searches go over http, then you'll have to make a bookmark for google with keyword (sees docs).

CMilwright
 
Posts: 17
Joined: January 8th, 2008, 9:49 am

Post Posted August 25th, 2012, 1:41 pm

I hate it. The old version didn't default to this. Now every time I use the forward and back buttons from a search result, I get the "entering a secure page" or "exiting a secure page" warnings. **Don't bother to suggest that it's as simple as turning off those warnings, I want them there for other reasons, but not for googling!!
Also 2.1 is very buggy. I only downloaded it this week and it's already "not responded" till I forced it quit about 6 different times. And for the first time ever since I owned my iMac it had an error when it booted up this morning. That could be a coincidence, but it's a suspicious one.

RPMozley

User avatar
 
Posts: 502
Joined: August 12th, 2006, 4:47 pm
Location: Gloucestershire, United Kingdom

Post Posted August 25th, 2012, 4:00 pm

Well for Google, you could set their preferences to open link in a new window/tab. So going back to the results page will not get the warnings, as it's already there in a different tab or window.
My build thread - Camino Builds - http://www.rpm-mozilla.org.uk
MacBook 13" 2.4GHz: OSX 10.6.8
iBook G3 Indigo 366MHz, PowerBook G3 333MHz: OSX 10.3.9

Return to Camino


Who is online

Users browsing this forum: No registered users and 1 guest