MozillaZine

ACCEPT_LANGUAGE not sent

Talk about the native Mac OS X browser.

Moderator: Camino Developers

Jonathan Pool
 
Posts: 6
Joined: October 14th, 2012, 11:48 am

Post Posted October 14th, 2012, 11:57 am

Unlike any other browser I have used, Camino is erratically not sending ACCEPT_LANGUAGE to the server. If I change the intl.accept_languages parameter, Camino thereafter sends ACCEPT_LANGUAGE during that session, but forgets my setting and in the next session again shows "en-us, en" as its value and fails to send any ACCEPT_LANGUAGE to the server.

In case it helps, I am appending a list of the headings that Camino did send in a recent connection, and ACCEPT_LANGUAGE isn't among them.

The environment variables and their values are SCRIPT_NAME
/u
SERVER_NAME
panlex.org
HTTP_REFERER
http://panlex.org/try/
SERVER_ADMIN
info@utilika.org
HTTP_ACCEPT_ENCODING
gzip, deflate
HTTP_CONNECTION
keep-alive
REQUEST_METHOD
GET
HTTP_ACCEPT
text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
SCRIPT_FILENAME
/var/www/cgi-bin/plxu.cgi
PERL_UNICODE
63
SERVER_SOFTWARE
Apache/2.2.3 (Red Hat)
HTTP_ACCEPT_CHARSET
UTF-8,*
logthis
logthis
QUERY_STRING

REMOTE_PORT
49543
ftype
mainfile
HTTP_USER_AGENT
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.2.28) Gecko/20120308 Camino/2.1.2 (like Firefox/3.6.28)
SERVER_PORT
80
SERVER_SIGNATURE
<address>Apache/2.2.3 (Red Hat) Server at panlex.org Port 80</address>, referer: http://panlex.org/try/
prevpage
fromhere
HTTP_CACHE_CONTROL
max-age=0
HTTP_COOKIE
__utma=207632531.122583453.1350196769.1350234501.1350238175.3; __utmz=207632531.1350196769.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); __utmc=207632531; __utmb=207632531.5.10.1350238175
REMOTE_ADDR
70.36.157.219
HTTP_KEEP_ALIVE
115
SERVER_PROTOCOL
HTTP/1.1
PATH
/sbin:/usr/sbin:/bin:/usr/bin
REQUEST_URI
/u
GATEWAY_INTERFACE
CGI/1.1
SERVER_ADDR
70.36.157.216
DOCUMENT_ROOT
/var/www/html/panlex.org
HTTP_HOST
panlex.org, referer: http://panlex.org/try/

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted October 14th, 2012, 7:26 pm

What happens if you change the order of languages, or add or remove a language, in the "Languages and Text" pref pane (and then, for good measure, log out and log back in)? Does that fix the problem permanently?

cl

Jonathan Pool
 
Posts: 6
Joined: October 14th, 2012, 11:48 am

Post Posted October 14th, 2012, 7:43 pm

No, it didn't solve the problem even temporarily. intl.accept_languages is "en_us, en", which isn't what I set the languages to in System Preferences, and Camino doesn't even send those two languages to the server.

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted October 15th, 2012, 4:24 am

If you delete that pref (via about:config or by manually editing prefs.js/user.js when Camino isn't running) entirely, does it then get properly populated from System Prefs?

cl

Return to Camino


Who is online

Users browsing this forum: No registered users and 1 guest