MozillaZine

Turn Off Flash Block?

Talk about the native Mac OS X browser.

Moderator: Camino Developers

maxsimms
 
Posts: 8
Joined: February 10th, 2004, 10:16 am

Post Posted February 24th, 2007, 7:19 pm

I just installed 1.1b, and for some reason it appears that Flash Block has somehow gotten turned on. I checked the "Web Features" setting, and the "Block Flash animations" box is not checked.

Is there some way for me to turn off the Flash Block feature without using the panel?

froodiantherapy
Camino Developer

User avatar
 
Posts: 732
Joined: June 11th, 2005, 8:44 am
Location: Massachusetts, Connecticut

Post Posted February 24th, 2007, 8:37 pm

When you view a page with flash, is the flash blocked with a play button (which will then display the animation when you click it), or can you not see the flash at all?
"Also, I can kill you with my brain."
10.4.x iBook G4 1.33 GHz
<a href="http://www.jonagold.org/~froodian/MoreCamino/">MoreCamino - More preferences for Camino</a>

maxsimms
 
Posts: 8
Joined: February 10th, 2004, 10:16 am

Post Posted February 24th, 2007, 8:44 pm

When I view a page, the Flash is blocked with a play button.

That's what puzzles me, because I've never installed or (knowingly) turned on any kind of Flash blocker.

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted February 24th, 2007, 9:07 pm

That doesn't seem possible for it to be on without the box being checked :? What happens if you try a fresh profile?
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

maxsimms
 
Posts: 8
Joined: February 10th, 2004, 10:16 am

Post Posted February 24th, 2007, 10:19 pm

Creating a fresh profile fixed the problem. Thanks.

maxsimms
 
Posts: 8
Joined: February 10th, 2004, 10:16 am

Post Posted February 24th, 2007, 10:35 pm

I've figured out that the problem was triggered by something in my usercontent.css file (or at least, deleting the usercontent.css file now makes Flash appear normally). The file worked fine in 1.03, but for some reason seems to automatically turn on the Flash Block in 1.1b.

ishermandom

User avatar
 
Posts: 231
Joined: January 17th, 2005, 7:54 pm
Location: Stanford

Post Posted February 24th, 2007, 11:01 pm

I had the same experience... leftovers from CamiTools I suppose. Removing the call to import flashblock.css from my userContent.css made the preference work as expected.

Right now my chrome folder has two files with "flashblock" in their name: flashblock.css and flashblock.jar. Should I have both of them, or just one?

dryeburn
 
Posts: 83
Joined: September 17th, 2005, 1:53 pm

Post Posted February 24th, 2007, 11:37 pm

whiterose wrote:Right now my chrome folder has two files with "flashblock" in their name: flashblock.css and flashblock.jar. Should I have both of them, or just one?

Try using neither of them.
David

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted February 25th, 2007, 12:26 am

maxsimms, glad you figured that out. Parts of Flashblock are automatically active when they are present but don't "work" unless the Flashblock stylesheet is loaded. The line in your userContent.css file causes the stylesheet to be loaded when Camino is launched.

All of Camino's built-in Flashblock lives inside the application itself...anything that seems to be Flashblock-related in your profile is probably residue from a non-Camino installation and may break Camino's built-in Flashblock.
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

Return to Camino


Who is online

Users browsing this forum: No registered users and 2 guests