MozillaZine

[Q] help with install rdf *SOLVED*

Discuss application theming and theme development.
error 13

User avatar
 
Posts: 3
Joined: October 4th, 2014, 7:59 am

Post Posted October 4th, 2014, 8:58 am

thease are all my files compiled https://www.dropbox.com/s/mdr6dmefma79av6/RedStar.jar?dl=0

so I'm new to themeing firefox and i want to create a new theme from the scratch so i packaged up my new theme with the default- browser ,global, and mozapps files from the .ja in the mozilla program files dir and wrote my own install.rdf and a chrome.manifest see the code for both below
Code: Select all
<?xml version="1.0"?>
<!-- This Source Code Form is subject to the terms of the Mozilla Public
   - License, v. 2.0. If a copy of the MPL was not distributed with this
   - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->


<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
     xmlns:em="http://www.mozilla.org/2004/em-rdf#">

  <Description about="urn:mozilla:install-manifest">
  <em:id>{06744550-4b69-11e4-916c-0800200c9a66}</em:id>
  <em:version>32.*</em:version>

<!-- Target Application this extension can install into,
         with minimum and maximum supported versions. -->

<em:targetApplication>
    <Description>
      <!-- Firefox's UUID -->
      <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
      <em:minVersion>32.*</em:minVersion>
      <em:maxVersion>32.*</em:maxVersion>
    </Description>
  </em:targetApplication>

  <!-- Front End MetaData -->
  <em:name>RedStar</em:name>
  <em:description>Nice Dark Theme for Firefox</em:description>
  <em:creator>H20s Red Star Brand #13</em:creator>
  <em:homepageURL>add-later-Themes_HomePage</em:homepageURL>
  <em:aboutURL>add-later-Url_of_About_Page </em:aboutURL>

  <!-- Allow lightweight themes to apply to this theme -->
    <em:skinnable>true</em:skinnable>
   
  <!-- Front End Integration Hooks (used by Theme Manager)-->
    <em:internalName>RedStar</em:internalName>
      <em:type>4</em:type>
        <em:unpack>true</em:unpack>
  </Description>

</RDF>

my chrome.manifest
Code: Select all
skin    browser         RedStar jar:chrome/RedStar.jar!/browser/
skin    global          RedStar jar:chrome/RedStar.jar!/global/
skin    mozapps         RedStar jar:chrome/RedStar.jar!/mozapps/


# Uncomment for development.
# skin    browser           RedStar file:///D:/MCD/dvl/moztheme/RedStar/unpacked/browser/
# skin    global            RedStar file:///D:/MCD/dvl/moztheme/RedStar/unpacked/global/
# skin    mozapps           RedStar file:///D:/MCD/dvl/moztheme/RedStar/unpacked/mozapps/


so mytheme.jar looks like this
Chrome-dir contains mytheme.jar with default- browser ,global and mozapps inside
chrome manifest
icon.png
install.rdf
i drop it in the addon window and it throws error: cant be installed because its not compatible with this version of ff
but it should be according to the install rdf i made i even tried swapping the chrome jar files with the files from the theme I'm running now and it still says same thing cant seem to figure out the problem heres a link to all the files i am using https://www.dropbox.com/s/mdr6dmefma79av6/RedStar.jar?dl=0 i need to have a default theme i can drag to install so i can start theming from scratch and have a installable theme when i am done. can someone help me figure out why i cant install this/ my theme all documentation is so out of date

working on firefox 32.03 in windows 7
Last edited by error 13 on October 6th, 2014, 6:08 am, edited 1 time in total.

mcdavis

User avatar
 
Posts: 3195
Joined: December 9th, 2005, 5:51 am

Post Posted October 4th, 2014, 8:16 pm

error 13 wrote:so I'm new to themeing firefox and i want to create a new theme from the scratch so i packaged up my new theme with the default- browser ,global, and mozapps files from the .ja in the mozilla program files dir and wrote my own install.rdf and a chrome.manifest see the code for both below


In install.rdf, I'm pretty sure you want 32.0 as the value for minVersion (and not 32.*, which you have now for that).

Also, it's generally considered better to use an id of the form extensionname@example.org, such as redstar@example.org, instead of the GUID form.

The parts of install.rdf are defined here: https://developer.mozilla.org/en-US/Add ... _Manifests
Theme Development is Radical Participation.
NNL Beta Builds for Current and Up-coming Firefox
Dear User: Your Help is Needed

error 13

User avatar
 
Posts: 3
Joined: October 4th, 2014, 7:59 am

Post Posted October 5th, 2014, 6:43 am

quote="mcdavis""In install.rdf, I'm pretty sure you want 32.0 as the value for minVersion (and not 32.*, which you have now for that)."
thats what i had at first 32.0 but changed it because its not a recognized version 32.* is from the mozilla firefox version page https://addons.mozilla.org/firefox/pages/appversions/ my theme passed mozilla submission validation seems like it should install wtf cant figure out why its throwing a non compatible error
validation screen shot Image

edit:
went through How Applications Determine Compatibility pages and everything seems good wish someone else would try to test/install this theme and see what happens. could be a problem with my FF program maybe idk really need some help on this one ???????

Frank Lion

User avatar
 
Posts: 19443
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted October 5th, 2014, 5:48 pm

Been a while since I've done a theme coded using this old 'conventional' method, but it's easy enough to fix. But, I'll tell you now, it'll be a lot of hard work to maintain using this method. Still, that's your choice.

For your version number, drop the * as it doesn't make sense and for your app min version use an alpha. I ignore most of what AMO documentation says, I know what works, they don't.

I always stick to the GUID format and not the @blah.com type as it makes the theme harder for users to find and fiddle with. Guess who they ask to fix it when they mess it up?

So...your install.rdf should look like this -

Code: Select all
<?xml version="1.0"?>
<!-- This Source Code Form is subject to the terms of the Mozilla Public
   - License, v. 2.0. If a copy of the MPL was not distributed with this
   - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->


<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
     xmlns:em="http://www.mozilla.org/2004/em-rdf#">

  <Description about="urn:mozilla:install-manifest">
  <em:id>{06744550-4b69-11e4-916c-0800200c9a66}</em:id>
  <em:version>32.0</em:version>

<!-- Target Application this extension can install into,
         with minimum and maximum supported versions. -->

<em:targetApplication>
    <Description>
      <!-- Firefox's UUID -->
      <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
      <em:minVersion>32.0a1</em:minVersion>
      <em:maxVersion>32.*</em:maxVersion>
    </Description>
  </em:targetApplication>

  <!-- Front End MetaData -->
  <em:name>RedStar</em:name>
  <em:description>Nice Dark Theme for Firefox</em:description>
  <em:creator>H20s Red Star Brand #13</em:creator>
  <em:homepageURL>add-later-Themes_HomePage</em:homepageURL>
  <em:aboutURL>add-later-Url_of_About_Page </em:aboutURL>

  <!-- Allow lightweight themes to apply to this theme -->
    <em:skinnable>true</em:skinnable>
   
  <!-- Front End Integration Hooks (used by Theme Manager)-->
    <em:internalName>RedStar</em:internalName>
      <em:type>4</em:type>
        <em:unpack>true</em:unpack>
  </Description>

</RDF>


Then code up line 20 of global/toolbar.css to look like this, so that you know that you're hitting your theme and not corrupting to the default or something -

Code: Select all
/* ::::: toolbar & menubar ::::: */

toolbar, menubar {
  -moz-appearance: none !important;
background: red !important;}


Then...you're good to go.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

error 13

User avatar
 
Posts: 3
Joined: October 4th, 2014, 7:59 am

Post Posted October 6th, 2014, 6:06 am

[quote="Frank Lion"]Been a while since I've done a theme coded using this old 'conventional' method, but it's easy enough to fix. But, I'll tell you now, it'll be a lot of hard work to maintain using this method. Still, that's your choice.

For your version number, drop the * as it doesn't make sense and for your app min version use an alpha. I ignore most of what AMO documentation says, I know what works, they don't.

I always stick to the GUID format and not the @blah.com type as it makes the theme harder for users to find and fiddle with. Guess who they ask to fix it when they mess it up?


SOLVED
thank you very much i got it to install with your edits i changed them one @ a time and line 21 was the problem i had <em:minVersion>32.*</em:minVersion> re-coded to: <em:minVersion>32.0a1</em:minVersion> and it installed fine funny how picky it was about the older version when i wasn't even trying to install to it. anyway cheers mate good work

Frank Lion

User avatar
 
Posts: 19443
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted October 9th, 2014, 9:54 am

error 13 wrote:SOLVED
thank you very much i got it to install with your edits i changed them one @ a time and line 21 was the problem i had <em:minVersion>32.*</em:minVersion> re-coded to: <em:minVersion>32.0a1</em:minVersion> and it installed fine funny how picky it was about the older version when i wasn't even trying to install to it. anyway cheers mate good work

No problem. Good luck with the rest of your theme, I look forward to seeing it.

Frank :)
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Return to Theme Development


Who is online

Users browsing this forum: No registered users and 1 guest