MozillaZine

Tabbed Browsing Extension problem

Talk about add-ons and extension development.
djst
Moderator

User avatar
 
Posts: 2826
Joined: November 5th, 2002, 1:34 am
Location: Sweden

Post Posted November 6th, 2002, 10:07 am

Neil Parks wrote:
MaGNuS_Z wrote:A question, where do you get the new tabbrowser extension? I downloaded the one from http://phoenixhelp.cjb.net/ and i still have this problem


Use the "homepage" option sted the "install click here".


Phoenix Help does link to the latest XPI. No need to go to the home page.

leoz

User avatar
 
Posts: 131
Joined: November 4th, 2002, 8:28 pm
Location: Boston, MA, USA

Post Posted November 6th, 2002, 10:18 am

djst wrote:
Neil Parks wrote:
MaGNuS_Z wrote:A question, where do you get the new tabbrowser extension? I downloaded the one from http://phoenixhelp.cjb.net/ and i still have this problem


Use the "homepage" option sted the "install click here".


Phoenix Help does link to the latest XPI. No need to go to the home page.


I, for one, always go to the home page. That way you know that a new version has been posted.
You also know what the changes were in the new version.

I am so hooked on TBE that I check it several times daily to see if there is a new version.
I should set it up to check automatically, but I am paranoid and afraid it wouldn't work :).

djst
Moderator

User avatar
 
Posts: 2826
Joined: November 5th, 2002, 1:34 am
Location: Sweden

Post Posted November 6th, 2002, 10:21 am

leoz wrote:I, for one, always go to the home page. That way you know that a new version has been posted.
You also know what the changes were in the new version.


Sure, that's what the Homepage link is for. :)

shoestring

User avatar
 
Posts: 156
Joined: November 5th, 2002, 3:40 pm
Location: Geekhaven, MA, USA

Post Posted November 17th, 2002, 11:01 pm

Very distressing, because this is such a <I>useful</I> extension, but ...

I had observed the following problem with Phoenix:

Using the Bookmark Manager, as is always my preference, I found that after you had once <I>gone to</I> a link (by double-clicking), any link you subsequently tried to <I>select</I> (by single-clicking) would instead be activated.

I finally submitted a bug report on this, only to find that some people couldn't replicate it.

It turns out that it only (apparently) happens when you are using the tabbed browser extension with the "Open any bookmark in new tab" option checked. Unfortunately, this is precisely what I want to happen, but of course only on a <B>double-</B>click.

The single-/double-click behavior seems to work correctly otherwise.
Bill Phillips
Sexagenarian Boy Genius
Geekhaven, Massachusetts

shoestring

User avatar
 
Posts: 156
Joined: November 5th, 2002, 3:40 pm
Location: Geekhaven, MA, USA

Post Posted November 18th, 2002, 4:57 am

Following up on myself ...

where does one report TBE bugs?
Bill Phillips
Sexagenarian Boy Genius
Geekhaven, Massachusetts

leoz

User avatar
 
Posts: 131
Joined: November 4th, 2002, 8:28 pm
Location: Boston, MA, USA

Post Posted November 18th, 2002, 5:27 am

shoestring wrote:Following up on myself ...

where does one report TBE bugs?


send email to the author (see the TBE home page for the email).

In my experience, Piro has been extremely good about fixing bugs.

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted November 18th, 2002, 6:35 pm

shoestring wrote:Following up on myself ...

where does one report TBE bugs?


TBE has moved to <a href="http://white.sakura.ne.jp/~piro/xul/_tabextensions.en.html">http://white.sakura.ne.jp/~piro/xul/_tabextensions.en.html</a>

Try the latest one before you submit a bug.

shoestring

User avatar
 
Posts: 156
Joined: November 5th, 2002, 3:40 pm
Location: Geekhaven, MA, USA

Post Posted November 19th, 2002, 9:11 am

leoz wrote:
shoestring wrote:Following up on myself ...

where does one report TBE bugs?


send email to the author (see the TBE home page for the email).

In my experience, Piro has been extremely good about fixing bugs.



Yes. I emailed Piro, and within 11 hours the bug was fixed.

Fantastic response!
Bill Phillips
Sexagenarian Boy Genius
Geekhaven, Massachusetts

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 3 guests