MozillaZine

Cant Upload Mozilla Addon

Talk about add-ons and extension development.
max1million
 
Posts: 2810
Joined: November 15th, 2004, 5:03 am

Post Posted October 28th, 2009, 4:42 am

prbably screwed the name
Code: Select all
<?xml version="1.0"?>
<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
    xmlns:em="http://www.mozilla.org/2004/em-rdf#">
  <Description about="urn:mozilla:install-manifest">

      <!-- extension info -->
      <em:id>orkutmanager@swarnava.com</em:id> <!-- guid of extension -->
      <em:name>Orkut Manager Plus</em:name>
      <em:version>3.0.0</em:version>
      <em:description>Manage orkut. You can quote messages, use the toolbar to format your text, use the quickreply button to reply fast on topics, use default colors and a signature for your posts, bookmark communities/topics, edit and create menus, manage communities/topics with an auto-update, accept multiple users on a community, remove ads, fix the layout and much more</em:description>
      <em:creator>Swarnava/Heaven GOD</em:creator>
      <em:contributor>Andre Steinn</em:contributor>
      <em:contributor>Bruno Leonardo Michels</em:contributor>
      <em:iconURL>chrome://orkutmanager/skin/orkutmanager.png</em:iconURL>
      <em:optionsURL>chrome://orkutmanager/content/options.xul</em:optionsURL>
      <em:type>2</em:type> <!-- type 2 = extension -->




      <!-- installs in -->
      <em:targetApplication>
      
               <!-- Firefox-->
               <Description>
                 <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id> <!-- guid of target application -->
                     <em:minVersion>3.5</em:minVersion>
                     <em:maxVersion>3.7.*</em:maxVersion>
               </Description>
      
      </em:targetApplication>



  </Description>
</RDF>

another_sam

User avatar
 
Posts: 22
Joined: August 15th, 2007, 9:46 pm

Post Posted November 19th, 2009, 5:32 am

I am getting this:



Oops! There seems to be a problem with this file...

The add-on failed a validation test: The following error occurred while parsing install.rdf: > required

Please correct this problem and upload your file again.



Why is it for? The add-on installs on my Firefox with no problem!

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 2 guests