MozillaZine


OLD NoScript 1.1.4, bookmarks and places friendly

Talk about add-ons and extension development.
manc39
Moderator
 
Posts: 2037
Joined: June 17th, 2004, 8:34 am
Location: Manchester, England

Post Posted June 19th, 2005, 2:30 am

How about an "Allow Javascript for the originating site only" feature?

Some sites have Javascript links and other things dependant on allowing Javascript- the temporary allow feature does the job nicely but an originating site only option would allow sites to function properly without their advertising/tracking scripts running, without any clicking and reloading of the page.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060712 BonEcho/2.0b1

Red Dragon

User avatar
 
Posts: 125
Joined: July 20th, 2004, 6:10 pm

Post Posted June 19th, 2005, 8:59 am

Giorgio Maone wrote:
Smartguy wrote:"There's a browser safer than Firefox...
...it is Firefox with NoScript!
NoScript - a Firefox extension for whitelist driven safe JavaScript execution"


Can I ask a dumb question? Does this mean I dont have to download Java?

Java is completely different than JavaScript: the only thing they have in common (other than some syntax) is that they both are means to execute programs from the web.

Generally speaking, you should avoid to execute anything coming from the Internet unless you trust it and you need it.

NoScript allows you to choose which JavaScript you trust, but doesn't affect Java (nor Flash, which is very similar from the forementioned POV).
Since Java content is far less widespread than JavaScript (which is actually almost everywhere), you may want not to download Java or to keep it disabled (Options|Web Features) until you need it (e.g. for your bank web site).

I'm planning to extend NoScript so that you can use the same user interface to selectively allow Java and Flash content, but it won't come today nor tomorrow...


Thanks! I was just wishing I could get away from Java, altogether, as it is prone to parasites. I occassionally have to 'uninstall it.

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted June 19th, 2005, 2:42 pm

lynchknot wrote:I receive many crashes when choosing "allow"

Please read FAQ 2.1.
In brief, try to change permissions only when there's no ongoing browser activity.

ARC-4919
 
Posts: 9
Joined: June 17th, 2005, 9:41 pm

Post Posted June 19th, 2005, 8:40 pm

Giorgio,

Have you checked the website I provided you with
that does not run Javascripts with NoScript whitelist?
https://email.secureserver.net/login.ph ... hvideo.org

Also, any ideas about my Linksys router's setup page/log not running
scripts with NoScript?

Thanks ... please advise :)

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted June 20th, 2005, 3:32 am

ARC-4919 wrote:Giorgio,

Have you checked the website I provided you with
that does not run Javascripts with NoScript whitelist?
https://email.secureserver.net/login.ph ... hvideo.org

Also, any ideas about my Linksys router's setup page/log not running
scripts with NoScript?

Thanks ... please advise :)

Yes, I checked it, and it apparently works for me (at least to the extent I'm allowed to test).
When I try to login with JS forbidden, authentication page goes blank.
When I allow secureserver.net from the contextual menu, it says "Authentication Failed. Please Try Again" in red.
All the links on the page don't work when JS is forbidden, work if i "Allow secureserver.net".
I can't test furthermore, simply because I've no techvideo.org mail account ;)
You want me to go on in this test, you should provide me such an account.
Before doing that, you may want also to manually allow "techvideo.org".

Good luck and let me know :)

ARC-4919
 
Posts: 9
Joined: June 17th, 2005, 9:41 pm

Post Posted June 20th, 2005, 9:45 am

"Giorgio Maone" wrote:
:: When I try to login with JS forbidden, authentication page goes blank.

Yes, that's what I get when I use NoScripts with scripting enabled for
that website. If I enable Firefox scripting globally, then all works perfectly.

:: You want me to go on in this test, you should provide me such an account.

I shall prepare this.

Thanks :)

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted June 20th, 2005, 10:01 am

ARC-4919 wrote:"Giorgio Maone" wrote:
:: When I try to login with JS forbidden, authentication page goes blank.

Yes, that's what I get when I use NoScripts with scripting enabled for
that website. If I enable Firefox scripting globally, then all works perfectly.

It's too strange, works for me and doesn't for you apparently under the same conditions.

Can you send me (Private Message) a copy of your "prefs.js" file (you will find it in your profile directory) as it is after you allow 192.168.1.1 and secureserver.net (I'm mostly interested in the noscript.* and capability.* entries).

Thank you very much

therube

User avatar
 
Posts: 20636
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 20th, 2005, 11:22 am

If you were running through a proxy, that may have some affect?
But if so, I would not think you could log into your router at all.
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

lynchknot
 
Posts: 6253
Joined: November 4th, 2002, 7:36 pm

Post Posted June 20th, 2005, 1:53 pm

Giorgio Maone wrote:
lynchknot wrote:I receive many crashes when choosing "allow"

Please read FAQ 2.1.
In brief, try to change permissions only when there's no ongoing browser activity.
Yes, I see and thank you. It's still too easy to inadvertently change permissions when I have 23 important tabs open during a research project of mine. I have to start over now - temporarily disabling NoScript. Unfortunately it does not just crash that one tab that is the source. * edit - just disabling NoScript caused Firefox to crash.

zmartha

User avatar
 
Posts: 148
Joined: September 13th, 2004, 2:00 pm

Post Posted June 20th, 2005, 3:38 pm

FF shuts down when I click Allow ______ or Temporarily Allow __________. It usually doesn't go down if it is the only Tab open--95%. I still like it. :) and I can wait for the improvements. Keep up the good work.
In His name,
zmartha
Using WinXP SP3 FF newest version

ARC-4919
 
Posts: 9
Joined: June 17th, 2005, 9:41 pm

Post Posted June 20th, 2005, 4:31 pm

"Giorgio Maone" wrote

: Can you send me (Private Message) a copy of your "prefs.js" file
: (you will find it in you profile directory) as it is after you allow
: 192.168.1.1 and secureserver.net (I'm mostly interested in the
: noscript.* and capability.* entries).

Confused ... it appears to be *empty* ... (viewed in plain text, below)


===================================================

# Mozilla User Preferences

/* Do not edit this file.
*
* If you make changes to this file while the browser is running,
* the changes will be overwritten when the browser exits.
*
* To make a manual change to preferences, you can visit the URL about:config
* For more information, see http://www.mozilla.org/unix/customizing.html#prefs
*/
=====================================================

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted June 21st, 2005, 12:11 am

ARC-4919 wrote:"Giorgio Maone" wrote

: Can you send me (Private Message) a copy of your "prefs.js" file
: (you will find it in you profile directory) as it is after you allow
: 192.168.1.1 and secureserver.net (I'm mostly interested in the
: noscript.* and capability.* entries).

Confused ... it appears to be *empty* ... (viewed in plain text, below)

It smells of bad permissions... :-k
Are you running Firefox using an unprivileged user and a browser profile which was not created by/for this user?
Please check if user you run Firefox with has write permissions on prefs.js.
Apparently Firefox is not able to write preferences back when they are changed... definitely not a normal situation :(

mcmeeuwis
 
Posts: 1
Joined: June 21st, 2005, 1:54 am

Post Posted June 21st, 2005, 2:23 am

Hi,

I searched the noscript options for this but haven't seen where to set what I want: I would like to only see the bar when script is forbidden (so the 'JavaScript Currently Forbidden' bar), and not to be bothered with a bar when script is allowed, even partially. Is it possible to set the options this way?

Thanks

Mike

Giorgio Maone

User avatar
 
Posts: 3516
Joined: September 21st, 2004, 12:05 am
Location: Palermo - Italy

Post Posted June 21st, 2005, 3:09 am

mcmeeuwis wrote:I searched the noscript options for this but haven't seen where to set what I want: I would like to only see the bar when script is forbidden (so the 'JavaScript Currently Forbidden' bar), and not to be bothered with a bar when script is allowed, even partially. Is it possible to set the options this way?

Not at this moment.
Currently you can either:
  • Completely hide the notify bar (you can still watch status through the status bar icon)
  • Enable the notify bar, which will be shown whenever JavaScript is disabled (even partially) on a page.

I believe the latter is the smartest default, since many people who installed early versions of NoScript reported "not working pages" dued to JavaScript forbidden in a subframe: better let them know about <i>every</i> blocked script ;)

Nevertheless, your suggestion is very valuable as an additional option for advanced users ("Show message about partially allowed scripts"?).

Anysia

User avatar
 
Posts: 149
Joined: July 22nd, 2004, 6:45 pm

Post Posted June 21st, 2005, 3:49 am

I really do like the idea behind NoScript, but it has a habit of crashing FF if more than one javascript is disabled/enabled on a single webpage. Also, everytime I tried to enable "Overture.com" (needed tech support from Sonic) it would crash FF everytime. I have been sending the talk backs to Mozilla, and hopefully this information is passed along to you.

I have installed the latest version in hopes it will help

FF 1.04, WinXP, 512meg Ram, 2.8ghz.
Never argue with idiots. They will drag you down to their level, then beat you with their experience.

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 3 guests