MozillaZine

Post the extensions you want compatible with SeaMonkey

Talk about add-ons and extension development.
baldyeti

User avatar
 
Posts: 43
Joined: September 1st, 2003, 10:11 am

Post Posted August 18th, 2010, 2:05 pm


Thanks again Tony, I now have 1.0b1 running with SM2.06 under ubuntu 10.04 and Win7.

_development
 
Posts: 332
Joined: October 19th, 2007, 9:29 am
Location: Montevideo, Uruguay

Post Posted August 21st, 2010, 9:42 am

Question, Tree Style Tab on SeaMonkey, how difficult can be that?
I know TST is complex with lots of hacking, but with lots of stripping maybe there is a chance? Something similar? I fell stuck with firefox just because of the extensions.

Straightshooter2
 
Posts: 7
Joined: October 19th, 2006, 6:40 pm

Post Posted August 26th, 2010, 9:03 am

XMarks? I'm STUNNED Seamonkey and XMarks are not compatible...
Will they ever be?

ElTxolo

User avatar
 
Posts: 2532
Joined: July 30th, 2007, 9:35 am
Location: Localhost

Post Posted August 26th, 2010, 9:32 am

Straightshooter2 wrote:XMarks? I'm STUNNED Seamonkey and XMarks are not compatible...
Will they ever be?

You could use Firefox Sync 1.4.4 (Works with: SeaMonkey 2.0a3 - 2.1a2)
How to Ask Questions The Smart Way - How to Report Bugs Effectively ;)
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20200426 SeaMonkey/2.53.2
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20200529 SeaMonkey/2.53.4

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted August 26th, 2010, 10:48 am

ElTxolo wrote:
Straightshooter2 wrote:XMarks? I'm STUNNED Seamonkey and XMarks are not compatible...
Will they ever be?

You could use Firefox Sync 1.4.4 (Works with: SeaMonkey 2.0a3 - 2.1a2)

But Weave Sync won't sync bookmarks until SeaMonkey 2.1a3. Because that's where we switched to using the Firefox bookmarks system.

Phil

eagleheart
 
Posts: 7
Joined: April 26th, 2003, 1:34 am

Post Posted September 5th, 2010, 2:48 am

Any chance to get CookieSafe (https://addons.mozilla.org/de/firefox/addon/2497/) working with recent trunk builds?
It stopped working sometimes after SeaMonkey 2.1a. It does not work in Firefox trunk also. So it seems it is affected by some changes in Toolkit.

eagleheart
 
Posts: 7
Joined: April 26th, 2003, 1:34 am

Post Posted September 5th, 2010, 7:12 am

eagleheart wrote:It stopped working sometimes after SeaMonkey 2.1a. It does not work in Firefox trunk also. So it seems it is affected by some changes in Toolkit.


Just wanted to add that I searched the web but did not find any hint from the addon author.

casper1975
 
Posts: 402
Joined: November 26th, 2006, 10:54 am
Location: Australia

Post Posted September 6th, 2010, 7:19 pm

Could you please make MyTube preference & Default Full Zoom available for SM 2.1.

Sheepeeshaun
 
Posts: 3
Joined: October 24th, 2009, 9:09 pm

Post Posted September 7th, 2010, 2:20 am

4chan Firefox Extension
http://4chan.wrathfilledhate.net/
http://4chan.wrathfilledhate.net/menu/4chan.v0.4.5.12.xpi

It worked in 2.0.6 (just needed to change the version in the install.rdf) but now gives this error when starting Seamonkey 2.1a3:

Code: Select all
TypeError: Components.classes['@4chan.wrathfilledhate.net/menu/manager-object;1'] is undefined


Also gives errors when I try to use it's options dialogue interface.

Some help making it work in 2.1a3 please?

arifsaha
 
Posts: 14
Joined: January 19th, 2005, 8:33 pm
Location: Edmonton, AB

Post Posted September 10th, 2010, 9:46 pm

How about Tab Kit?

xed

User avatar
 
Posts: 669
Joined: February 11th, 2007, 12:04 pm

Post Posted September 16th, 2010, 11:18 am

Tab Clicking Options is a pretty nice extension that works with SeaMonkey. I've had it installed quite a while and each time SeaMonkey is updated I have to use Mr Tech Toolkit to re-enable compatibility, but it's almost a replacement for Tab Mix Plus's functions that I use in Firefox.
"Doin' right ain't got no end." Cap'n Red Legs

tonymec

User avatar
 
Posts: 731
Joined: October 15th, 2004, 2:58 am
Location: Ixelles (Brussels Capital Region, Belgium)

Post Posted September 16th, 2010, 5:13 pm

xed wrote:Tab Clicking Options is a pretty nice extension that works with SeaMonkey. I've had it installed quite a while and each time SeaMonkey is updated I have to use Mr Tech Toolkit to re-enable compatibility, but it's almost a replacement for Tab Mix Plus's functions that I use in Firefox.

The capability I missed most from TMP was the "flowing tabs" option (add a second, third, etc. row of tabs if one row isn't enough)… until I succeeded to implement it via userChrome.css. Otherwise, I use the Duplicate Tab extension (mentioned on that extension's page) and the Tabs Menu extension (which isn't) while Undo Close Tab's capability is included in plain-vanilla SeaMonkey.
Best regards,
Tony

EvanD
 
Posts: 8
Joined: November 5th, 2009, 4:14 pm

Post Posted September 19th, 2010, 11:00 am

xed wrote:Tab Clicking Options is a pretty nice extension that works with SeaMonkey. I've had it installed quite a while and each time SeaMonkey is updated I have to use Mr Tech Toolkit to re-enable compatibility, but it's almost a replacement for Tab Mix Plus's functions that I use in Firefox.


@Phil Chee

Do you plan to make Tab Clicking Options compatible with Seamonkey 2? It may be our best tab options extension since TMP can't be modified.

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted September 19th, 2010, 11:16 am

EvanD wrote:
xed wrote:Tab Clicking Options is a pretty nice extension that works with SeaMonkey. I've had it installed quite a while and each time SeaMonkey is updated I have to use Mr Tech Toolkit to re-enable compatibility, but it's almost a replacement for Tab Mix Plus's functions that I use in Firefox.


@Phil Chee

Do you plan to make Tab Clicking Options compatible with Seamonkey 2? It may be our best tab options extension since TMP can't be modified.

Hmm. Try pinging the author first since it's just bumping up the maxVersion in the compatibility metadata. Let me know if this doesn't work. The Nightly Tester Tools extension can also disable compatibility checking in SeaMonkey 2.0.

Phil

EvanD
 
Posts: 8
Joined: November 5th, 2009, 4:14 pm

Post Posted September 19th, 2010, 2:30 pm

Philip Chee wrote:Hmm. Try pinging the author first since it's just bumping up the maxVersion in the compatibility metadata. Let me know if this doesn't work. The Nightly Tester Tools extension can also disable compatibility checking in SeaMonkey 2.0.

Phil


I bumped-up the maxVersion to 2.1 in install.rdf and the xpi appears to install and asks for a Restart. After the latter, TCO hasn't installed so I thought a modification to the install.js file might be required. If the problem is unique to me, I'll try to learn Mr. Tech Toolkit or I'll drop it.

The author hasn't updated TCO since SM 2.0a1 and FF3.0 so I doubt he's still around. ( http://twanno.mozdev.org/ ) It's only the mention of TCO working on SM 2.0.8 in this forum that piqued my interest.

Thanks for everything you've done over the years for Seamonkey.

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 1 guest