MozillaZine

Post the extensions you want compatible with SeaMonkey

Talk about add-ons and extension development.
Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted September 19th, 2010, 9:34 pm

EvanD wrote:I bumped-up the maxVersion to 2.1 in install.rdf and the xpi appears to install and asks for a Restart. After the latter, TCO hasn't installed so I thought a modification to the install.js file might be required. If the problem is unique to me, I'll try to learn Mr. Tech Toolkit or I'll drop it.

Ah install.js is needed only for SeaMonkey 1.0 and 1.1. Not too sure if TCO will work 100% in SeaMonkey 2.1 since we've done a lot of changes to the SeaMonkey tabbrowser recently - mostly making it support as much of the Firefox API as possible. TCO should work fine with any version of SeaMonkey 2.0.x though.
EvanD wrote:The author hasn't updated TCO since SM 2.0a1 and FF3.0 so I doubt he's still around. ( http://twanno.mozdev.org/ ) It's only the mention of TCO working on SM 2.0.8 in this forum that piqued my interest.

Thanks for everything you've done over the years for Seamonkey.

In my notes somewhere I have:

Not too sure if this link is still valid.

Phil

EvanD
 
Posts: 8
Joined: November 5th, 2009, 4:14 pm

Post Posted September 20th, 2010, 11:13 am

Philip Chee wrote:

Not too sure if this link is still valid.

Phil


The links are valid and the TCO xpi had a maxVersion of 2.1 and it installed properly on SM 2.0.8. (Perhaps you should include this extension on your "modifiedmisc.html" site.)

Thanks for your help.

D555

User avatar
 
Posts: 152
Joined: August 17th, 2005, 9:52 pm

Post Posted October 17th, 2010, 6:30 pm

There is one extension that very important imho , it's GCE Manager.
I tried to make it compatible, but no results ((( It seems It has problems with registering its new protocol gchrome:// ...
I hope to see it workable on SeaMonkey2.1x ...
Many thanks in advance.

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted October 17th, 2010, 9:54 pm

D555 wrote:There is one extension that very important imho , it's GCE Manager.
I tried to make it compatible, but no results ((( It seems It has problems with registering its new protocol gchrome:// ...
I hope to see it workable on SeaMonkey2.1x ...
Many thanks in advance.

Not surprising since it isn't compatible with Firefox 4.0b8 either.
Last bunch of checkins were 7 months ago. http://bitbucket.org/matoeil/gce/.
Report issues here https://bitbucket.org/matoeil/gce/issues

I'll probably work in SM 2.0 if you overlay things correctly. https://developer.mozilla.org/en/Extensions_support_in_SeaMonkey_2

Phil

D555

User avatar
 
Posts: 152
Joined: August 17th, 2005, 9:52 pm

Post Posted October 18th, 2010, 5:34 am

Thank you , I'll try !
Is a really huge difference in API between gecko 2 and 1.91 ?
I really hoped that there is may be a tweak to force GCE Manager work either on SM2.1 ... (((
This extension mean much for me because this one is Extension of extensions ... And there are a lot very interesting stuffs ...

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted October 18th, 2010, 5:39 am

D555 wrote:Thank you , I'll try !
Is a really huge difference in API between gecko 2 and 1.91 ?

Huge is an understatement. But looking at the reviews a lot of Chrome extensions don't work even in Firefox 3.6.

Phil

D555

User avatar
 
Posts: 152
Joined: August 17th, 2005, 9:52 pm

Post Posted October 18th, 2010, 6:02 am

those ones are taken specific chrome navigation ... they're not needed at all))), but there are others very interesting things ..., I'd say are like widgets ... and they are pretty interesting and even have a great style ...

xion87
 
Posts: 12
Joined: October 21st, 2010, 3:34 am

Post Posted October 21st, 2010, 1:15 pm

Youtube video downloader https://addons.mozilla.org/it/firefox/addon/10137/ can you convert it for seamonkey? ç_ç thank!

xion87
 
Posts: 12
Joined: October 21st, 2010, 3:34 am

Post Posted October 27th, 2010, 6:08 am

up! ç_ç

xion87
 
Posts: 12
Joined: October 21st, 2010, 3:34 am

Post Posted October 29th, 2010, 9:51 am

BUMP!

therube

User avatar
 
Posts: 20550
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 29th, 2010, 4:18 pm

May as well sit tight. He's been away & when he gets back he'll have plenty on his plate.
Then comes the part that it may or may not be feasible to do.
Licensing comes into play. (Hint, if it is not open source or similar, won't happen. Hint #2, post back the licensing info on it.)

Maybe this will work as an alternative, Video DownloadHelper.
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted October 30th, 2010, 1:52 am

therube wrote:May as well sit tight. He's been away & when he gets back he'll have plenty on his plate.
Then comes the part that it may or may not be feasible to do.
Licensing comes into play. (Hint, if it is not open source or similar, won't happen. Hint #2, post back the licensing info on it.)

Maybe this will work as an alternative, Video DownloadHelper.

The latest version or perhaps a slightly older version should work in SeaMonkey 2.0 out of the box:
Video DownloadHelper 4.8.1

I'm currently in Glasgow, Scotland visiting family. I'll be back on Monday but will probably take a couple of weeks to dig myself out of the backlog that has accumulated since I left for Vienna.

Phil

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted November 9th, 2010, 3:36 am

eagleheart wrote:Any chance to get CookieSafe (https://addons.mozilla.org/de/firefox/addon/2497/) working with recent trunk builds?
It stopped working sometimes after SeaMonkey 2.1a. It does not work in Firefox trunk also. So it seems it is affected by some changes in Toolkit.

If it doesn't work with Firefox trunk then it is unlikely to work with SeaMonkey 2.1b.

Aha! It was the component registration changes that broke Cookie Safe:
https://developer.mozilla.org/en/XPCOM/XPCOM_changes_in_Gecko_2.0#Component_registration

Looks like a fair bit of rewriting is involved. Mostly mechanical but I don't have time to do this.

Phil

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted November 9th, 2010, 3:38 am

casper1975 wrote:Could you please make MyTube preference & Default Full Zoom available for SM 2.1.

Have you tried contacting the authors? These days making extensions compatible with SeaMonkey is much simpler. You could point them to:
https://developer.mozilla.org/en/Extensions_support_in_SeaMonkey_2

Phil

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted November 9th, 2010, 3:40 am

Sheepeeshaun wrote:4chan Firefox Extension
http://4chan.wrathfilledhate.net/
http://4chan.wrathfilledhate.net/menu/4chan.v0.4.5.12.xpi

It worked in 2.0.6 (just needed to change the version in the install.rdf) but now gives this error when starting Seamonkey 2.1a3:

Code: Select all
TypeError: Components.classes['@4chan.wrathfilledhate.net/menu/manager-object;1'] is undefined


Also gives errors when I try to use it's options dialogue interface.

Some help making it work in 2.1a3 please?

1. See http://forums.mozillazine.org/viewtopic.php?p=10105907#p10105907 for what changes need to be made.
2. And I try to stay as far away from 4chan as possible so I can't really test this extension can I?

Phil

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 1 guest