MozillaZine

Firefox 3: "Failed to load XPCOM component" [solved]

Talk about add-ons and extension development.
Ricky
 
Posts: 35
Joined: December 11th, 2002, 1:57 am

Post Posted August 7th, 2008, 8:36 pm

Hi all,

I have an extension which works fine in Firefox 2, but but the XPCOM component will not load under Firefox 3 in Linux. It does load successfully on Firefox 3 in Windows, so it must be some sort of build problem. (It's being built on ubuntu server v 8.04.) Unfortunately, I can't seem to coax any more information out of Firefox than "Failed to load XPCOM component: [path to .so file]." I've tried building it against both the Firefox 2 tree and the Firefox 3 tree. (When I build against FF3, it stops working in FF2.) I was wondering if anyone could point me to documentation or suggest how I can go about debugging and isolating the problem. I've scoured the internets, but nothing useful is popping up.

I realize this is kind of vaguely worded; if I knew the right question to ask, I'd probably have an answer by now. :) I'd be happy to provide any additional details that might be helpful (maybe CPP/LDFLAGS?). Anything that will get me closer to a solution would be greatly appreciated.

Thanks,
Ricky ](*,)
Last edited by Ricky on August 8th, 2008, 11:41 am, edited 1 time in total.

Ricky
 
Posts: 35
Joined: December 11th, 2002, 1:57 am

Post Posted August 8th, 2008, 11:41 am

Thanks to http://developer.mozilla.org/en/docs/Tr ... ific_hints and viewtopic.php?f=27&t=770085 (which I wasn't able to find when searching the forums before), I figured it out. Annoyingly enough (but also a bit of a relief), all I had to do was move the LDFLAGS to the end of my g++ command to fix a raft of unresolved symbols. The most time consuming problems often have the simplest solutions...

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 1 guest