MozillaZine

Fixes for extensions broken since new addon manager landed

Discussion about official Mozilla Firefox builds
GTK66
 
Posts: 1896
Joined: May 30th, 2004, 5:20 am

Post Posted August 15th, 2010, 6:06 pm

sipowicz wrote:
peeppeep wrote:I have several errors with Adblock Plus and it happens frequently that replies to blogs are not submitted. Sometimes I get an error about the failure, but not always. So the "fix" has not entirely cured the problem.

The temporary fix does solve the problem. Without it ABP can't be used. The errors are there but ABP functions. If you do not want to see the errors, remove ABP completely and put up with the ads.


A new Dev Release was done today and it brings back the problem. I would advise against using it.

Elen
 
Posts: 394
Joined: February 13th, 2004, 5:53 am

Post Posted August 15th, 2010, 10:36 pm

sipowicz wrote:
sipowicz wrote:
peeppeep wrote:I have several errors with Adblock Plus and it happens frequently that replies to blogs are not submitted. Sometimes I get an error about the failure, but not always. So the "fix" has not entirely cured the problem.

The temporary fix does solve the problem. Without it ABP can't be used. The errors are there but ABP functions. If you do not want to see the errors, remove ABP completely and put up with the ads.


A new Dev Release was done today and it brings back the problem. I would advise against using it.


You just need to reapply the workaround, the new version just overwrites the file during install.

fuxxi
 
Posts: 128
Joined: November 8th, 2004, 10:30 am

Post Posted August 15th, 2010, 10:52 pm

Thanks Brummelchen!

Terepin

User avatar
 
Posts: 1081
Joined: March 11th, 2009, 2:35 am
Location: Košice, Slovakia

Post Posted August 16th, 2010, 3:55 am

Just tried new dev build of ABP. What it was suppose to fix?
Hope dies penultimate. What remains till the end is sarcasm. And I have plenty of it.

rob64rock

User avatar
 
Posts: 2122
Joined: November 11th, 2009, 6:16 am

Post Posted August 16th, 2010, 5:16 am

Mr.Henky wrote:Just tried new dev build of ABP. What it was suppose to fix?


The lastest dev build adblockplus-1.3a.20100816 was supposed to fixed the 302 errors and redirects on Firefox 4.0b4pre I thought, but also breaks WebMail Notifer 2.5.5 extension which works if adblockplus-1.3a.20100816 is disabled.(Note: Using both extensions versions I mentioned above work on Firefox 3.6.8 with no problems.)

From link given by Alex: Bug 23092 "Mozilla's Bug 546606 - Make redirect API async breaks Adblock Plus".

YourProfilePath\extensions\{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}\modules\ContentPolicy.jsm
in line 395
under

// nsIChannelEventSink interface implementation

add this

asyncOnChannelRedirect: function(oldChan, newChan, flags, redirectCallback) {
this.onChannelRedirect(oldChan, newChan, flags);
redirectCallback.onRedirectVerifyCallback(0);
},

so it looks like

// nsIChannelEventSink interface implementation
//
asyncOnChannelRedirect: function(oldChan, newChan, flags, redirectCallback) {
this.onChannelRedirect(oldChan, newChan, flags);
redirectCallback.onRedirectVerifyCallback(0);
},
onChannelRedirect: function(oldChannel, newChannel, flags)
{

that should fix the move problems with ABP :)

This suggestion DID fix ABP for me (using the 1.3a.20100726 build), but without breaking WebMail Notifier 2.5.5.

Until the extension incompatibility is fixed with WebMail Notifer 2.5.5 and ABP on Firefox 4.0b4pre, I will suggest using the Mod version of ABP 1.3a20100726 build or reapply the fix suggested by Alex mentioned above to ABP 1.3a.20100816.

GTK66
 
Posts: 1896
Joined: May 30th, 2004, 5:20 am

Post Posted August 16th, 2010, 5:59 am

The build [1.3a.20100726] did not fix the redirects or 302 errors. The Fix above^ does. Using :

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100816 Minefield/4.0b4pre

rob64rock

User avatar
 
Posts: 2122
Joined: November 11th, 2009, 6:16 am

Post Posted August 16th, 2010, 6:03 am

sipowicz wrote:The build [1.3a.20100726] did not fix the redirects or 302 errors. The Fix above^ does. Using :

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100816 Minefield/4.0b4pre


I'm reading deja vu, I just stated that in the post prior to yours. ](*,)

GTK66
 
Posts: 1896
Joined: May 30th, 2004, 5:20 am

Post Posted August 16th, 2010, 6:45 am

rob64rock wrote:
sipowicz wrote:The build [1.3a.20100726] did not fix the redirects or 302 errors. The Fix above^ does. Using :

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100816 Minefield/4.0b4pre


I'm reading deja vu, I just stated that in the post prior to yours. ](*,)


I did not see your post at the time. Oh and at the ABP forum I would use the ABP Mod if it was in English. ](*,)

PS: You mentioned in your post that it works in Fx 3.6.8. I am not using that.
Last edited by GTK66 on August 16th, 2010, 6:48 am, edited 1 time in total.

GTK66
 
Posts: 1896
Joined: May 30th, 2004, 5:20 am

Post Posted August 16th, 2010, 6:46 am

Mr.Henky wrote:Just tried new dev build of ABP. What it was suppose to fix?


It did not fix anything. But the bug was closed.

mxyztplk
 
Posts: 4
Joined: May 13th, 2006, 11:21 am

Post Posted August 16th, 2010, 11:38 am

PlainOldFavorites 1.1 Beta is a dev release that works for me in Firefox 4.0b3. It can be downloaded from the developer's site at:
http://www.iosart.com/firefox/plainoldfavorites/

(The stable version, 1.0.3, does not have the XPCOM fixes and therefore does not work for me on Firefox 4.0b2 and later.)

mxyztplk
 
Posts: 4
Joined: May 13th, 2006, 11:21 am

Post Posted August 16th, 2010, 11:41 am

PlainOldFavorites 1.1 Beta is a dev release that works for me in Firefox 4.0b3. It can be downloaded from the developer's site at:
http://www.iosart.com/firefox/plainoldfavorites/

(The old, stable version, 1.0.3, does not have the XPCOM fixes.)

ltsnow

User avatar
 
Posts: 1107
Joined: March 23rd, 2006, 1:49 pm
Location: Valdosta, GA

Post Posted August 16th, 2010, 5:50 pm

APB is now fixed with the newest 8/17 build.

https://adblockplus.org/devbuilds/adblockplus/

avada
 
Posts: 1831
Joined: February 10th, 2008, 6:30 am
Location: Hungary

Post Posted August 20th, 2010, 10:09 am

Hi!
Does anyone know what causes this? Its a button with garbage that does nothing.
Image

Something else. Is it just me or the l10n nightlies really can't update themselves?

_Dexter_

User avatar
 
Posts: 1436
Joined: August 30th, 2008, 6:54 pm
Location: Miami

Post Posted August 24th, 2010, 6:58 pm

Intel i7 Core Quad @ 4.25Ghz | Cooler Master Hyper 212 Plus | 12GB PC3-16000 RAM | ASUS HD6970 2GB - 12.3 CATS | ASUS PA246Q IPS 24" LCD 16:10 | OCZ AGILITY-EX SSD SLC | Windows 7 SP1 x64 Ultimate

Virtual_ManPL

User avatar
 
Posts: 1982
Joined: July 24th, 2008, 5:52 am

Post Posted August 26th, 2010, 5:46 am

Someone know how to fix Fierr addon ?

Because I get this error for about 1-2 days, probably some patch landed and broke this addon in Firefox 4 nightlys
XML Parsing Error:
Location: file:///C:/Documents%20and%20Settings/Virtual_ManPL/Dane%20aplikacji/Mozilla/Firefox/Profiles/rzdx1st3.default/extensions/{2E481B23-66AC-313F-D6A8-A81DDDF26249}/chrome/content/netError.xhtml
Line Number 429, Column 136: <xul:hbox xmlns:xul="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul" align="center" style="-moz-margin-start: 80px;">
---------------------------------------------------------------------------------------------------------------------------------------^

Return to Firefox Builds


Who is online

Users browsing this forum: Google [Bot] and 4 guests