MozillaZine

Will they ever fix font rendering in firefox 4?

Discussion about official Mozilla Firefox builds
WonderCsabo
 
Posts: 2230
Joined: June 25th, 2010, 9:29 am
Location: Budapest, Hungary

Post Posted June 28th, 2011, 3:11 pm

Some screenshots for compare:

Image Fx7 before
Image Fx 7 after
Image Fx5 before
Image Fx5 after

code65536

User avatar
 
Posts: 57
Joined: October 17th, 2004, 7:01 pm
Location: .us

Post Posted June 28th, 2011, 7:00 pm

KB2545698 only changes the apparent weight (perhaps by tweaking gamma/contrast) (but not the hinting/spacing) of Tahoma, Verdana, and Arial. This is NOT a change to DirectWrite: this is a change to the fonts themselves, and will thus affect all programs that use natural rendering with those fonts. Since all three of those fonts are on the Firefox 7 GDI fallback list, there will be no effect on Firefox 7 under default settings. On older Firefoxen, KB2545698 will affect these three fonts under default settings, but nothing else.

Fanolian
 
Posts: 878
Joined: February 21st, 2011, 10:14 am

Post Posted June 28th, 2011, 9:37 pm

KB2545698 greatly improves my browsing experience.
I have to use Natural_symmetric in Nightly due to some CJK font issues. After the update I can have GDI-like effect on those 3 font families, and thankfully most sites use Arial as the default font.

P.S. GDI fallback is not in effect if gfx.font_rendering.cleartype_params.rendering_mode is not -1.

WonderCsabo
 
Posts: 2230
Joined: June 25th, 2010, 9:29 am
Location: Budapest, Hungary

Post Posted June 29th, 2011, 3:39 am

code65536 wrote:KB2545698 only changes the apparent weight (perhaps by tweaking gamma/contrast) (but not the hinting/spacing) of Tahoma, Verdana, and Arial. This is NOT a change to DirectWrite: this is a change to the fonts themselves, and will thus affect all programs that use natural rendering with those fonts. Since all three of those fonts are on the Firefox 7 GDI fallback list, there will be no effect on Firefox 7 under default settings. On older Firefoxen, KB2545698 will affect these three fonts under default settings, but nothing else.


Thanks for correcting, after reading the KB and testing, i came up with the same conclusion. Thanks again!

watdis
 
Posts: 21
Joined: March 12th, 2011, 11:50 am

Post Posted June 29th, 2011, 4:37 pm

So can anyone help me with my issue?

watdis wrote:Does anyone else have blackwhite antialias in firefox menu and context menus? I tried a new profile in safemode, same thing. This issue is pretty old (appeard on 7.0 though), I just thought someone broke it and would get fixed eventually, since it was fine before.

psishock
 
Posts: 150
Joined: February 9th, 2011, 5:11 am

Post Posted June 29th, 2011, 5:11 pm

watdis wrote:So can anyone help me with my issue?


that is most likely windows or graphic driver issue, not Firefox related. Especially now that you've tried with new profile, and experienced the exact same, while other users don't have this problem.

Perhaps you can check native cleartype/fontsmoothing settings in windows, and/or install another (newer?) graphic driver.

watdis
 
Posts: 21
Joined: March 12th, 2011, 11:50 am

Post Posted June 29th, 2011, 6:01 pm

That's the problem, I tried new nVidia driver, (275.33/50) and I didn't change cleartype settings. I did ran it again just to be sure, but it didn't make a difference. I sense this is something stupid simple I'm missing.

wmarcello
 
Posts: 262
Joined: December 13th, 2003, 7:30 am
Location: NB, Canada

Post Posted June 30th, 2011, 7:32 pm

Can somebody explain to me why the font rendering in my current Aurora and Nightly builds (2011-06-30) look so different on certain sites? I think the Aurora rendering has only changed in the past few days. This is all with HA enabled. Here are a couple screenshots from TSN.

Aurora
Nightly

watdis
 
Posts: 21
Joined: March 12th, 2011, 11:50 am

Post Posted June 30th, 2011, 9:03 pm

wmarcello wrote:Can somebody explain to me why the font rendering in my current Aurora and Nightly builds (2011-06-30) look so different on certain sites? I think the Aurora rendering has only changed in the past few days. This is all with HA enabled. Here are a couple screenshots from TSN.

Aurora
Nightly


Nightly falls back to GDI for some fonts and font sizes, and it seems Aurora doesn't. Also KB2545698 could add to this issue.

WonderCsabo
 
Posts: 2230
Joined: June 25th, 2010, 9:29 am
Location: Budapest, Hungary

Post Posted July 1st, 2011, 1:14 am

BTW, it falls back to DW with whole pixel (GDI Classic) rendering, not really the old GDI.

watdis
 
Posts: 21
Joined: March 12th, 2011, 11:50 am

Post Posted July 1st, 2011, 3:26 pm

Okay, can someone confirm this? I asked some people around and they all seem to have black&white antialias on menubar and I suppose Fx App menu as well. Is this a bug? I bet this is the same bug that's causing AA issues on my context menu. I also tried Instantbird and it also has black&white antialias on menubar.

Seems HW/DW isn't applied correctly everywhere? A bit confusing, because I remember it was fine before, probably on 6.0 nightly.

garbawnzo
New Member
 
Posts: 1
Joined: August 16th, 2011, 7:34 pm

Post Posted August 16th, 2011, 8:23 pm

Nvidia driver: 280.26 WHQL
GPU: GTX 560Ti, connected to monitor via DVI. Monitor set to sRGB
OS: Windows 7 (64bit)
Cleartype: enabled (and adjusted several times)
KB2505438/KB2454826/KB2545698: all installed
Windows is completely updated

FF6 is unusable without disabling hardware acceleration due to font rendering. No other browser (IE9, Chrome 13, Opera 11.50) has this issue.

T0morrow

User avatar
 
Posts: 302
Joined: April 9th, 2010, 9:16 am

Post Posted August 16th, 2011, 8:59 pm

garbawnzo wrote:Nvidia driver: 280.26 WHQL
GPU: GTX 560Ti, connected to monitor via DVI. Monitor set to sRGB
OS: Windows 7 (64bit)
Cleartype: enabled (and adjusted several times)
KB2505438/KB2454826/KB2545698: all installed
Windows is completely updated

FF6 is unusable without disabling hardware acceleration due to font rendering. No other browser (IE9, Chrome 13, Opera 11.50) has this issue.

viewtopic.php?f=38&t=2281823

WindHeight
 
Posts: 156
Joined: February 8th, 2008, 3:05 am

Post Posted August 31st, 2012, 11:10 pm

To summarize:
* HWA on, default settings: using DirectWrite in natural mode
* HWA on, mode=2 ("GDI Classic"): using DirectWrite in whole pixel mode (the "GDI Natural" option is an icky combination wherein the rendering is whole pixel, but the positioning is natural, and it's just a bad combination: either go all whole or all natural)
* HWA off, using the legacy GDI in whole pixel mode (the only mode that GDI supports)


How do I select option 2? What change to I have to make in about:config?

I know this is an old topic, but I am trying to make my fonts look like they did in ff 3.6. I am just now -trying- to upgrade to ff 15. I'd rather not disable hardware acceleration, but that does seem to work.

I've read about 2 dozen pages, including the nice summary post that I quoted from, but still am lost on how to revert back to ff 3.6-looking fonts without disbaling hardware acceleration. I tried toggling gfx.direct2d.disabled which seemed to help, but dropped my fps to ~30 in the https://developer.mozilla.org/media/upl ... e/HWACCEL/. I get 60+ (the maximum it will display) without toggling this.

HN_FIN
 
Posts: 251
Joined: July 28th, 2005, 2:12 pm
Location: Finland

Post Posted September 1st, 2012, 12:59 am

WindHeight wrote:
To summarize:
* HWA on, default settings: using DirectWrite in natural mode
* HWA on, mode=2 ("GDI Classic"): using DirectWrite in whole pixel mode (the "GDI Natural" option is an icky combination wherein the rendering is whole pixel, but the positioning is natural, and it's just a bad combination: either go all whole or all natural)
* HWA off, using the legacy GDI in whole pixel mode (the only mode that GDI supports)


How do I select option 2? What change to I have to make in about:config?

If you mean that "mode 2 / GDI classis", then gfx.font_rendering.cleartype_params.rendering_mode is the correct option.

Documentation can be found in the original commit:
http://hg.mozilla.org/mozilla-central/d ... nit/all.js

My current non-default settings values are:
gfx.font_rendering.cleartype_params.cleartype_level = 0
gfx.font_rendering.cleartype_params.rendering_mode = 2
gfx.font_rendering.directwrite.enabled = true

And remember to restart Firefox after making changes.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 5 guests