MozillaZine

The Official Win32 20120504 builds are out

Discussion about official Mozilla Firefox builds
Arjen87
 
Posts: 956
Joined: March 28th, 2012, 10:46 am
Location: The Netherlands

Post Posted May 3rd, 2012, 8:10 am

A couple of notes about the Nightly thread.
Nightly Build thread RSS feed (courtesy DaCypher)

.The Official Win32 20120504 NIGHTLY build is out Changeset: 2db9df42823d
.The Official Win32 20120504 AURORA build is out Changeset: 09cc74b7a248
.The Official Firefox 13 BETA 3 build 1 builds are not yet out Changeset: 4ed2dffc85cd

Previous NIGHTLY 20120503 (FF15.0a1)
Previous AURORA 20120503 (FF14.0a2)
Previous BETA 20120502 (FF13.0b2)

Hourly NIGHTLY builds : mozilla-central-linux || mozilla-central-macosx || mozilla-central-win32 || Firefox Tinderbox || NIGHTLY Changelog
Hourly NIGHTLY archive for Windows, Mac and Linux (not the final format yet)
AURORA Tinderbox || AURORA changelog

Last update: 2012-05-04 -- 03:00 PDT = 10:00 UTC

Fixed:
    NIGHTLY
  1. #670514
  2. #745254
  3. #749649 [Core:Networking]-crash in nsIOService::SpeculativeConnect [All] (actually fixed on 2012-04-30)
  4. #749957
  5. #751286 [Core:DOM: Events]-eventPhase NONE constant [Mac]
  6. #751561 [Core:DOM]-Call forgetSkippable twice before CC [Lin]
    AURORA
  1. #723465
  2. #741267 [Core:DOM]-UserScript's XMLHttpRequest is undefined in 20120401 nightly [Win]
  3. #744992 [Core:Widget: Win32]-crash in mozilla::widget::TaskbarPreview::MainWindowHook mainly with toolbar@web.de [Win]
  4. #747603 [Firefox:Developer Tools: Inspector]-Firefox:Inspector cannot start up with DOMi [All]
  5. #748803 [Core:Document Navigation]-Frame with elements blocked through hosts file prevents from scrolling down the page with spacebar [Win]
  6. #748983 [Core:DOM]-foo instanceof XMLHttpRequest always throws [Mac]
  7. #749527 [Firefox:Untriaged]-When trying to 'copy' a picture directly from Firefox into a windows live chat box, it copys the image location (link) instead of the image. [Win]
  8. #749860
    BETA
  1. #723465
  2. #744541
  3. #744992 [Core:Widget: Win32]-crash in mozilla::widget::TaskbarPreview::MainWindowHook mainly with toolbar@web.de [Win]
  4. #748803 [Core:Document Navigation]-Frame with elements blocked through hosts file prevents from scrolling down the page with spacebar [Win]
  5. #749527 [Firefox:Untriaged]-When trying to 'copy' a picture directly from Firefox into a windows live chat box, it copys the image location (link) instead of the image. [Win]

Partial Landings/WIPs/Incoming:
    NIGHTLY
  1. #640904 [Core:XPConnect]-Crash in JSAutoEnterCompartment::enter [All]
  2. #674225 [Core:Video/Audio]-support the Opus voice codec in <audio> and <video> elements [Oth]
  3. #703537 [Core:JavaScript Engine]-Implement Harmony direct proxies [All]
  4. #735280 [Core:XPConnect]-Remove the Components object's dependency on caps. [Lin]
  5. #739512 [Core:JavaScript Engine]-Shrink JSScript [All]
  6. #748303 [Core:Editor]-Generate <p>/<div> for newlines, not <br> [All]
    AURORA
  1. #650355 BACK OUT [Core:Security: PSM]-Stop accepting MD5 as a hash algorithm in signatures (toggle security.enable_md5_signatures to false) [All]
    BETA
    None

Regressions/Annoying/Common bugs:
    None



Nightly 15.0a1 fixes since 20110322 (mozilla 2.2) = ~6250
Aurora 14.0a2 fixes since 20110322 (mozilla 2.2) = ~6063
Beta 13.0 b fixes since 20110322 (mozilla 2.2) = ~5488

Release tracking Firefox 13-16 see HERE
Last edited by Arjen87 on May 4th, 2012, 12:00 pm, edited 3 times in total.
Microsoft Windows 7 Ultimate 64-bit | Intel Core i7 620M | 8 GB DDR3 | NVIDIA Quadro FX 1800M | 1 GB GDDR5

alex_mayorga
 
Posts: 1737
Joined: May 8th, 2008, 9:35 am
Location: Monterrey/Zacatecas, Mexico

Post Posted May 3rd, 2012, 8:12 am

streetwolf wrote:I'm using the latest hourly and I can't seem to play videos on msnbc.com. Other sites play fine. Can anyone confirm?

safe-mode doesn't play videos but a new profile does. My guess it's a Pref.

Also videos don't work on The Weather Channel.


WFM with the video towards the bottom of http://photoblog.msnbc.msn.com/_news/20 ... bana-beach

streetwolf

User avatar
 
Posts: 1218
Joined: August 21st, 2011, 8:07 am
Location: Marlboro, NJ

Post Posted May 3rd, 2012, 8:29 am

From last thread:

I'm using the latest hourly and I can't seem to play videos on msnbc.com. Other sites play fine. Can anyone confirm?

safe-mode doesn't play the videos but a new profile does. My guess it's a Pref. I'm running flash 11.3.300.231.

Also videos don't work on The Weather Channel.

Make sure you are on the latest hourly and same version of flash before saying if it works or not for you.
i7 Quad 3770K @ 5Ghz|ASUS P8Z77-V Deluxe|Corsair 1050W PSU|Corsair H100 CPU Cooler|Corsair DDR3 16GB RAM @ 2400MHz|Sapphire HD7970 3GB|DUAL ASUS PA249Q IPS 24" LCDs|Samsung SSD 830, 840 256GB|2TB Seagate SATA3|Windows 10 Pro x64|AMD 15.7.1 CATS|120Mbps/40Mbps

alex_mayorga
 
Posts: 1737
Joined: May 8th, 2008, 9:35 am
Location: Monterrey/Zacatecas, Mexico

Post Posted May 3rd, 2012, 8:35 am

Is the layout of http://music.yahoo.com/ricardo-arjona/ botched for anyone else?
Works on Chromium :-k

Dingler

User avatar
 
Posts: 1219
Joined: November 14th, 2011, 4:41 am

Post Posted May 3rd, 2012, 8:36 am

What's the interest to have removed the date of Gecko build in the UA?

Dingler

User avatar
 
Posts: 1219
Joined: November 14th, 2011, 4:41 am

Post Posted May 3rd, 2012, 8:39 am

alex_mayorga wrote:Is the layout of http://music.yahoo.com/ricardo-arjona/ botched for anyone else?
Works on Chromium :-k

The culprit is Adblock Plus, disable it or try in safe mode, you'll see the layout is fine. It's broken with ABP on FF12 too.

Cru_N_cher
 
Posts: 377
Joined: January 31st, 2010, 11:15 am

Post Posted May 3rd, 2012, 8:47 am

yep easiest fix is disable ABP for the page and use Ghostery as backup works like a charm ;)

alex_mayorga
 
Posts: 1737
Joined: May 8th, 2008, 9:35 am
Location: Monterrey/Zacatecas, Mexico

Post Posted May 3rd, 2012, 8:54 am

Dingler wrote:
alex_mayorga wrote:Is the layout of http://music.yahoo.com/ricardo-arjona/ botched for anyone else?
Works on Chromium :-k

The culprit is Adblock Plus, disable it or try in safe mode, you'll see the layout is fine. It's broken with ABP on FF12 too.

Thanks! Reported as such https://reports.adblockplus.org/5fa47a3 ... 07da7be949

Dingler

User avatar
 
Posts: 1219
Joined: November 14th, 2011, 4:41 am

Post Posted May 3rd, 2012, 8:56 am

alex_mayorga wrote:
Dingler wrote:
alex_mayorga wrote:Is the layout of http://music.yahoo.com/ricardo-arjona/ botched for anyone else?
Works on Chromium :-k

The culprit is Adblock Plus, disable it or try in safe mode, you'll see the layout is fine. It's broken with ABP on FF12 too.

Thanks! Reported as such https://reports.adblockplus.org/5fa47a3 ... 07da7be949

Culprit filter is
Code: Select all
/skyad.

dindog
 
Posts: 170
Joined: September 3rd, 2010, 11:57 am
Location: China

Post Posted May 3rd, 2012, 9:06 am

Dingler wrote:What's the interest to have removed the date of Gecko build in the UA?

> The build date will be dropped entirely in the next major release, making the > token just “Gecko” without the “/” or the date. (The build date itself has
> always been misleading — it’s not related to the Gecko version in any
> meaningful way.
scream for the fact that we are actually dying when living

Caspid

User avatar
 
Posts: 553
Joined: December 18th, 2005, 4:01 pm

Post Posted May 3rd, 2012, 9:07 am

Anyone else have problems getting the "Find" bar to go away?
"Know what I pray for? The strength to change what I can, the inability to accept what I can't, and the incapacity to tell the difference." -Calvin

LordStriker

User avatar
 
Posts: 732
Joined: September 7th, 2010, 7:14 am
Location: Macedonia, Greece

Post Posted May 3rd, 2012, 9:15 am

Did you notice improvement on smooth-scrolling behavior? When I was scrolling fast to bottom, I had 1-2 hiccups. Now it keeps scrolling smoothly... I hope it's been fixed and not placebo on my part.

It approaches IE9's perfect scrolling.
Fx 16.02 -//- Fx 19α x64 -//- Win 8 Pro x64 -//- CPU: i5 2500 -//- GPU: 7950 -//- RAM: 8GB

Joga5000

User avatar
 
Posts: 72
Joined: November 7th, 2010, 10:22 pm
Location: Houston, TX

Post Posted May 3rd, 2012, 9:19 am

LordStriker wrote:Did you notice improvement on smooth-scrolling behavior? When I was scrolling fast to bottom, I had 1-2 hiccups. Now it keeps scrolling smoothly... I hope it's been fixed and not placebo on my part.

It approaches IE9's perfect scrolling.


Probably a result of Bug 702463 that just landed. That's always annoyed me too - smooth scrolling always had little hiccups and wasn't completely smooth the way IE9 is. I'll have to turn on smooth scrolling again and try it out.
Windows 8 Pro 64-bit | Core i7 4770K @ 4.5GHz | 8GB DDR3 1333 | Radeon HD 7950 3GB | Samsung S23A700D (120 Hz, 1080p)

alex_mayorga
 
Posts: 1737
Joined: May 8th, 2008, 9:35 am
Location: Monterrey/Zacatecas, Mexico

Post Posted May 3rd, 2012, 9:38 am

Caspid wrote:Anyone else have problems getting the "Find" bar to go away?

Pressing [Esc] whenever it is showing makes it go away here FWIW.

Optimizer HD

User avatar
 
Posts: 264
Joined: April 12th, 2011, 11:48 am

Post Posted May 3rd, 2012, 10:08 am

Is there a problem with flash in the 05-03 build ?
I just updated a few minutes before and since then none of flash content is loading.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 2 guests