MozillaZine

Firefox 13 smooth scrolling changed?

Discussion about official Mozilla Firefox builds
Canyonero
 
Posts: 1407
Joined: April 25th, 2003, 11:02 pm

Post Posted June 29th, 2012, 11:14 am

I'm guessing this is an addon bug. Can anyone seeing it post what extensions they're using?

Arrow189
 
Posts: 2
Joined: September 2nd, 2012, 3:29 am

Post Posted September 2nd, 2012, 3:34 am

Canyonero wrote:I'm guessing this is an addon bug. Can anyone seeing it post what extensions they're using?

It's not addons. The issue seems to be that the new smooth scrolling behavior includes an acceleration mechanic that causes an awkward burst of page redraws. Setting the minimum and maximum speeds to the same value, thereby removing the acceleration, fixes the chopping and more or less makes firefox act the way it used to.

It's like they didn't test this feature before adding it.

LordStriker

User avatar
 
Posts: 732
Joined: September 7th, 2010, 7:14 am
Location: Macedonia, Greece

Post Posted September 2nd, 2012, 8:55 am

Can you tell us, please, how you set min/max speeds?
Fx 16.02 -//- Fx 19α x64 -//- Win 8 Pro x64 -//- CPU: i5 2500 -//- GPU: 7950 -//- RAM: 8GB

Arrow189
 
Posts: 2
Joined: September 2nd, 2012, 3:29 am

Post Posted September 11th, 2012, 8:42 am

squall_leonhart wrote:set

general.smoothScroll.mouseWheel.durationMaxMS
and
general.smoothScroll.mouseWheel.durationMinMS

to 150, and the Lag feeling will be gone.

From the first page. It doesn't have to be 150, I use 200, and there doesn't seem to be lag at all. Just make sure its the same.

Cyberbeing
 
Posts: 107
Joined: May 21st, 2008, 10:47 pm

Post Posted September 11th, 2012, 6:12 pm

When Firefox 13 was released I used the following which does make scrolling more responsive without the annoying drift of the default settings:
general.smoothScroll.durationToIntervalRatio = 100
general.smoothScroll.mouseWheel.durationMaxMS = 150
general.smoothScroll.mouseWheel.durationMinMS = 150

...but that never got rid of the stuttering/lag. Recently I discovered that the layout.frame_rate setting was able to resolve that remaining problem.

Setting layout.frame_rate to monitor refresh rate x 4 makes a massive difference, at the expense of a couple percent higher CPU usage when scrolling.
As an added bonus, it also seems to increase responsiveness and reduce lag of the UI in general.

If you have a 60Hz LCD, try setting layout.frame_rate = 240.
Be careful with this setting though, since after you pass a certain threshold (which was around 375-400 on my PC), CPU usage will skyrocket and performance will become significantly degraded.
A value of 240 which is essentially a 4.16ms rendering timer should be safe and stable enough in Firefox if you have a decent computer.

Caspid

User avatar
 
Posts: 545
Joined: December 18th, 2005, 4:01 pm

Post Posted September 11th, 2012, 8:50 pm

^neat.


I don't suppose anyone has written up precisely what each of these configuration options does?
general.smoothScroll.durationToIntervalRatio, general.smoothScroll.lines.durationMaxMS, general.smoothScroll.other.durationMinMS, etc
"Know what I pray for? The strength to change what I can, the inability to accept what I can't, and the incapacity to tell the difference." -Calvin

Caspid

User avatar
 
Posts: 545
Joined: December 18th, 2005, 4:01 pm

Post Posted September 11th, 2012, 9:31 pm

Also, I can't seem to increase the number of lines Firefox scrolls by. Even with mousewheel.withnokey.sysnumlines set to false and mousewheel.withnokey.numlines set to 20, the mouse wheel still only scrolls by a few lines.

edit: many thanks!
Last edited by Caspid on September 12th, 2012, 9:57 pm, edited 1 time in total.
"Know what I pray for? The strength to change what I can, the inability to accept what I can't, and the incapacity to tell the difference." -Calvin

Chris000001
 
Posts: 396
Joined: September 12th, 2005, 4:43 pm

Post Posted September 11th, 2012, 9:40 pm

Caspid wrote:Also, I can't seem to increase the number of lines Firefox scrolls by. Even with mousewheel.withnokey.sysnumlines set to false and mousewheel.withnokey.numlines set to 20, the mouse wheel still only scrolls by a few lines.

It's mousewheel.default.delta_multiplier_y now. It's a percentage. 100 = system number of lines, 200 would double that, etc.

Chrysalis
 
Posts: 313
Joined: January 27th, 2004, 10:43 am

Post Posted September 17th, 2012, 8:38 pm

thanks for this cyberbeing, I went from esr to 15.0.1, and immediatly noticed the scrolling was weird in a negative way with extra jerkyness.

Setting the settings you posted has improved it somewhat. I find myself wondering what goes on inside the dev's minds, everytime I upgrade firefox there is something to fix.

squall_leonhart

User avatar
 
Posts: 835
Joined: March 17th, 2008, 5:32 am
Location: Australia

Post Posted October 3rd, 2012, 2:21 pm

the jerkiness is actually a bug in aurora and nightly, that Mozilla QA can't for the life of them reproduce for some reason.

it occurs when certain addons that use frequently updating ui controls are installed and you maximise the window (and subsequently remains after unmaximising past a certain window dimension)

Beta does not have this problem.

dbcooper.dk
 
Posts: 806
Joined: March 14th, 2010, 3:44 am

Post Posted October 3rd, 2012, 3:53 pm


LordStriker

User avatar
 
Posts: 732
Joined: September 7th, 2010, 7:14 am
Location: Macedonia, Greece

Post Posted October 4th, 2012, 3:21 am

Cyberbeing wrote:If you have a 60Hz LCD, try setting layout.frame_rate = 240.
Be careful with this setting though, since after you pass a certain threshold (which was around 375-400 on my PC), CPU usage will skyrocket and performance will become significantly degraded.
A value of 240 which is essentially a 4.16ms rendering timer should be safe and stable enough in Firefox if you have a decent computer.


Keep in mind, though, if you care for efficiency, this is extremely inefficient. Default smooth scrolling adds noticeable load on GPU ( in comparison to non-smooth scrolling ), but the clocks remain in idle mode -it's O.K.

If you set 240Hz, the clocks are -almost constantly- in 3d mode. With a little scrolling on Reddit, for instance, temps go up by 6-7 degrees. Of course it adds responsiveness.

By the way, on 16 beta the default settings aren't bad... In Nightly the problem appears.
Fx 16.02 -//- Fx 19α x64 -//- Win 8 Pro x64 -//- CPU: i5 2500 -//- GPU: 7950 -//- RAM: 8GB

streetwolf

User avatar
 
Posts: 1030
Joined: August 21st, 2011, 8:07 am
Location: Marlboro, NJ

Post Posted October 4th, 2012, 7:17 am

Speaking of scrolling I began to notice in the last week or so a slight delay in scrolling when a new page opens up. When I go to a a page and scroll using my wheel there is a pause of 1-2 seconds until the page scrolls. I don't recall this happening until recently. Any insight into this?
i7 Quad 3770K @ 5.1Ghz|ASUS P8Z77-V Deluxe|Corsair 1050W PSU|Corsair H100 CPU Cooler|Corsair DDR3 16GB RAM @ 2400MHz|Sapphire HD7970 3GB|ASUS PA246, PA249 IPS 24" LCD|Samsung SSD 830, 840 256GB|2TB Seagate SATA3|Windows 8.1 Pro x64|AMD 15.4 CATS|120Mbps/40Mbps

Cyberbeing
 
Posts: 107
Joined: May 21st, 2008, 10:47 pm

Post Posted October 4th, 2012, 7:32 am

I haven't noticed any difference on 2D/3D clocks, since my GT 440 DDR5 would enter 3D Mode whenever scrolling even with default settings. You're correct that GPU load is much higher though, but at least on this GPU it has nearly no effect on temps (+1° C) which maintains the lowest auto idle fanspeed of 25%. I'll agree that this isn't efficient, but until Mozilla achieves similar smoothness and responsiveness with a 1:1 ratio of layout.frame_rate:refresh_rate, I find it to be an acceptable solution on my PC. For laptop users on battery power, maybe not.

Firefox may be in need of something like a smoothscroll event timer which is set higher for responsiveness and works independently of the VSync rendering rate.

streetwolf wrote:Speaking of scrolling I began to notice in the last week or so a slight delay in scrolling when a new page opens up. When I go to a a page and scroll using my wheel there is a pause of 1-2 seconds until the page scrolls. I don't recall this happening until recently. Any insight into this?

The page probably wasn't fully rendered, but I've also seen issues with Firefox scrolling in general where scrolling will stall slightly or slow down when it hits certain image or content heavy page elements. This seems to happen even without smoothscrolling though.

squall_leonhart

User avatar
 
Posts: 835
Joined: March 17th, 2008, 5:32 am
Location: Australia

Post Posted October 4th, 2012, 4:20 pm


Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 2 guests