MozillaZine

Post extensions that work with Deer Park/Firefox 1.5 HERE

Discussion about official Mozilla Firefox builds
manc39
Moderator
 
Posts: 2037
Joined: June 17th, 2004, 8:34 am
Location: Manchester, England

Post Posted May 28th, 2005, 9:58 am

Slim Extensions List 0.1 is working perfectly. :)
Last edited by manc39 on May 28th, 2005, 10:01 am, edited 1 time in total.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060712 BonEcho/2.0b1

sboulema
 
Posts: 6615
Joined: May 20th, 2003, 12:34 am
Location: Amstelveen, The Netherlands

Post Posted May 28th, 2005, 9:59 am

only quickly tested it on a clean profile with tbe and adblock installed.

Xemanth
 
Posts: 129
Joined: September 8th, 2004, 6:31 am
Location: Southern Finland

Post Posted May 28th, 2005, 10:05 am

Well well here's my collection of hacked extensions.
http://moz.urli.net/ext/hacked/
I bumped all their max version to 1.0+.

Red_Fat_Lazy_Cat

User avatar
 
Posts: 564
Joined: April 16th, 2003, 12:45 pm
Location: The ottoman near the fireplace

Post Posted May 28th, 2005, 10:10 am

only quickly tested it on a clean profile with tbe and adblock installed.

Hmm, my experience lead me to a strong belief that TBE and AdBlock ain't perfect companions.....
Some people say that cats are sneaky, evil, and cruel. True, and they have many other fine qualities as well. -- Missy Dizick

My Firefox themes: Red Cats (blue & green flavor), Curacao

ChefChaudart

User avatar
 
Posts: 521
Joined: March 3rd, 2004, 12:43 pm
Location: Belgium

Post Posted May 28th, 2005, 11:02 am

agreed ;-)


What about the Googlebar ?
Do not forget Liu Xiaobo

Sam-I-am
 
Posts: 43
Joined: September 16th, 2004, 2:29 pm

Post Posted May 28th, 2005, 12:31 pm

Between 1.0.4, the nightlies that followed and Deer Park Alpha 1, something about how extensions are handled changed, and many extensions broke.

For many, all that was needed was to bump the maxVersion number to 1.0+ or better yet 1.1.

For others, the name of the extension inside the install.rdf needed to be replaced with a GUID for security reasons. These are easy to understand and fix.

For EZNav and Sort Extensions, the problems are somehow different.

I can see with the changes in the layout, how the adding a -Sort- clickable entry on the bottom bar of the extensions popup could break it. But is there are easy fix to that?

I don't see such an obvious reason for why EZNav broke.

Anyone have any ideas on either of these?

For Calendar, there may be similar issues. The add-in works in 1.0.4 and breaks in Deer Park. And clearly from reading through the nightly info, they are in major rewrite. Any ideas as to what the problem is there?

And more importantly, is anyone aware of anyone having hacked these to work?

Thanks
Sam

dgrimm1
 
Posts: 632
Joined: December 7th, 2004, 3:55 pm
Location: Kansas USA

Post Posted May 28th, 2005, 12:59 pm

Sam,

Your post brings up a good point -- it would be nice if someone would compile a list of "Things that might cause Firefox 1.0 extensions to break in Deere Park Alpha1". There are some obvious things maxVersion and GUID issues that will affect many extensions.

There are some other issues like variable names changing in bookmarks.js that will affect certian extensions. If someone that knows more about this stuff could put together a fairly complete list, I would be happy to add it to the website page and/or the first post here.

dirtyepic

User avatar
 
Posts: 168
Joined: June 17th, 2004, 8:16 pm
Location: Canada

Post Posted May 28th, 2005, 4:43 pm

manc39 wrote:Slim Extensions List 0.1 is working perfectly. :)


silently fails for me. new profile.

edit: Xemanth's works.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051223 Firefox/1.6a1 ID:2005122304

dirtyepic

User avatar
 
Posts: 168
Joined: June 17th, 2004, 8:16 pm
Location: Canada

Post Posted May 28th, 2005, 5:03 pm

working out of the box:

BBCodeXtra 0.2.3
CookieCuller 1.2.0
New Tab Homepage 0.1
Openbook 1.2.0
Rocker Navigation 1.0 (but only works going forwards, not back)
Tab Clicking Options 0.5.1
Update Bookmark 0.0.4
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051223 Firefox/1.6a1 ID:2005122304

dbMorris

User avatar
 
Posts: 479
Joined: October 28th, 2004, 10:19 pm
Location: Bay Area, CA.

Post Posted May 28th, 2005, 5:46 pm

I was able to install the below additional extensions just by bumping the MaxVersion to 1.1:
* All-In-One Gestures 0.14.3
* Bible Toolbar 2.0
* Bloglines Toolkit 1.5.6
* Bookmark Backup 0.3.1
* LiveLines 0.4.2
* WindowsUpdate 1.0
Last edited by dbMorris on May 28th, 2005, 5:59 pm, edited 1 time in total.
<a href="http://www.freewebs.com/dbmorris/systemconfig.htm" target="_blank" class="postlink">My System</a> | <a href="http://www.freewebs.com/dbmorris/firefoxconfig.htm" target="_blank" class="postlink">Firefox Extensions & Plugins</a>

ShareBird

User avatar
 
Posts: 2740
Joined: December 8th, 2004, 7:09 am
Location: Berlin | Made in Brasil

Post Posted May 28th, 2005, 5:49 pm

I've tried to make SortBookmarks work with Deer Park, but no way... Did someone also try it???

.

ahpatel
 
Posts: 4
Joined: September 1st, 2004, 8:42 am

Post Posted May 28th, 2005, 6:44 pm

These extensions do not install:

ConQuery 1.5.4
Compact Menu 1.7.2
Image Zoom 0.1.9.2005.0126
Show Image 0.3

BenneJezzerette

User avatar
 
Posts: 1482
Joined: November 1st, 2004, 1:47 am
Location: Ghost in the Machine

Post Posted May 28th, 2005, 10:42 pm

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050528 Firefox/1.0+ ID:2005052805

All my extensions

Adbloc 0.5 Seems to be the origianl maybe the Drag and Drop of the jar file thinking it was a theme made it work from the mozdev site Works
Netcraft, Bump Versioning fix, thank you Ria
Moji
Translate
Translate Page
Translate Panel
ForecastFOX 7.8
Build ID Copier 0.3 The QFA launcher does not work for me.
jslib 0.1.290
jsoptions 1.0
Smiley Xtra 3.1.3
Spellbound
Diggler 0.9

Once again thank you to Ria for the nice Mod Tips.
Vista Home Premium 64 AMD 9950 Quad Core + 8GB DDR2 1066 1x500GB 1X750GB Partitioned 1X1TB MSI GTX260 896
Firefox Safe Browsing - Pocomail Safe E-Mail from Script Kitties
True Internet Surfing + E-Mail not Junk

Philippe-Pierre

User avatar
 
Posts: 344
Joined: May 28th, 2003, 1:48 pm

Post Posted May 28th, 2005, 11:06 pm

illegalien wrote:These extensions do not install:

ConQuery 1.5.4
...

ConQuery 1.5.4 installed and works all right for me on 0527 and 0528, once the maxversion
set to 1.1
Plain Text Links 0.2 too.

These others have been reported already I think, but anyway:
Diggler 0.9
Permit Cookies 0.6
Web developper 0.9.3
Ook 0.3.3
are all ok, all with maxversion to 1.1
Last edited by Philippe-Pierre on May 28th, 2005, 11:23 pm, edited 1 time in total.
Regards

Philippe-Pierre a.k.a. pierre_h
----
* Dedicated to software which sucks less ... http://suckless.org/

MajereDB8

User avatar
 
Posts: 3
Joined: May 7th, 2005, 10:10 pm

Post Posted May 28th, 2005, 11:09 pm

BenneJezzerette,

How did you manage ForecastFox 0.78 to work? I bumped the maxversion to 1.1, but I can't get any of the icons to show. The hacked version (0.71) WFM though.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 4 guests