MozillaZine

Post extensions that work with Deer Park/Firefox 1.5 HERE

Discussion about official Mozilla Firefox builds
Ria

User avatar
 
Posts: 3550
Joined: March 21st, 2004, 3:25 am
Location: Netherlands

Post Posted May 31st, 2005, 3:51 am

ankh wrote:I tried
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050530 Firefox/1.0+

Clean --starting with no profile, to force everything new, and tried installing RIP again (the stock 1.0.3) and got the same error.

Using OSX, I tried to open the rip.xpi file with a couple of text editors, no luck. I'm guessing 7-zip is probably a Windows app?

I think I'll wait on the official catching-up process.

A normal zip-program will do. XPI is a renamed ZIP. So when you rename it to ZIP you can extract it and repackage it again.

ckjnigel
 
Posts: 285
Joined: November 5th, 2002, 12:37 am

Post Posted May 31st, 2005, 4:19 am

cheesypeanut chose not to divulge that the AdBlock and Deer Park compatible version of Tab Mix is at
http://www.gary.elixant.com/tabmix/ . It turns out to have an ability that Sakura's latest lacked...
When one uses the Greasemonkey auto-login script for MySpace, one gets swept immediately from the login page to one's home page; an attempt to redisplay that subsequently closed tab of the home page using TBE produced only an "Untitled" blank. With TabMix, this works properly.
I am quite surprised that Smoothwheel 0.43.1.20041107 works -- a boon to me since its "Nice and Easy" scrolling option betters more recent algorithms in my setup.
One oddity is that the Firefox modern theme that seemed to work earlier now shows as installed but will not "take." I've switched to Pinball, Ayakawa Rev. for trunk, 0.9.9.3, release 13.
And, that only Weatherfox 0.5.1 would work -- latest Forecastfoxes' claims to compatibility failed here -- is no sadness since that was the best ever. (Glad I keep all my old xpi's !!! )

ShareBird

User avatar
 
Posts: 2740
Joined: December 8th, 2004, 7:09 am
Location: Berlin | Made in Brasil

Post Posted May 31st, 2005, 5:01 am

Who becomes now developer for official TabMix?? Does someone know?

.
Silvermel - A Theme for Firefox and Thunderbird
YATT - Yet Another Theme Tutorial
Don't give a man a fish. Teach him how to fish instead.

tomomodel
 
Posts: 4
Joined: April 24th, 2005, 12:37 am
Location: Nagasaki, Japan

Post Posted May 31st, 2005, 5:10 am

ShareBird wrote:Who becomes now developer for official TabMix?? Does someone know?

.


http://www.gary.elixant.com/tabmix/

Jumbie

User avatar
 
Posts: 72
Joined: June 19th, 2004, 7:42 am

Post Posted May 31st, 2005, 6:31 am

I've just updated to jayfromtaiwan's optimized nightly build (29th May) and two extensions I was using on an earlier version of DeerPark will no longer install.

Open Link In

and

Paste and Go

Any help on possibly hacking these extensions to work with the [almost] latest DeerPark?

Thanks.

Ria

User avatar
 
Posts: 3550
Joined: March 21st, 2004, 3:25 am
Location: Netherlands

Post Posted May 31st, 2005, 6:44 am

ckjnigel - the latest Forecastfox 0.7.8 looks also nice:

Image

Ria

User avatar
 
Posts: 3550
Joined: March 21st, 2004, 3:25 am
Location: Netherlands

Post Posted May 31st, 2005, 6:46 am

Jumbie wrote:I've just updated to jayfromtaiwan's optimized nightly build (29th May) and two extensions I was using on an earlier version of DeerPark will no longer install.

Open Link In

and

Paste and Go

Any help on possibly hacking these extensions to work with the [almost] latest DeerPark?

Thanks.

Have you tried bumping the maxVersion in the install.rdf to 1.1?

Jumbie

User avatar
 
Posts: 72
Joined: June 19th, 2004, 7:42 am

Post Posted May 31st, 2005, 7:02 am

Nope.

I just looked up how to do it though and will give it a try. Having just installed a couple versions of FF (jay's trunk and then stipe's 1.04) I don't much feel like doing it right now.

Will report back in a bit if it works.

Anyway, just to double-check all I'd need to do is change the install.rdf in Paste and Go 0.4.1 from

<em:maxVersion>1.0</em:maxVersion>

to

<em:maxVersion>1.1</em:maxVersion>

Is that correct?

a;skdjfajf;ak

User avatar
 
Posts: 17002
Joined: July 10th, 2004, 8:44 am

Post Posted May 31st, 2005, 7:05 am

Jumbie wrote:Nope.

I just looked up how to do it though and will give it a try. Having just installed a couple versions of FF (jay's trunk and then stipe's 1.04) I don't much feel like doing it right now.

Will report back in a bit if it works.

Anyway, just to double-check all I'd need to do is change the install.rdf in Paste and Go 0.4.1 from

<em:maxVersion>1.0</em:maxVersion>

to

<em:maxVersion>1.1</em:maxVersion>

Is that correct?


Yes, that is correct, however...A few extensions we have found need some other changes to make them work, but that's the 1st place to start, is bump up the MaxVersion.

Jumbie

User avatar
 
Posts: 72
Joined: June 19th, 2004, 7:42 am

Post Posted May 31st, 2005, 7:36 am

Thanks.

I actually went ahead and did it. Happy to report success. Sort of... Paste and Go does not work despite installing. :(

I was also able to get Image_Zoomer_0.2.xpi to work but not ImageZoom which is the one I actually prefer to use. While the latter installs fine (same with previous trunk I was using), it gives an error when loading. Not a big deal.

[edit]

Funny. I decided to try changing the install.rdf to 1.1+ in Paste and Go instead of just 1.1 and now it seems to be working.

I know I'm happy.

[/edit]

mathparent
 
Posts: 22
Joined: April 21st, 2005, 9:31 pm

Post Posted May 31st, 2005, 8:54 am

Ria wrote:mathparent - possibly you only need to bump the maxVersion in the install.rdf.


Thanks, it's working now, but anyway the error messages doesn't help, and a javascript error is not sufficient for an end-user

:)

jtc331
 
Posts: 23
Joined: October 21st, 2004, 2:54 pm

Post Posted May 31st, 2005, 6:43 pm

I have hacked the Tab X Ultra extension by changing the GUID and version number to support nightly build, it can be found at

http://mysite.verizon.net/jtc331/TabX.xpi

BenBasson
Moderator

User avatar
 
Posts: 13671
Joined: February 13th, 2004, 5:49 am
Location: London, UK

Post Posted May 31st, 2005, 6:59 pm

Everything except Image Toolbar 0.5 on http://www.cusser.net/extensions/ is updated to 1.0+. Image Toolbar users can install version 0.5, but please use my 0.6a instead.

dgrimm1
 
Posts: 632
Joined: December 7th, 2004, 3:55 pm
Location: Kansas USA

Post Posted June 1st, 2005, 5:22 am

I have updated some of the extensions on the <a href="http://www.projects1.com/firefox/exthacks/FFnightlyextensions.html"> Extensions hacked for Deer Park Alpha</a> page, as a few of them still had "maxversion" set at 1.0, which wouldn't work after a checkin late last week. All extensions listed there should now work.

At this point, I do not intend to try to host on the list every extension that simply needs its "maxversion" bumped, or contains something like an invalid GUI or version number. I am much more interested in hosting extensions that need some code changes or tweaks to work. I probably would be willing to host fairly popular extensions that need minor changes, for those users that are not comfortable doing that themselves.

Lastly, has anyone tried using the latest session saver (n28 I think) with Deer Park? The one extension I kind of miss, although Tab Mix's "load last tabs at startup" is good enough to get by.

Jumbie

User avatar
 
Posts: 72
Joined: June 19th, 2004, 7:42 am

Post Posted June 1st, 2005, 5:57 am

SessionSaver 0.2.1.027 [hacked] is working for me with Deer Park 20050529 (jayfromtaiwan's optimized build). Dunno how recent of a nightly you're referring to. On a previous version of DP, it seemed to load blank tabs a lot with FocusLastSelectedTab (FLST) installed. Didn't install it this time round and so far so good.

The one extension I can't get to work is ImageZoom 0.1.7 http://www.extensionsmirror.nl/index.ph ... 27&hl=zoom

Anyone care to try and hack that one? I can't do much more than bump maxversion :)

Return to Firefox Builds


Who is online

Users browsing this forum: Google [Bot] and 7 guests