MozillaZine

Aurora 50 slowdown

Discussion about official Mozilla Firefox builds
Ezh
 
Posts: 468
Joined: November 5th, 2002, 1:35 pm
Location: Tallinn, Estonia

Post Posted August 10th, 2016, 2:40 am

Does someone experiences a slowdown in Aurora 50 UI after some time of up-time? I'm on Windows 10.

Started right from 50 installing, returned to 49 and no problem.

dbcooper.dk
 
Posts: 895
Joined: March 14th, 2010, 3:44 am

Post Posted August 10th, 2016, 3:21 am

Yep. It's on Nightly too.

Might be triggered by youtube.

Ezh
 
Posts: 468
Joined: November 5th, 2002, 1:35 pm
Location: Tallinn, Estonia

Post Posted August 10th, 2016, 6:44 am

Is there a bug for it?

dbcooper.dk
 
Posts: 895
Joined: March 14th, 2010, 3:44 am

Post Posted August 10th, 2016, 6:51 am

Not that I know of.

Ezh
 
Posts: 468
Joined: November 5th, 2002, 1:35 pm
Location: Tallinn, Estonia

Post Posted August 11th, 2016, 4:01 am

Does someone knows the bug? It's not so good to fill a new bug and get a duplicate.

dbcooper.dk
 
Posts: 895
Joined: March 14th, 2010, 3:44 am

Post Posted August 18th, 2016, 4:07 pm


dbcooper.dk
 
Posts: 895
Joined: March 14th, 2010, 3:44 am

Post Posted August 18th, 2016, 4:32 pm


Ezh
 
Posts: 468
Joined: November 5th, 2002, 1:35 pm
Location: Tallinn, Estonia

Post Posted August 20th, 2016, 2:19 am


dbcooper.dk
 
Posts: 895
Joined: March 14th, 2010, 3:44 am

Post Posted August 20th, 2016, 2:27 am

Thanks for filing the bug.


dbcooper.dk
 
Posts: 895
Joined: March 14th, 2010, 3:44 am

Post Posted August 22nd, 2016, 4:52 pm

Possible regression:

https://bugzilla.mozilla.org/show_bug.cgi?id=1294953

I spend some time with nightly builds and mozreggression tool which is great by
the way. Bisecting on those massive slow downs is hard because they starts
after some time depending on browser usage and I haven't managed to produce
easy steps to reproduce the issue (with almost not responsive browser) fast.
But I have found steps to quickly diagnose micro shuttering during scrolling on
very big site. I spend quite some time to actually find the patch which broke
it. I believe this is the same issue actually which gets more significant over
time.

Long story short, this commit is responsible for regression.

https://hg.mozilla.org/mozilla-central/ ... ca328cb3ec

And it seems like it is already being worked on in Bug 1295214.

I will do some more testing to be sure and mark this bug report as a duplicate
tomorrow.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 5 guests