MozillaZine

The first official 20171030 builds are out

Discussion about official Mozilla Firefox builds
Josa
 
Posts: 2657
Joined: July 28th, 2009, 4:52 pm

Post Posted October 29th, 2017, 8:33 am

Previous Nightly Builds thread 20171029

The first official 20171030 NIGHTLY builds are out
.The Official Firefox 57 Beta 13 builds are not yet out

Previous NIGHTLY: 20171029 (Fx 58.0a1)
Previous BETA: 20171027 (Fx 57.0b12)

Mozilla Inbound Builds
Treeherder
Release Notes: NIGHTLY | BETA
Changelogs: NIGHTLY | BETA


Fixed:
    NIGHTLY +26
  1. #1408990
  2. #1411849
  3. #1412252
  4. #1412181 [Core:Audio/Video: Playback]-Fix the scary way to abuse ClearOnShutdown() in MediaCache::GetMediaCache() [Uns][]
  5. #1412187 [Core:Audio/Video: Playback]-ChannelMediaResource::Resume() should call Seek() instead of CacheClientSeek() [Uns][]
  6. #1410420 [Core:DOM: IndexedDB]-support.microsoft.com ghost window via IDBDatabase object on 57 beta [Uns][[MemShrink]]
  7. #1404842 [Core:DOM]-Implement Element.attachShadow and Element.slot [Uns][]
  8. #1379564 [Core:DOM: Animation]-Cleanup TimeDuration handling [Uns][]
  9. #748315 [Core:Editor]-queryCommandState("justify*") should respect CSS text-align values [All][]
  10. #1399389 [Core:Graphics: WebRender]-Integrate gfxCriticalNote/gfxCriticalError in WebRender [Uns][[wr-reserve] [gfx-noted]]
  11. #1408481 [Core:Graphics: WebRender]-wr-text: implement -moz-osx-font-smoothing: grayscale [Mac][[wr-mvp]]
  12. #1411957 [Core:JavaScript: Internationalization API]-Update to tzdata2017c [Uns][]
  13. #1411881 [Core:Layout: Web Painting]-Don't let UnmarkFrameForDisplay clobber entries added as MarkFrameForDisplayAsVisible [Uns][]
  14. #1412221 [Core:Memory Allocator]-Miscellaneous code cleanups in mozjemalloc.cpp [Uns][]
  15. #1412234 [Core:Memory Allocator]-Make all allocator API entry points handle initialization properly [Uns][]
  16. #1410620 [Core:Networking]-Change CacheInfo interfaces to use ACString [Uns][[necko-triaged]]
  17. #1410794 [Core:Preferences: Backend]-Change some |string| occurrences in nsIPrefBranch.idl to |AUTF8String| [Uns][]
  18. #1411879 [Core:Printing: Setup]-Use 'kPMDataFormatXMLCompressed' parameter into PMPageFormatCreateDataRepresentation() on macOS. [Uns][]
  19. #1411683 [Core:Security: PSM]-Add methods to iterate and segment nsNSSCertList objects [All][]
  20. #1412050 [Firefox:Developer Tools]-[dt-onboarding] restoreSession triggers the onboarding flow if devtools.enabled is false [Uns][]
  21. #1404193 [Firefox:New Tab Page]-make Onboarding more configurable [Uns][]
  22. #1409640 [Firefox:Preferences]-[Linux] Dropdown arrow for Applications is barely visible [Lin][[photon-preference]]
  23. #1408539 [Firefox:Tours]-Onboarding Tour: update customize, library, and screenshot illustration [Uns][[photon-onboarding][photon-onboarding-newui]]
  24. #1409977 [Firefox:Tours]-define the property to mark Onboarding tour complete instantly [Uns][[photon-onboarding]]
  25. #1401400 [Toolkit:Crash Reporting]-Shutdown hangs don't produce useful crash pings [Uns][]
  26. #1384753 [Toolkit:Safe Browsing]-Move csd.proto into a common Safe Browsing directory and update it [Uns][pwphish-prep]

    Partial Landings/Diagnostic Patches:
  1. #1406327 [Core:WebVR]-Detect VR content to manage VR listener thread [Uns][]

    Beta 12 -> Beta 13 Changelog +3
  1. #1409444 [Core:CSS Parsing and Computation]-stylo: Crash in rand::weak_rng [Win][]
  2. #1397441 [Core:Security: PSM]-Make sure HPKP preload expiration date is accurate for 57 [All][[psm-blocked] ]
  3. #1409101 [Firefox:Developer Tools: Debugger]-Editor is occasionally empty [Uns][]

Nightly 58 fixes since 20170921 (Gecko 57) ~2017
Beta 57 fixes since 20170802 (Gecko 56) ~3528

Nightly Blog
Release Calendar
Release Tracking
MozRegression Guide
Last edited by Josa on October 30th, 2017, 3:20 pm, edited 1 time in total.

Mark12547
 
Posts: 126
Joined: May 13th, 2017, 11:36 am
Location: Oregon, United States, Earth

Post Posted October 29th, 2017, 10:51 pm

In Nightly I still have the Facebook problem of when I go to a private group some of the content (usually at least the group picture, sometimes additional content) is whited out and is unviewable and unreadable. I notice this with my usual Nightly profile, but I can reproduce it with a brand new Nighly profile (zero customization, zero extensions other than what Mozilla automatically loads).

Omega X

User avatar
 
Posts: 7917
Joined: October 18th, 2007, 2:38 pm
Location: A Parallel Dimension...

Post Posted October 30th, 2017, 1:48 am

Looks like a few improvements landed in the last day or so.

Media Cache off the main thread, More Webrender stuff, a fix for that throbber issue, Stylo fixes. A push and backout for MSVC 2017. Finally building Stylo on Android Nightly.
Latest: Firefox/57.0 *ESR/52.5 - Mobile/57.0 - Thunderbird/52.4.0 - SeaMonkey/2.49.1
Nightly: Nightly/59.0a1 - Mobile/59.0a1 - Daily/59.0a1 - SeaMonkey/2.55a1

Sintendo
 
Posts: 102
Joined: January 26th, 2012, 3:03 am

Post Posted October 30th, 2017, 1:58 am

Anyone else having trouble playing 1080p60 content on YouTube? The image completely hangs after one second, while the audio keeps going. I tried 56.0.2 and Chrome 62, which both do much better than Nightly on the same hardware. Has a bug been filed?

EDIT: More specifically, the problem seems to be with vp9 content.
EDIT 2: Apparently I'm getting avc1 instead of vp9 on Firefox 56.0.2, which could explain the performance difference. Chrome gets vp9 though, and still manages runs smoother.

Lurtz
 
Posts: 194
Joined: June 12th, 2016, 12:25 pm

Post Posted October 30th, 2017, 1:13 pm

Stylo can now be used for the chrome: layout.css.servo.chrome.enabled

Omega X wrote:Looks like a few improvements landed in the last day or so.

Media Cache off the main thread

Can you name the ticket for that?
Last edited by Lurtz on October 30th, 2017, 1:41 pm, edited 1 time in total.

GHM113

User avatar
 
Posts: 668
Joined: December 16th, 2015, 3:59 am
Location: Moscow, Russia

Post Posted October 30th, 2017, 1:37 pm

Sintendo wrote:Has a bug been filed?

I came across this bug when watching this video at 1440p: https://www.youtube.com/watch?v=UzdNECcio54
Lurtz wrote:Stylo can now be used for the Chrome: layout.css.servo.chrome.enabled

Thanks, I've just enabled that pref 8-)
I am an idiot. Sorry for my poor English. Current list of config tweaks: https://pastebin.com/1dCT4Cvp

Omega X

User avatar
 
Posts: 7917
Joined: October 18th, 2007, 2:38 pm
Location: A Parallel Dimension...

Post Posted October 30th, 2017, 2:00 pm

Lurtz wrote:Stylo can now be used for the chrome: layout.css.servo.chrome.enabled

Omega X wrote:Looks like a few improvements landed in the last day or so.

Media Cache off the main thread

Can you name the ticket for that?


https://bugzilla.mozilla.org/show_bug.cgi?id=1369263
Latest: Firefox/57.0 *ESR/52.5 - Mobile/57.0 - Thunderbird/52.4.0 - SeaMonkey/2.49.1
Nightly: Nightly/59.0a1 - Mobile/59.0a1 - Daily/59.0a1 - SeaMonkey/2.55a1

Peja Stija

User avatar
 
Posts: 560
Joined: June 4th, 2008, 8:46 am
Location: Belgium (proud producer of waffles)

Post Posted October 30th, 2017, 2:22 pm

GHM113 wrote:
Sintendo wrote:Has a bug been filed?

I came across this bug when watching this video at 1440p: https://www.youtube.com/watch?v=UzdNECcio54

Is this about the video stalling while the sound keeps playing ?
I only experience a little at the beginning with the one above.
This one, I experience a lot of video stalls while the sound plays just fine (at 1080p60).

Lurtz
 
Posts: 194
Joined: June 12th, 2016, 12:25 pm

Post Posted October 30th, 2017, 2:23 pm

Omega X wrote:https://bugzilla.mozilla.org/show_bug.cgi?id=1369263

Doesn't look like it landed yet.

streetwolf

User avatar
 
Posts: 2119
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted October 30th, 2017, 2:31 pm

Lurtz wrote:Stylo can now be used for the chrome: layout.css.servo.chrome.enabled

Omega X wrote:Looks like a few improvements landed in the last day or so.

Media Cache off the main thread

Can you name the ticket for that?


Check out the search engine icons on the search bar. Some of mine are huge.
Intel Core i7-8700K CPU @ 5GHz | Gigabyte Z370 AORUS Gaming 7 | Corsair 1000W PSU | Corsair H115i v2 CPU Cooler | Corsair 64GB RAM | EVGA GeForce GTX 1080 Ti FTW3 GAMING 11GB | DUAL ASUS PA249Q IPS 24" LCDs | 2-512GB Samsung 960 PRO M.2 | 2TB Seagate | Windows 10 Pro x64 | FIOS 1Gb Internet

GHM113

User avatar
 
Posts: 668
Joined: December 16th, 2015, 3:59 am
Location: Moscow, Russia

Post Posted October 30th, 2017, 2:32 pm

Peja Stija wrote:Is this about the video stalling while the sound keeps playing ?
I only experience a little at the beginning with the one above.

Yes! Video stalls at the beginning on my computer as well.
Peja Stija wrote:This one, I experience a lot of video stalls while the sound plays just fine (at 1080p60).

Lots of stalls on my computer as well.
I am an idiot. Sorry for my poor English. Current list of config tweaks: https://pastebin.com/1dCT4Cvp

Lurtz
 
Posts: 194
Joined: June 12th, 2016, 12:25 pm

Post Posted October 30th, 2017, 2:35 pm

streetwolf wrote:Check out the search engine icons on the search bar. Some of mine are huge.

That's already filed.

streetwolf

User avatar
 
Posts: 2119
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted October 30th, 2017, 2:45 pm

There's always reasons why a new feature has it's pref disabled. PROBLEMS.
Intel Core i7-8700K CPU @ 5GHz | Gigabyte Z370 AORUS Gaming 7 | Corsair 1000W PSU | Corsair H115i v2 CPU Cooler | Corsair 64GB RAM | EVGA GeForce GTX 1080 Ti FTW3 GAMING 11GB | DUAL ASUS PA249Q IPS 24" LCDs | 2-512GB Samsung 960 PRO M.2 | 2TB Seagate | Windows 10 Pro x64 | FIOS 1Gb Internet

Sintendo
 
Posts: 102
Joined: January 26th, 2012, 3:03 am

Post Posted October 30th, 2017, 3:13 pm

Peja Stija wrote:
GHM113 wrote:
Sintendo wrote:Has a bug been filed?

I came across this bug when watching this video at 1440p: https://www.youtube.com/watch?v=UzdNECcio54

Is this about the video stalling while the sound keeps playing ?
I only experience a little at the beginning with the one above.
This one, I experience a lot of video stalls while the sound plays just fine (at 1080p60).

Yeah, I think that's the one. I've disabled VP9 video for now.

A completely different issue, there's a persistent stutter in this video: https://tweakers.net/video/player/15903 ... super.html It also happens on Firefox 56.0.2, but not on Chrome.

Josa
 
Posts: 2657
Joined: July 28th, 2009, 4:52 pm

Post Posted October 30th, 2017, 3:21 pm


Return to Firefox Builds


Who is online

Users browsing this forum: DinGo and 4 guests