MozillaZine

FF v. 56.0.2 vulnerability? (Mac)

User Help for Mozilla Firefox
bMonaLisa
 
Posts: 16
Joined: June 12th, 2010, 11:49 am

Post Posted November 18th, 2017, 10:30 am

How vulnerable do I become if I remain on Firefox (mac) 56.0.2 for several months - instead of upgrading to 57.0 ?

I have a legacy extension.
Developer says he hopes to be able to make it compatible with v. 57 by beginning of next year.
However, I'd forgo that Extension if security is compromised by not getting further updates to v. 56

Would appreciate informed advice. Thanks....

Brummelchen
 
Posts: 4616
Joined: March 19th, 2005, 10:51 am

Post Posted November 18th, 2017, 10:33 am


bMonaLisa
 
Posts: 16
Joined: June 12th, 2010, 11:49 am

Post Posted November 18th, 2017, 10:58 am



Thanks for link...
I did read it carefully
and then re-read it
and read it again...
Don't understand in pragmatic terms whether I leave myself open by not upgrading.
Looks like I probably do...but I guess no one can advise...depends on how I use browser (very basic...internet surfing on english and spanish sites).

Omega X

User avatar
 
Posts: 8186
Joined: October 18th, 2007, 2:38 pm
Location: A Parallel Dimension...

Post Posted November 18th, 2017, 1:04 pm

bMonaLisa wrote:


Thanks for link...
I did read it carefully
and then re-read it
and read it again...
Don't understand in pragmatic terms whether I leave myself open by not upgrading.
Looks like I probably do...but I guess no one can advise...depends on how I use browser (very basic...internet surfing on english and spanish sites).


Those are known vulnerabilities that are patched in Fx57 and Fx-ESR 52.5. Yes you will leave your PC open to attack by continuing to use Fx56.

If you have legacy addons that do have updates for Firefox 57, then you benefit from upgrading to Fx57.

If you have legacy addons that are mission critical without an update for Fx57, its recommended to atleast move to the Extended Release 52.5.
Latest: Firefox/81.0.1 *ESR/78.3.0 - Mobile/81.1.1 - Thunderbird/78.2.2
Nightly: Nightly/83.0a1 - Mobile/GV 82.0a1 - Daily/83.0a1

elist74
 
Posts: 94
Joined: June 27th, 2013, 11:27 am

Post Posted November 18th, 2017, 2:02 pm

Also ff 57 gonna be vulnerable when ff 58 is out and when ff 59 is out , ff 58 gonna be vulnerable too.

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 13 guests