MozillaZine

The first official 20190102 builds are out

Discussion about official Mozilla Firefox builds
Josa
 
Posts: 3845
Joined: July 28th, 2009, 4:52 pm

Post Posted January 1st, 2019, 6:34 am

Previous Nightly Builds thread 20190101

The first official 20190102 NIGHTLY builds are out
.The Official Firefox 65 Beta 8 builds are not yet out

Previous NIGHTLY: 20190101 (Fx 66.0a1)
Previous BETA: 20181228 (Fx 65.0b7)

Mozilla Inbound Builds
Treeherder
Release Notes: NIGHTLY | BETA
Changelogs: NIGHTLY | BETA


Fixed:
    NIGHTLY +8
  1. #1517077 [Core:Graphics]-Remove cairo D2D backend [Uns][]
  2. #1516560 [Core:JavaScript Engine: JIT]-tryAttachDOMProxyUnshadowed assumes DOM proxies have static prototypes [Uns][]
  3. #1516727 [Core:SVG]-Having classes called SVGAngle and nsSVGAngle is confusing [All][]
  4. #1516980 [Core:SVG]-Move nsSMILCompositor and nsSMILTimedElement to the mozilla namespace [Uns][]
  5. #1517108 [Core:SVG]-Move SMILTimeContainer and some helper classes to the mozilla namespace [All][]
  6. #1517127 [Core:SVG]-Move nsSVGClass to the mozilla::dom namespace [Uns][]
  7. #1516448 [Toolkit:Add-ons Manager]-Remove the "categories-list" binding [Uns][]
  8. #1516876 [Toolkit:Autocomplete]-Remove the "autocomplete-richlistbox" binding [Uns][]

    Partial Landings/Diagnostic Patches:
    None

    Beta 7 -> Beta 8 Changelog +15
  1. #1374012
  2. #1515461
  3. #1505250 [Core:Audio/Video: Playback]-Intermittent dom/media/test/test_looping_eventsOrder.html | application crashed [@ mozilla::MediaDecoderStateMachine::LoopingDecodingState::HandleError(mozilla::MediaResult const&)] after Assertion failure: aError != NS_ERROR_DOM_MEDIA_END_OF_STREAM [Uns][]
  4. #1511235 [Core:Audio/Video: Playback]-invisible video decoding causes high CPU usage [Uns][[webcompat]]
  5. #1512597 [Core:CSS Parsing and Computation]-SVG fill: currentColor is incorrect if parent is an a:visited element [All][]
  6. #1516334 [Core:Graphics: Text]-Emoji with font-size > 8em not displayed [Mac][[gfx-noted]]
  7. #1504656 [Core:JavaScript: Internationalization API]-Locale fallback handling for Intl.RelativeTimeFormat doesn't work correctly [Uns][]
  8. #1513934 [Core:JavaScript: Internationalization API]-Import patch for ICU-20302 [Uns][]
  9. #1505482 [Core:Plug-ins]-Comcast does not allow login in Windows 7 [Win][]
  10. #1515548 [Core:WebRTC]-Crash [@ webrtc::DesktopCaptureImpl::Run ] provoked by {frameRate: {max: 0}} (divide by zero) [Mac][]
  11. #1513022 [Core:WebVR]-Crash in mozilla::gfx::VRProcessParent::Shutdown [Lin][]
  12. #1498823 [Core:Widget: Gtk]-Enter to submit text doesn't work in web.whatsapp.com on Linux [Uns][]
  13. #1516323 [Core:Widget: Gtk]-At least ibus won't set a modifier flag which indicates a key event is synthesized asynchronously in some environments [All][]
  14. #1515939 [Firefox:Search]-Fix styling of the submenu used to add new search engines [Uns][]
  15. #1466817 [Firefox:Site Identity and Permission Panels]-The "Edit Pop-up Blocker Options/Preferences" command should open the in-content preferences [Uns][]

Nightly 66 fixes since 20181210 (Gecko 65) ~654
Beta 65 fixes since 20181022 (Gecko 64) ~2181

Nightly Blog
Release Calendar
Release Tracking
MozRegression Guide
Last edited by Josa on January 7th, 2019, 8:57 am, edited 1 time in total.

Jgr9
 
Posts: 73
Joined: September 2nd, 2015, 12:51 am

Post Posted January 1st, 2019, 6:35 pm

My slow Nightly starts appear to be due to uBlock Origin.

I'm not surprised, as since FF's major add-on changes, Nightly had been usable at start but uBlock's blocking wouldn't start working for a while after starting and browsing in Nightly.

uBlock not being functional until later was annoying, but now it looks like Nightly holds off until uBlock is functional before Nightly will load a page/your homepage on start.

So currently for me, it takes a long time before Nightly is usable after starting it with uBlock enabled. But here's hoping Nightly/Firefox is finally heading back closer to the launch speed it had with uBlock back before the add-on changes.

Josa
 
Posts: 3845
Joined: July 28th, 2009, 4:52 pm

Post Posted January 1st, 2019, 6:57 pm

People, I'll be travelling the next few days. Everything will be back to normal on monday. Happy New Year!

Mouse4
 
Posts: 487
Joined: December 27th, 2017, 4:03 am
Location: Australia

Post Posted January 1st, 2019, 6:59 pm

i just wonder if Ublock Origin makes Nightly restarts Slow during Updates

Mouse4
 
Posts: 487
Joined: December 27th, 2017, 4:03 am
Location: Australia

Post Posted January 1st, 2019, 7:00 pm

Josa wrote:People, I'll be travelling the next few days. Everything will be back to normal on monday. Happy New Year!

Happy New Year Josa, have a safe Trip

toolong
 
Posts: 913
Joined: December 24th, 2011, 10:29 am

Post Posted January 1st, 2019, 7:10 pm

Mouse4 wrote:i just wonder if Ublock Origin makes Nightly restarts Slow during Updates



Slow? Nothing that I have noticed.

I do see that Nightly now installs the update before the restart. And that opening a 'new' tab causes a pause to load and display. Which I assumed was a design feature.

Am I missing something?

Mark12547

User avatar
 
Posts: 276
Joined: May 13th, 2017, 11:36 am
Location: Oregon, United States, Earth

Post Posted January 1st, 2019, 8:16 pm

The loading of extensions before opening web pages was a design decision because users of ad blockers don't want to see ads on their home pages, and that was the only way to make sure extensions that change content (ad blockers, script blockers, reddit enhancement, etc.) were launched first.

My machine is fast with lots of RAM, so I haven't noticed any slowdown in Firefox, not to be confused with my own slowdown in the past few decades. :)

One thing you might do is save your ad blocker options, uninstall uBlock Origin, restart Firefox, install uBlock Origin, restore your ad blocker options, and see if that improves restart time of Firefox. (A change in how extensions stores data wasn't always cleanly migrated.)

Fanolian
 
Posts: 856
Joined: February 21st, 2011, 10:14 am

Post Posted January 1st, 2019, 11:37 pm

After restarting Nightly, uBO doesn't always loads on my pinned tabs, which auto-reload after a restart.
Other extensions may have similar issues but I don't have many which modify the content.

tomatoshadow2

User avatar
 
Posts: 393
Joined: May 11th, 2017, 9:52 am

Post Posted January 2nd, 2019, 1:54 am

Also using Ublock Origin, haven't noticed any slow downs.

Are You A Wiiizard?
 
Posts: 379
Joined: August 30th, 2012, 4:27 am

Post Posted January 2nd, 2019, 7:01 am

Not seeing that issue with uBlock Dev but I am seeing issues with rendering pages with large amount of text where the page will just whitescreen and stay like that until I scroll to another area.

gwarser
 
Posts: 22
Joined: October 23rd, 2017, 10:24 am

Post Posted January 2nd, 2019, 9:07 am

Development version of uBO now have "suspendTabsUntilReady" feature enabled by default and uses "persistent startup listener" to prevent loading of pages before uBO will load all of the filter lists and will be ready to filter ads.

"persistent startup listener" description: https://bugzilla.mozilla.org/show_bug.cgi?id=1503721
"suspendTabsUntilReady" description: https://github.com/gorhill/uBlock/wiki/ ... perimental

streetwolf

User avatar
 
Posts: 2360
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted January 2nd, 2019, 2:20 pm

The first time I go to about:support I notice two things

1. There is some graphical glitches when it first displays
2. Multiprocess Windows shows 1/1 Unknown status

After this all appears fine when run again. Starts all over again when I exit and start Fx.

Confirm? Might be that about:support is now using Fluent.
Intel Core i9-9900K@5.16GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA GTX 1080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 4-512GB Samsung 970 PRO M.2 | 2TB Samsung 860 EVO | 480GB SanDisk USB Extreme900 | Windows 10 Pro | FIOS 1Gb

Are You A Wiiizard?
 
Posts: 379
Joined: August 30th, 2012, 4:27 am

Post Posted January 2nd, 2019, 3:09 pm

streetwolf wrote:The first time I go to about:support I notice two things
1. There is some graphical glitches when it first displays
2. Multiprocess Windows shows 1/1 Unknown status
After this all appears fine when run again. Starts all over again when I exit and start Fx.

Confirm? Might be that about:support is now using Fluent.

Didn't get any graphical glitches but I'm getting "Multiprocess Windows 1/1 Unknown status"

gwarser wrote:Development version of uBO now have "suspendTabsUntilReady" feature enabled by default and uses "persistent startup listener" to prevent loading of pages before uBO will load all of the filter lists and will be ready to filter ads.

Was disabled by default for me.

TheVisitor
 
Posts: 4886
Joined: May 13th, 2012, 10:43 am

Post Posted January 2nd, 2019, 4:22 pm

streetwolf wrote:The first time I go to about:support I notice two things

1. There is some graphical glitches when it first displays
2. Multiprocess Windows shows 1/1 Unknown status

After this all appears fine when run again. Starts all over again when I exit and start Fx.

Confirm? Might be that about:support is now using Fluent.


I see the same.

mdew

User avatar
 
Posts: 366
Joined: March 2nd, 2005, 2:34 am

Post Posted January 3rd, 2019, 4:32 pm

Has the graphic glitches, where the tab will go completely black? anyone else notices?

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 5 guests