MozillaZine

The first official 20190929 builds are out

Discussion about official Mozilla Firefox builds
Josa
 
Posts: 4212
Joined: July 28th, 2009, 4:52 pm

Post Posted September 29th, 2019, 7:56 am

Previous Nightly Builds thread 20190928

The first official 20190929 NIGHTLY builds are out
.The official Firefox 70 Beta 11 builds are not yet out

Previous NIGHTLY: 20190928 (Fx 71.0a1)
Previous BETA: 20190927 (Fx 70.0b10)

Mozilla Inbound Builds
Treeherder
Release Notes: NIGHTLY | BETA
Changelogs: NIGHTLY | BETA


Fixed:
    NIGHTLY +6
  1. #1582353 [Core:Audio/Video: Playback]-Make GPU/RDD decoder IPC methods use MozPromise [Uns]
  2. #1536747 [Core:Widget: Gtk]-[Wayland] Picture-in-picture video window is not always on top [Lin]
  3. #1583852 [Core:Widget: Gtk]-Don't draw titlebar corners mask for PIP window on X11 [Uns]
  4. #1584492 [Core:Widget: Gtk]-Set and propagate PIP window flag to nsWindow [Uns]
  5. #1583174 [DevTools:Debugger]-No breakable line available in actors/thread.js from BrowserContentToolbox [Uns]
  6. #1583424 [DevTools:Debugger]-Terminating a worker with breakpoint causes blank Debugger [Uns]

    Partial Landings/Diagnostic Patches:
    None

    Beta 10 -> Beta 11 Changelog +10
  1. #1581903
  2. #1582222 [Core:Audio/Video: cubeb]-Increasing YouTube player speed causes tab crashes without any debug trace [Uns]
  3. #1579585 [Core:CSS Parsing and Computation]-Crash in [@ OOM | large | mozalloc_abort | mozalloc_handle_oom | gkrust_shared::oom_hook::hook | std::alloc::rust_oom | std::collections::hash::map::HashMap<T>::try_resize<T> | std::collections::hash::set::HashSet<T>::insert<T>] [Win]
  4. #1316965 [Core:Disability Access APIs]-Associated label of file upload field (input type=file) in Firefox is not read by screen reader [Uns]
  5. #1581773 [Core:Widget: Gtk]-[Wayland] Bookmark popup panel disappears when opening a dropdown [Lin]
  6. #1577740 [Firefox:Address Bar]-"This time, search with" and prefs/options cog/gear icon use too faint a shade of grey as foreground colour on default theme [mac]
  7. #1578856 [Firefox:Address Bar]-browser.fixup.dns_first_for_single_words preference no longer works properly [All]
  8. #1581570 [Firefox:New Tab Page]-bug in spocs placement which causes spocs to not display after a dismiss until next restart [Uns]
  9. #1564248 [Firefox:Tracking Protection]-Double check if the contentblocking.exceptions probe was really needed [Uns]
  10. #1583225 [Web Compatibility:Interventions]-Import WebCompat GoFaster 6.1.0 sources [Uns]

Nightly 71 fixes since 20190901 (Gecko 70) ~1202
Beta 70 fixes since 20190708 (Gecko 69) ~2794

Nightly Blog
Release Calendar
Release Tracking
MozRegression Guide
Last edited by Josa on October 1st, 2019, 2:09 pm, edited 1 time in total.

streetwolf

User avatar
 
Posts: 2432
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted September 29th, 2019, 8:29 am

For the last week or so random pages will 'dim'. Could be a graphics card driver issue or an Fx issue. This doesn't happen in any other program. It doesn't happen very often but I'd like to see if anyone else is having this anomaly?
Intel Core i9-9900K@5.16GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA RTX 2080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 3-512GB Samsung 970 PRO NVMe | 2TB Samsung 860 EVO | 1TB Sabrent Rocket NVMe| Windows 10 Pro | FIOS 1Gb

Fanolian
 
Posts: 868
Joined: February 21st, 2011, 10:14 am

Post Posted September 29th, 2019, 10:27 am

Thanks for all the testings on https://my.hko.gov.hk.
Reading about TLS, I think it is a server issue. I guess not all HKO servers support TLS 1.2+. It may explain the intermittent errors.
Anyway, I filed a webcompat issue on this.

Omega X

User avatar
 
Posts: 8134
Joined: October 18th, 2007, 2:38 pm
Location: A Parallel Dimension...

Post Posted September 29th, 2019, 2:42 pm

streetwolf wrote:For the last week or so random pages will 'dim'. Could be a graphics card driver issue or an Fx issue. This doesn't happen in any other program. It doesn't happen very often but I'd like to see if anyone else is having this anomaly?


I have not seen that before. It could be a color calibration or driver issue.
Latest: Firefox/71.0 *ESR/68.3.0 - Mobile/71.0 - Thunderbird/68.3.0
Nightly: Nightly/73.0a1 - Mobile/73.0a1 - Daily/73.0a1

dickvl

User avatar
 
Posts: 52876
Joined: July 18th, 2005, 3:25 am

Post Posted September 29th, 2019, 2:58 pm

I noticed that my Tab bar moved to the top again in the current Nightly build.
I still have now empty space at the bottom of the #navigator-toolbox where the Tab should be and the Tab bar has its reduced height, so userChrome.css is working, but positioning the #TabsToolbar at the lower position via "position: absolute;" no longer works.
The Browser Toolbox shows that the rules are still applied, but do not seem to have effect.
Enabling and disabling the menu bar modifies the top value (30px / 0px)
Are there new CSS rules required or is this no longer possible?

Code: Select all
#TabsToolbar {
 -moz-box-ordinal-group: 1000!important
 position: absolute !important;
 bottom: 0 !important;
 width: 100vw !important;
}

dickvl

User avatar
 
Posts: 52876
Joined: July 18th, 2005, 3:25 am

Post Posted September 29th, 2019, 5:03 pm

OK.
I found this discussion on Reddit:
https://www.reddit.com/r/FirefoxCSS/com ... e_or_even/

Adding display:block like suggested works to fix this and have the Tabs back on bottom again.
Code: Select all
#TabsToolbar {
 -moz-box-ordinal-group: 1000!important
 position: absolute !important;
 bottom: 0 !important;
 width: 100vw !important;
 display: block !important;
}


layout.css.xul-box-display-values.survive-blockification.enabled

Bug 1580012 - Turn off blockification of `display: -moz-box` (behind a pref for now)
Bug 1582530 - Turn on `layout.css.xul-box-display-values.survive-blockification.enabled` by default

Virtual_ManPL

User avatar
 
Posts: 2010
Joined: July 24th, 2008, 5:52 am

Post Posted October 1st, 2019, 2:26 am

streetwolf wrote:For the last week or so random pages will 'dim'. Could be a graphics card driver issue or an Fx issue. This doesn't happen in any other program. It doesn't happen very often but I'd like to see if anyone else is having this anomaly?

Happened for me today 2 times, on tab swap whole website page (except 1 image) will go block in my case, it fixes itself when I move mouse pointer/cursor over it.

streetwolf

User avatar
 
Posts: 2432
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted October 1st, 2019, 7:26 am

Virtual_ManPL wrote:
streetwolf wrote:For the last week or so random pages will 'dim'. Could be a graphics card driver issue or an Fx issue. This doesn't happen in any other program. It doesn't happen very often but I'd like to see if anyone else is having this anomaly?

Happened for me today 2 times, on tab swap whole website page (except 1 image) will go block in my case, it fixes itself when I move mouse pointer/cursor over it.


Sounds exactly what I am experiencing. Are you overclocking your GPU at all?
Intel Core i9-9900K@5.16GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA RTX 2080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 3-512GB Samsung 970 PRO NVMe | 2TB Samsung 860 EVO | 1TB Sabrent Rocket NVMe| Windows 10 Pro | FIOS 1Gb

Virtual_ManPL

User avatar
 
Posts: 2010
Joined: July 24th, 2008, 5:52 am

Post Posted October 1st, 2019, 8:43 am

streetwolf wrote:
Virtual_ManPL wrote:
streetwolf wrote:For the last week or so random pages will 'dim'. Could be a graphics card driver issue or an Fx issue. This doesn't happen in any other program. It doesn't happen very often but I'd like to see if anyone else is having this anomaly?
Happened for me today 2 times, on tab swap whole website page (except 1 image) will go block in my case, it fixes itself when I move mouse pointer/cursor over it.
Sounds exactly what I am experiencing. Are you overclocking your GPU at all?

No, I'm overclocking only: CPU, FSB and RAM,
but it's stable, looking at results in: Memtest86+, MemTest64, Prime95, OCCT, LinX and IntelBurnTest.
I don't updated system and drivers for over 1 month, so they can't be cause of this.

I suspect some widely GFX issue in Firefox, not only related to WebRender which you're probably using as compositing.
BTW - in my case, I'm using Direct3D 11 (Advanced Layers) compositing with NVIDIA GeForce GTX 750 Ti.

Josa
 
Posts: 4212
Joined: July 28th, 2009, 4:52 pm

Post Posted October 1st, 2019, 2:10 pm


Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 3 guests