MozillaZine

Problems with include files

Discussion about official Mozilla Firefox builds
Tessai
 
Posts: 4
Joined: December 27th, 2002, 5:28 am

Post Posted December 27th, 2002, 5:38 am

I've been trying to compile Phoenix with AA fonts for the longest. However, I'm being haunted by a horde of errors coming out of the gfx/src/gtk/ directory of the Moz source. This is the error log that I created by running "make -f client.mk build 2>err.log" and then "grep -i 'no such file' err.log >find.log".



../../../dist/include/pref/nsIPref.h:10: nsISupports.h: No such file or directory
../../../dist/include/pref/nsIPrefService.h:10: nsISupports.h: No such file or directory
../../../dist/include/pref/nsIPrefBranch.h:10: nsISupports.h: No such file or directory
nsDeviceContextGTK.cpp:45: nsIServiceManager.h: No such file or directory
nsDeviceContextGTK.cpp:46: nsCRT.h: No such file or directory
../../../dist/include/gfx/nsIDeviceContext.h:43: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsCoord.h:42: nscore.h: No such file or directory
../../../dist/include/gfx/nsRect.h:48: nsUnitConversion.h: No such file or directory
../../../dist/include/gfx/nsRect.h:49: nsComObsolete.h: No such file or directory
../../../dist/include/widget/nsIWidget.h:41: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsColor.h:42: nscore.h: No such file or directory
../../../dist/include/gfx/nsColor.h:43: nsComObsolete.h: No such file or directory
../../../dist/include/widget/nsIMouseListener.h:43: nsISupports.h: No such file or directory
../../../dist/include/widget/nsIMenuListener.h:41: nsISupports.h: No such file or directory
../../../dist/include/string/nsString2.h:50: nscore.h: No such file or directory
../../../dist/include/string/nsBufferHandle.h:37: nsDebug.h: No such file or directory
../../../dist/include/string/nsBufferHandle.h:40: nscore.h: No such file or directory
../../../dist/include/string/nsCharTraits.h:65: nscore.h: No such file or directory
../../../dist/include/string/nsStringTraits.h:34: nscore.h: No such file or directory
../../../dist/include/string/nsLiteralString.h:28: nscore.h: No such file or directory
../../../dist/include/string/nsStr.h:211: nscore.h: No such file or directory
../../../dist/include/string/nsStr.h:212: nsMemory.h: No such file or directory
../../../dist/include/gfx/nsIRenderingContext.h:42: nscore.h: No such file or directory
../../../dist/include/gfx/nsIRenderingContext.h:43: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsIDrawingSurface.h:42: nscore.h: No such file or directory
../../../dist/include/gfx/nsIDrawingSurface.h:43: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsDeviceContext.h:45: nsCOMPtr.h: No such file or directory
../../../dist/include/gfx/nsDeviceContext.h:46: nsIAtom.h: No such file or directory
../../../dist/include/gfx/nsDeviceContext.h:47: nsVoidArray.h: No such file or directory
../../../dist/include/gfx/nsDeviceContext.h:48: nsIObserver.h: No such file or directory
../../../dist/include/gfx/nsDeviceContext.h:49: nsIObserverService.h: No such file or directory
../../../dist/include/gfx/nsDeviceContext.h:50: nsWeakReference.h: No such file or directory
../../../dist/include/gfx/nsDeviceContext.h:51: nsComObsolete.h: No such file or directory
nsDeviceContextGTK.h:43: nsUnitConversion.h: No such file or directory
../../../dist/include/view/nsIView.h:41: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsRenderingContextImpl.h:42: nsComObsolete.h: No such file or directory
nsRenderingContextGTK.h:43: nsUnitConversion.h: No such file or directory
../../../dist/include/gfx/nsFont.h:42: nscore.h: No such file or directory
../../../dist/include/gfx/nsFont.h:43: nsComObsolete.h: No such file or directory
nsRenderingContextGTK.h:47: nsCRT.h: No such file or directory
../../../dist/include/gfx/nsTransform2D.h:42: nscore.h: No such file or directory
../../../dist/include/gfx/nsTransform2D.h:44: nsUnitConversion.h: No such file or directory
../../../dist/include/gfx/nsTransform2D.h:45: nsComObsolete.h: No such file or directory
nsRenderingContextGTK.h:52: nsVoidArray.h: No such file or directory
../../../dist/include/gfx/nsGfxCIID.h:42: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsGfxCIID.h:43: nsIFactory.h: No such file or directory
../../../dist/include/gfx/nsGfxCIID.h:44: nsIComponentManager.h: No such file or directory
../../../dist/include/gfx/nsIRegion.h:42: nscore.h: No such file or directory
../../../dist/include/gfx/nsIRegion.h:43: nsISupports.h: No such file or directory
nsDrawingSurfaceGTK.h:46: nsCOMPtr.h: No such file or directory
../../../dist/include/gfx/nsIFontMetrics.h:42: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsIScreenManager.h:10: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsIScreen.h:10: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsIDeviceContextPS.h:39: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsIDeviceContextXPrint.h:40: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsIPrintSettings.h:10: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsIPrintOptions.h:10: nsISupports.h: No such file or directory
nsDeviceContextSpecG.h:46: nsVoidArray.h: No such file or directory
nsDeviceContextSpecG.h:47: nsCOMPtr.h: No such file or directory
../../../dist/include/gfx/nsIDeviceContextSpecPS.h:43: nsISupports.h: No such file or directory
../../../dist/include/gfx/nsIDeviceContextSpecXPrint.h:43: nsISupports.h: No such file or directory
nsDeviceContextSpecG.h:54: nsCRT.h: No such file or directory

I'm using gcc 2.95.6 and kernel version 2.4.18 (Slackware 8.0). When I run locate, the files that are "missing", are in fact in dist. I've been reading about these files, and from what I understand, they should be generated during the building process. I've been google'ing like mad for the past 2 weeks trying to get this error fixed, but no one seems to have had this problem. Any help in the right direction would be appreciated...

Tessai

crippled-bird
Guest
 

Post Posted December 27th, 2002, 3:23 pm

Well, I just got done compiling Phoenix with AA and I checked three of those files at random. I have them all in my sources. So can you compile Phoenix without AA support? What does your .mozconfig look like? Did you run a final CVS checkout with "make -f client.mk checkout MOZ_CO_FLAGS=-PA" ?

Tessai
 
Posts: 4
Joined: December 27th, 2002, 5:28 am

Post Posted December 27th, 2002, 5:18 pm

Well, I just got done compiling Phoenix with AA and I checked three of those files at random. I have them all in my sources. So can you compile Phoenix without AA support? What does your .mozconfig look like? Did you run a final CVS checkout with 'make -f client.mk checkout MOZ_CO_FLAGS=-PA'? wrote:



I tried again running the final checkout again before trying to build. This is the last line that runs:

c++ -o nsDeviceContextGTK.o -c -DNATIVE_THEME_SUPPORT -DOSTYPE="Linux2.4" -DOSARCH="Linux" -DOJI -D_BSD_SOURCE -DUSE_POSTSCRIPT -DUSE_XPRINT -DUSE_MOZILLA_TYPES -DMOZ_ENABLE_FREETYPE2 -I./. -I./.. -I./../shared -I./../freetype -I./../x11shared -I/usr/local/include -I/usr/X11R6/include -I/usr/X11R6/include/freetype2 -I -I../../../dist/include/xpcom -I../../../dist/include/string -I../../../dist/include/widget -I../../../dist/include/view -I../../../dist/include/util -I../../../dist/include/pref -I../../../dist/include/uconv -I../../../dist/include/unicharutil -I../../../dist/include/locale -I../../../dist/include/necko -I../../../dist/include/content -I../../../dist/include/layout -I../../../dist/include/imglib2 -I../../../dist/include/gfx -I../../../dist/include -I/home/tessai/CVS/mozilla/dist/include/nspr -I/usr/X11R6/include -I/usr/X11R6/include/freetype2 -fPIC -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -pedantic -Wno-long-long -pthread -pipe -DNDEBUG -DTRIMMED -O2 -march=i686 -I/opt/gnome/include/gtk-1.2 -I/opt/gnome/include/glib-1.2 -I/opt/gnome/lib/glib/include -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/nsDeviceContextGTK.pp nsDeviceContextGTK.cpp
make[5]: Leaving directory `/home/tessai/CVS/mozilla/gfx/src/gtk'
make[4]: Leaving directory `/home/tessai/CVS/mozilla/gfx/src'
make[3]: Leaving directory `/home/tessai/CVS/mozilla/gfx'
make[2]: Leaving directory `/home/tessai/CVS/mozilla'
make[1]: Leaving directory `/home/tessai/CVS/mozilla'

The error output is captured to file, and is the same as in my previous post. My .mozconfig looks like this:

export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --enable-strip
ac_add_options --enable-strip-libs
ac_add_options --enable-optimize="-O2 -march=i686"
ac_add_options --enable-xft

The procedure I followed is:

1.) wget'ing a nightly source tarball
2.) unpacking with "tar yxvf"
3.) running "cvs -d:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot checkout mozilla/client.mk" (to make sure I have the latest client.mk file)
4.) running "cvs -d:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot checkout mozilla/toolkit mozilla/browser"
5.) running "make -f mozilla/client.mk checkout MOZ_CO_FLAGS=-PA" (to make sure all components are up to date)
6.) running "cd mozilla && make -f client.mk build"

From what I understand, I've followed the directions given on most sites. If I've done anything wrong, please let me know.

Tessai

Tessai
 
Posts: 4
Joined: December 27th, 2002, 5:28 am

Post Posted December 28th, 2002, 5:58 am

I decided to try to compile Phoenix without AA fonts and have been successful. I don't know why I would be successful compiling without AA fonts, but not with (but, then again, this is my first attempt at compiling a browser from source). There must be something that I'm missing. I would appreciate another push in the right direction. It just has to be something simple.

Thank you for the help so far...

Tessai

crippled-bird
Guest
 

Post Posted December 28th, 2002, 5:15 pm

I'm just going to toss a couple things out. Where did your Xft.h come from? I had to copy the Xft.h from the fontconfig package over my distributions Xft.h, because the compiler wanted to use the Xft.h that came with my distribution, but needed the one from fontcomfig. My error was about unresolved symbols, though. And what fontconfig do you have installed? Did it come with Slackware or did you compile it? Which version?

Good luck,

- C Bird

Tessai
 
Posts: 4
Joined: December 27th, 2002, 5:28 am

Post Posted December 28th, 2002, 6:02 pm

I compiled Xft2 from FontConfig 2.0. The Xft.h reads v 1.28, which is the same version that was in the FC 2.0 tarball. FC 2.1 seems to have a broken Xft2 source file. Every time I try to compile Xft2 from FC 2.1, it fails with unresolved symbols.

Thanks for giving me more pointers... Hopefully I'll get this solved soon...

Tessai

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 4 guests