MozillaZine

What preference can make mozdev.org think Javascript is off

Discussion about official Mozilla Firefox builds
mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 2:41 am

I have narrowed a problem I am having down to my prefs file. I have no extensions installed. When I use a default created prefs file, I can add Search Engine plugins from the following page: http://mycroft.mozdev.org/download.html ... orm=Search , no problem.

If I use my backed up prefs file, I get redirected to the following page whenever I click on one of them to try to install any of the Search Engine plugins: http://mycroft.mozdev.org/jsreq.html

It states that "JavaScript must be enabled to install a search plugin.
If you have installed NoScript, you will need to allow this page to run scripts."

This is a tall task to have to go through one's prefs file setting by setting to figure out the problem, so I am asking here, because I can't figure out what it could be, and I thought you guys might know which probable preference it might be.

mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 2:43 am

Oh, and btw, Javascript IS enabled.

Guest
Guest
 

Post Posted March 4th, 2008, 2:58 am

Can you upload or post the contents of the prefs.js file?

mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 3:05 am

yep. http://umsis.miami.edu/~medmunds/prefs.js

Make note that there are a lot of extension settings in there, but I don't have any of the extensions installed, so it shouldn't matter.

Guest
Guest
 

Post Posted March 4th, 2008, 3:12 am

Code: Select all
user_pref("capability.policy.maonoscript.Clipboard.cutcopy", "allAccess");
user_pref("capability.policy.maonoscript.Clipboard.paste", "allAccess");
user_pref("capability.policy.maonoscript.checkloaduri.enabled", "allAccess");
user_pref("capability.policy.maonoscript.javascript.enabled", "allAccess");
user_pref("capability.policy.maonoscript.sites", "...");


Try getting rid of those and remove all of the extension preferences.

Guest
Guest
 

Post Posted March 4th, 2008, 3:15 am

Also, I noticed that "javascript.enabled" is not present.

mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 3:52 am

Anonymous wrote:
Code: Select all
user_pref("capability.policy.maonoscript.Clipboard.cutcopy", "allAccess");
user_pref("capability.policy.maonoscript.Clipboard.paste", "allAccess");
user_pref("capability.policy.maonoscript.checkloaduri.enabled", "allAccess");
user_pref("capability.policy.maonoscript.javascript.enabled", "allAccess");
user_pref("capability.policy.maonoscript.sites", "...");


Try getting rid of those and remove all of the extension preferences.


Those may have just been session preferences, because they are no longer present in my prefs file.

mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 3:53 am

Anonymous wrote:Also, I noticed that "javascript.enabled" is not present.


hmm, that is weird, I see it in mine in about:config. Maybe I didn't upload the right prefs.js?
Last edited by mmortal03 on March 4th, 2008, 4:08 am, edited 1 time in total.

mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 3:55 am

Anonymous wrote:
Try getting rid of those and remove all of the extension preferences.


I am trying to avoid removing all of the extension preferences, as I don't know which are which. I could inadvertently reset the Firefox preference that is causing the problem, and it would get us no where. That is why I am posting here, because people here should know if there are any specifically Firefox settings that could be causing this.

Guest
Guest
 

Post Posted March 4th, 2008, 3:57 am

Close Firefox and upload user prefs.js again.

mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 4:02 am

Anonymous wrote:Close Firefox and upload user prefs.js again.


Yeah, that is the mistake that I made last time. However, I just realized that javascript.enabled is not going to be present if it is true, because that is the default value. Furthermore, I still see those entries you mentioned, however, they don't show up in about:config. I am going to go in an manually remove them from the prefs.js file and see what happens.

mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 4:08 am

Removed them, and still no fix. Here is my updated prefs.js: http://umsis.miami.edu/~medmunds/prefs.js

Guest
Guest
 

Post Posted March 4th, 2008, 4:24 am

I just had a thought. Check hostperm.1 in your profile for any script/mozdev entries.

Guest
Guest
 

Post Posted March 4th, 2008, 4:33 am

mmortal03 wrote: I still see those entries you mentioned, however, they don't show up in about:config.

CAPS preferences do not display in about:config.

http://kb.mozillazine.org/Caps

mmortal03
 
Posts: 385
Joined: January 29th, 2004, 9:08 am
Location: USA

Post Posted March 4th, 2008, 4:54 am

Anonymous wrote:I just had a thought. Check hostperm.1 in your profile for any script/mozdev entries.


Yeah, there were, but it doesn't matter, because I have tested it with a clean hostperm.1 (and just did again). Only when I introduce the prefs.js does the problem arise.

Return to Firefox Builds


Who is online

Users browsing this forum: Fanolian and 3 guests