MozillaZine

Facebook chat.

Discussion about official Mozilla Firefox builds
TheMunch8
 
Posts: 10
Joined: November 30th, 2004, 10:09 pm

Post Posted May 18th, 2008, 2:17 pm

I recently downloaded Firefox 3 RC1 and I keep having trouble with facebook's chat. It keeps going into an error, and this is in the error console. I am running Windows XP with SP2. Any ideas? is this something wrong with my setup, firefox, or facebook?

Error: uncaught exception: [Exception... "Not enough arguments [nsIDOMWindowInternal.postMessage]" nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)" location: "JS frame :: http://www.facebook.com/friends/?recent :: anonymous :: line 7" data: no]

michaell
 
Posts: 2417
Joined: November 4th, 2002, 4:47 pm
Location: London, UK

Post Posted May 18th, 2008, 2:30 pm

It's a known issue. Facebook changed stuff in their chat to work in Firefox 3 beta versions, and stuff changed before Firefox 3 RC1, so now Facebook will have to change it again.

Bad enough to write website code for specific browsers, but to actually write code for specific beta features... :(

kliu0x52

User avatar
 
Posts: 569
Joined: October 18th, 2006, 2:23 pm
Location: .us

Post Posted May 18th, 2008, 3:11 pm

Rather, unfinalized HTML5 standards...

TheMunch8, you can track the progress of this here:
https://bugzilla.mozilla.org/show_bug.cgi?id=433183
My addons: NoRedirect | QuickDrag | URL Flipper | TabSubmit
Developers: Make sure to test your addons for RTL compatibility!

TheMunch8
 
Posts: 10
Joined: November 30th, 2004, 10:09 pm

Post Posted May 18th, 2008, 3:13 pm

thank you, that at least points me in the right direction. thanks

KrisSilver
 
Posts: 63
Joined: February 2nd, 2008, 4:38 am

Post Posted May 18th, 2008, 3:17 pm

Photo album numbering still doesn't work either.

TheMunch8
 
Posts: 10
Joined: November 30th, 2004, 10:09 pm

Post Posted June 9th, 2008, 9:02 pm

I am still somewhat having trouble, as people are claiming I go offline for extended periods of time when I still have the facebook website open. Any other reports of this?

Portfolioso

User avatar
 
Posts: 243
Joined: March 10th, 2008, 8:16 am
Location: Connecticut

Post Posted June 10th, 2008, 9:24 am

KrisSilver wrote:Photo album numbering still doesn't work either.


Are you using a Minefield build? If so, it's a Facebook bug because they try to detect your browser and can't recognize minefield. It works fine in FF3 release candidates and Firefox branded browsers. See this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=424831 (marked invaild)

kliu0x52

User avatar
 
Posts: 569
Joined: October 18th, 2006, 2:23 pm
Location: .us

Post Posted June 10th, 2008, 9:59 am

Portfolioso wrote:https://bugzilla.mozilla.org/show_bug.cgi?id=424831 (marked invaild)

Erm, why was that marked INVALID instead of moved to TE (evangelism)?
Edit: Ah, there's already a TE bug for that: https://bugzilla.mozilla.org/show_bug.cgi?id=419484
My addons: NoRedirect | QuickDrag | URL Flipper | TabSubmit
Developers: Make sure to test your addons for RTL compatibility!

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 5 guests