MozillaZine

How to remove "Please fill out this field" Firefox message

Discuss how to use and promote Web standards with the Mozilla Gecko engine.
lanoiabcn
 
Posts: 3
Joined: December 29th, 2014, 5:04 pm

Post Posted December 29th, 2014, 5:18 pm

Hello, I would like to know how can I remove the "Please fill out this field." message, that shows automatically in a newsletter form in my website:
- as a help tip popup (yellow box)
- when I click subscribe and the field is not filled

I'm using a wordpress. It's in two languages, and the "Please fill out.." message, it's shown always in the FF installed language.
It doesn't work with the translation plugin I'm using, so I need to disable the pop up from the web. Is it possible?? It only happens with Firefox. Other browsers don't have this message.

Thank you very much in advance

therube

User avatar
 
Posts: 20180
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted December 29th, 2014, 7:24 pm

URL?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

lanoiabcn
 
Posts: 3
Joined: December 29th, 2014, 5:04 pm

Post Posted December 30th, 2014, 3:06 am


Daifne
Moderator

User avatar
 
Posts: 123063
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted December 30th, 2014, 6:55 am

moved to Web Development

trolly
Moderator

User avatar
 
Posts: 39908
Joined: August 22nd, 2005, 7:25 am

Post Posted December 30th, 2014, 10:36 am

I'm not entirely sure but I think you can only disable it through removing the required attribute and implementing a client side verification.
Think for yourself. Otherwise you have to believe what other people tell you.
A society based on individualism is an oxymoron. || Freedom is at first the freedom to starve.
Constitution says: One man, one vote. Supreme court says: One dollar, one vote.

AlfonsoML
 
Posts: 387
Joined: September 6th, 2006, 1:39 pm

Post Posted December 30th, 2014, 2:25 pm

Other browsers don't have this message

Are you sure?
Which browsers have you tested?

I've checked and both Chrome and IE show the same warning

lanoiabcn
 
Posts: 3
Joined: December 29th, 2014, 5:04 pm

Post Posted December 30th, 2014, 4:03 pm

Safari doesn't show it

trolly
Moderator

User avatar
 
Posts: 39908
Joined: August 22nd, 2005, 7:25 am

Post Posted December 30th, 2014, 4:21 pm

Safari ignores the required attribute.
http://www.w3schools.com/tags/att_input_required.asp
Think for yourself. Otherwise you have to believe what other people tell you.
A society based on individualism is an oxymoron. || Freedom is at first the freedom to starve.
Constitution says: One man, one vote. Supreme court says: One dollar, one vote.

jscher2000

User avatar
 
Posts: 10784
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted December 31st, 2014, 6:22 pm

To use your own tooltip on the field, try adding this to your input:

title="Dirección de correo electrónico"

(in the relevant language, of course)

But I don't know whether you can control the language of the pop-up that appears when clicking Subscribe with the field blank.

Return to Web Development / Standards Evangelism


Who is online

Users browsing this forum: No registered users and 1 guest