MozillaZine

Error loading stylesheet (xslt from xml)

Discuss how to use and promote Web standards with the Mozilla Gecko engine.
JonRisdon
 
Posts: 2
Joined: February 28th, 2017, 10:32 am

Post Posted February 28th, 2017, 11:09 am

My VERY basic blog site http://www.jonrisdon.co.uk/blog/alt_blog.html shows a simple javascript-driven slideshow in an iFrame; each 'slide' is an iFrame within a div (with a fade attribute) that loads an xml file that is a link to the relevant blog post: click the link to load the blog post (target="_top"). This works fine in Safari & Chrome, but in Firefox 51, I keep getting the error message "Error loading stylesheet: An unknown error has occurred ()" in the iFrame. This is shown in the Inspector for the page under #document with the tag <parsererror>.

I ran a search for similar problems and only came up with 2, and they were both more than 6 years old with no answers; can anybody help please? If you need code, let me know, but it is easily found on the site! Thanks very much in advance, Jon.

DanRaisch
Moderator

User avatar
 
Posts: 117793
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 28th, 2017, 11:11 am

Moving to Web Development.

Lnwdz
 
Posts: 151
Joined: June 12th, 2012, 7:59 am

Post Posted March 2nd, 2017, 5:09 am

I made a local copy of this page:
http://www.jonrisdon.co.uk/blog/database/alt_blog181216.html

The error went away after I changed the output method from "html/xml" to "html" in altblogStyle.xsl.

I'm not a programmer, so my answer might not be right.

JonRisdon
 
Posts: 2
Joined: February 28th, 2017, 10:32 am

Post Posted March 2nd, 2017, 11:50 am

Hi Lnwdz. Thanks very much for taking the trouble to reply: I appreciate that. I might have saved myself some time if I'd checked your post earlier, but after checking out some sites on this issue, I came to the same conclusion myself, so it now seems to work in Firefox. Yay! The benefit for me is that I found the solution myself, but if I hadn't, your contribution would have solved it, so thanks again. I'm not a programmer either, by the way!

Jon

Return to Web Development / Standards Evangelism


Who is online

Users browsing this forum: No registered users and 1 guest