MozillaZine

Disable popups

Discuss building things with or for the Mozilla Platform.
JannuBl22t
 
Posts: 1
Joined: August 28th, 2013, 3:42 am

Post Posted August 28th, 2013, 3:45 am

Hey there!

I'm using Skybound Gecko with Xulrunner and C#.

What I pretty much want to do is disable those popups like "SSL certificate error" and when page is not found "blabla couldn't be found" errors.
I have absolutely no idea how to disable them.

What I have tried is:

Code: Select all
GeckoPreferences.User["browser.xul.error_pages.enabled"] = false;
            GeckoPreferences.User["security.enable_ssl2"] = true;
            GeckoPreferences.User["security.default_personal_cert"] = "Ask Never";
            GeckoPreferences.User["security.warn_entering_weak"] = true;
            GeckoPreferences.User["security.warn_viewing_mixed"] = true;
            GeckoPreferences.User["dom.disable_open_during_load"] = true;
            GeckoPreferences.User["dom.allow_scripts_to_close_windows"] = true;
            GeckoPreferences.User["dom.popup_maximum"] = 0;


Please help me out

Gatlarf
 
Posts: 1
Joined: September 17th, 2013, 2:14 pm

Post Posted September 17th, 2013, 2:22 pm

I just ran into the same problem. You need to set "browser.xul.error_pages.enabled" to true. That will give you an error page in the browser window instead of the annoying popups. Drop a line here if it helped.

Return to Mozilla Development


Who is online

Users browsing this forum: No registered users and 3 guests