MozillaZine

Thunderbird is sending the ip of my pc when sending emails

Discussion of general topics about Mozilla Thunderbird
garfy
 
Posts: 70
Joined: March 30th, 2010, 12:12 am

Post Posted June 4th, 2010, 10:34 am

Can i disable that?

Is that possible?

I dont want that in every email you can see my real ip adress

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted June 4th, 2010, 10:57 am

Use the Config Editor to set mail.smtpserver.default.hello_argument or to create it as a new String preference if it does not exist. Mine is set to: localhost   You can also set different values for different SMTP servers, if necessary.
Rod

rsx11m
Moderator
 
Posts: 14406
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted June 4th, 2010, 11:41 am

Note that this will only hide whatever Thunderbird adds as the greeting (which, by default on Windows, is the IP address of your local machine - thus, if it's behind a DSL or cable modem, it will be the internal-network address assigned by that modem). The address by which you are connected with the provider (i.e., the one used by the DSL or cable modem to talk to the rest of the world) is usually logged by the receiving server on your provider's side, thus there is no way to prevent that.

garfy
 
Posts: 70
Joined: March 30th, 2010, 12:12 am

Post Posted June 4th, 2010, 11:52 am

Rod Whiteley wrote:Use the Config Editor to set mail.smtpserver.default.hello_argument or to create it as a new String preference if it does not exist. Mine is set to: localhost   You can also set different values for different SMTP servers, if necessary.



can you please be more detailed, I am a newbie, I know where config is, but i need exact line please and exactly what to do (right click on that line and modify it ....????)

Thank you

rsx11m
Moderator
 
Posts: 14406
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted June 4th, 2010, 12:29 pm

You go into Tools > Options > Advanced > General and click Config Editor there (you got that far). Then, copy-paste the preference you need into the search bar or enter part of it. Most likely, this preference isn't found (if it is, simply double-click on the entry to modify it). From the right-click menu, use New > String, enter the preference name (Ok), and the preference value (another Ok). Send a message to yourself and verify in the source that the last "Received" header (i.e., the first of the sequence) contains the chosen string now rather than the IP address.

garfy
 
Posts: 70
Joined: March 30th, 2010, 12:12 am

Post Posted June 4th, 2010, 10:54 pm

Ok I created new string
mail.smtpserver.default.hello_argument

and set it to localhost, still it send s out ip, is there a way to fix this

garfy
 
Posts: 70
Joined: March 30th, 2010, 12:12 am

Post Posted June 4th, 2010, 10:58 pm

Received: from [123.xxx.xxx.199] (helo=localhost)
by box524.bluehost.com with esmtpa (Exim 4.69)
(envelope-from <admin@xxxxxxxxxxxx.org>)
id 1OKmMa-0004yr-7h

So this is not working i think

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted June 5th, 2010, 1:31 am

Thunderbird does not send out any Received header. You can see that by looking in your Sent folder. A Received header is created by a server when the message is received.
Rod

garfy
 
Posts: 70
Joined: March 30th, 2010, 12:12 am

Post Posted June 5th, 2010, 5:01 am

so how to hide that?

rsx11m
Moderator
 
Posts: 14406
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted June 5th, 2010, 5:37 am

Thunderbird sends out the "(helo=localhost)" information, the "Received: from [123.xxx.xxx.199]" is the stamp from the receiving server (i.e., this is beyond Thunderbird's control at this point as it happens after Thunderbird has handed off the message to the ISP's server for relaying). Thus sorry, but if the provider decides to disclose that address (and most do), it's part of the message header.

Return to Thunderbird General


Who is online

Users browsing this forum: No registered users and 2 guests