MozillaZine

eMail window often empty and message "Appendix no content"

Discussion of general topics about Mozilla Thunderbird
H. Friedrich
 
Posts: 2
Joined: August 5th, 2017, 9:33 am

Post Posted August 5th, 2017, 9:51 am

Thunderbird version: 52.2.1 - 32bit
OS: Win7
Account on own server: IMAP
Gigabit LAN to the server
FFTH internet access 100Mbit up/down
Language German

If I click through the eMails in my input folder, sometimes the eMail window is empty though the eMail has content. If I click another one and come back to the first, it's content is displayed suddenly.

Also if an eMail is shown, having an appendix, clicking this gives me a message "This appendix seems to have no content". Clicking it a second time gives the content.

This happens on several computers in our network since some weeks.

The behavior is not cruel but getting a bit on our nerves. So thanks for any hint :D

Harald Friedrich

tanstaafl
Moderator

User avatar
 
Posts: 43115
Joined: July 30th, 2003, 5:06 pm

Post Posted August 6th, 2017, 2:17 am

By appendix do you mean an attachment?

Use view -> message source or Control-G and look at the raw message source the next time this happens. It will be very user unfriendly but see if it appears to have a intact message body and attachments. It should have several Content-Type: headers, one near the subject and the other in the attachment. It may have more than that if if this problem only occurs in very complex messages where the actual message body is made up of multiple parts. Typically the first Content-Type header is set to multipart/related if that occurs.

https://en.wikipedia.org/wiki/MIME

What are the Content-Type headers set to?
What are the headers for the attachment? You should be able to recognize it due to the header specifying the filename. Its contents will typically be a big block of hex numbers all run together (due to base64 encoding the binary file so that it can be stored in a 7-bit ascii message).

Are there any types of messages (such as plain text messages with no attachments) that NEVER have this problem?

See if https://addons.mozilla.org/en-US/thunde ... src=search helps.

Try copying several of these troublesome messages to a new remote folder and see if you have the same problem with messages in that folder. I'm wondering if your problem is due to a corrupt inbox. Deleting inbox.msf or rebuilding the index file would not cure that (that only effects corrupted folder listings).

If the problem still occurs copy some of those messages to a new folder in "Local Folders" and see what happens. I'm suggesting that to try to rule out your IMAP server being the culprit.

H. Friedrich
 
Posts: 2
Joined: August 5th, 2017, 9:33 am

Post Posted August 6th, 2017, 11:22 am

Hello tanstaafl,

thanks for your answer. Yes I meant Attachment instead of Appendix. And yes the message contents look normal. It seems to happen only with bigger eMails above 2MB content and attachment.

If I look at the message source text, it seems to have normal headers and the multi-part MIME thing seems to be OK too. If I compare the raw contents of the 2 cases (the message is shown or not) then the raw contents are identical.

Unfortunately the problem does not occur reproducibly. Smaller eMails with no attachment tend to not to have that problem.

As the problem seems to be unknown here, I will have a closer look at our IMAP server. Maybe it is not delivering content in certain cases. Thanks again for your ideas.

Best regards, Harald Friedrich

makaiguy

User avatar
 
Posts: 16469
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted August 6th, 2017, 1:14 pm

If you have your anti-virus program configured to scan your outgoing mail, try turning off that option. Your recipients should all be scanning their incoming mail anyway so an outbound scan is redundant. Further, the time taken to scan, especially with large attachments, can mess up the timing between you and the SMTP server, resulting in errors.
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.4.0 ESR (64bit), TB 52.3.0 (32bit)║ Android 7.0/6.0.2: FF 56.0, No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

Return to Thunderbird General


Who is online

Users browsing this forum: No registered users and 3 guests