MozillaZine

forced Updates

Discussion of general topics about Mozilla Thunderbird
jamo2
 
Posts: 33
Joined: October 8th, 2017, 3:44 pm

Post Posted February 26th, 2018, 7:51 pm

A lot of ADD-Ons does only work with Thunderbird versions less then version 56.

For this reason we use version 55b2. But TB trys to update it to the version 58 ... it was needed to set not only automatic updates to NO, bat also seek for updates to no.

You have to change the update procedure. When an user installs an old version, TB does never force to update. On the first start (after the install of an older version of TB) TB does ask: "this is not the newest version of TB, doyou want to update to vers xx? Y / N"

UPDATES must never be forced. (Also not in firefox). Also not if the old installation was set to auto-update.

Thanks
Jamo2

DanRaisch
Moderator

User avatar
 
Posts: 119747
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 27th, 2018, 5:39 am

You have to change the update procedure.

Except we can't. This forum is not run by or formally associated with Mozilla. We're an independent user-helping-user community. See the disclaimer in the right hand column of this page.

Also, under menu path Tools->Options->Advanced->Update->have you checked the option to "Never check for updates"?
You can delete the Mozilla Maintenance program so that Thunderbird won't update without requesting to bypass he Windows User Account Control (UAC) dialog. https://support.mozilla.org/en-US/kb/wh ... ce-service

MdniteEagl
 
Posts: 26
Joined: March 27th, 2010, 6:48 pm

Post Posted March 4th, 2018, 2:03 pm

jamo2 wrote:A lot of ADD-Ons does only work with Thunderbird versions less then version 56.

For this reason we use version 55b2. But TB trys to update it to the version 58 ... it was needed to set not only automatic updates to NO, bat also seek for updates to no.

You have to change the update procedure. When an user installs an old version, TB does never force to update. On the first start (after the install of an older version of TB) TB does ask: "this is not the newest version of TB, doyou want to update to vers xx? Y / N"

UPDATES must never be forced. (Also not in firefox). Also not if the old installation was set to auto-update.

Thanks
Jamo2

Being that you are using beta versions of TB - the current official release is 52.6.0 - it's not surprising that the default setting is to force an update to the next beta release, as it likely has significant repairs. I tend to avoid betas for email, as opposed to web browsing... my emails are far more important and I prefer not to risk their security with beta software.
Windows 10 Pro 64-bit - Intel Xeon E5-1630 v3 quad-core - 32GB (4x8GB) 2400MHz DDR4 - Chrome 64.0/TB 52.6.0

WaltS48

User avatar
 
Posts: 3664
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted March 5th, 2018, 7:35 am

jamo2 wrote:A lot of ADD-Ons does only work with Thunderbird versions less then version 56.

For this reason we use version 55b2. But TB trys to update it to the version 58 ... it was needed to set not only automatic updates to NO, bat also seek for updates to no.

UPDATES must never be forced. (Also not in firefox). Also not if the old installation was set to auto-update.

Thanks
Jamo2


It appears to me that the solution to your problem is to not use a Beta version.

The current 59.0b2 has several bug and security fixes along with those fixed in 56, 57 and 58.

56 Beta Notes

57 Beta Notes

58 Beta Notes

59 Beta Notes
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

Return to Thunderbird General


Who is online

Users browsing this forum: No registered users and 3 guests