MozillaZine

StartupMaster Plugin Askining Twice for Signin

Discussion of general topics about Mozilla Thunderbird
marklang
 
Posts: 63
Joined: August 5th, 2004, 6:20 pm
Location: Pennsylvania

Post Posted December 15th, 2018, 3:14 pm

I have been using the StartupMaster plugin (now 1.6.5) for several years. I have several email accounts, and Thunderbird asks for my master password initially when it logs into each email account, forcing me to type it 6 times. This plugin nicely fixed that by asking once for the password before Thunderbird starts. For some reason, however, when I made the latest Thunderbird upgrade to 60.3.3, StartupMaster starting asking me for the password exactly two times every time I start the program. I am not sure if this is the place to ask questions about plugins, but I believe this is a common issue and many people use this plugin.

Any suggestions? Does anyone know if this was fixed in Thunderbird so StartupMaster might not be needed any more?
Mark Lang

DanRaisch
Moderator

User avatar
 
Posts: 120955
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 15th, 2018, 3:33 pm

Note that the extension has not been updated in 14 month so there may be issues when using it with the current versions of Thunderbird. That means that the correct way to ask the question would be to email the Startup Master author using the link on the extension's AMO page. https://addons.thunderbird.net/en-US/th ... tupmaster/

marklang
 
Posts: 63
Joined: August 5th, 2004, 6:20 pm
Location: Pennsylvania

Post Posted December 15th, 2018, 6:17 pm

Thanks. I did email the author several days ago, but no reply so far. I did note that he had updated the page to say it was compatible with Thunderbird through 61.*. I gather this was done so the new versions would not disable the plugin.
Mark Lang

morat
 
Posts: 3077
Joined: February 3rd, 2009, 6:29 pm

Post Posted December 15th, 2018, 7:55 pm

The extension asks me for the master password only once on startup and only once on restart.

I'm using 2 Gmail IMAP accounts.

There are no errors in the console.

StartupMaster 1.6.5
Thunderbird 60.3.3
Windows 7 SP1 32-bit

Perhaps, there is a conflict with another extension. Try disabling all extensions except the StartupMaster extension, then restart.

marklang
 
Posts: 63
Joined: August 5th, 2004, 6:20 pm
Location: Pennsylvania

Post Posted December 16th, 2018, 12:30 pm

Thanks for the feedback. I have 7 IMAP accounts. 5 are hosted on Google, and the others are independent ISPs. I tried disabling my plugins a few at a time. It did not seem to make a difference. I tried just removing StartupMaster. I got one password screen in a separate window as Thunderbird started (but the program started before I responded), and then one more (different looking) inside the program after it started. It appeared that I could just dismiss the first screen with no side effects. However, this is more inconvenient than typing the password twice into StartupMaster. When I tried to reinstall StartupMaster, Thunderbird would not let me until I changed the extensions.strict setting. Interesting this did not happen when I upgraded Thunderbird. Once reinstalled, I had the same behavior.

The Thunderbird error log says this occurs now only on Google accounts using the OAuth2 authentication. That applies to 5 of my accounts. The error log suggests the problem is fixed in Thunderbird 63. I will wait to see if the author of StartupMaster has any suggestions. Typing the password twice only on startup is something I can live with. It sounds like it will be fixed when Thunderbird 63 reaches a point of stable distribution.

Thanks again for the suggestions.
Mark Lang

morat
 
Posts: 3077
Joined: February 3rd, 2009, 6:29 pm

Post Posted December 16th, 2018, 1:41 pm

I'm not using Gmail OAuth2 authentication.

Multiple requests for master password when Gmail OAuth2 is enabled
http://bugzilla.mozilla.org/show_bug.cgi?id=1176399
http://bugzilla.mozilla.org/show_bug.cgi?id=1176399#c126

For reading only as Bugzilla is not a forum.

Jorg K wrote:The bug has just been fixed in TB 63 available as Daily. You will see more activity in this bug when it gets backported to TB 60.

I think the developers may backport the fix to Thunderbird 60.

marklang
 
Posts: 63
Joined: August 5th, 2004, 6:20 pm
Location: Pennsylvania

Post Posted December 16th, 2018, 3:53 pm

Thanks. Looks like it will be fixed in Thunderbird 60.1. Hopefully, that will come soon. I am not going to try the betas.
Mark Lang

DanRaisch
Moderator

User avatar
 
Posts: 120955
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 17th, 2018, 8:15 am

Looks like it will be fixed in Thunderbird 60.1.

???
Thunderbird release version is already at 60.3.3.

marklang
 
Posts: 63
Joined: August 5th, 2004, 6:20 pm
Location: Pennsylvania

Post Posted December 17th, 2018, 8:25 am

So you are correct. The Bugzilla log suggests it has been fixed, but apparently it has not. As I noted, I tried removing StartupMaster, and I still got two requests for the password, one in a separate window on startup and one on top of the opening page of startup. That is better than asking for the password for every account, but still not fixed -- at least in the public releases.
Mark Lang

marklang
 
Posts: 63
Joined: August 5th, 2004, 6:20 pm
Location: Pennsylvania

Post Posted January 12th, 2019, 9:38 am

I found another plugin called Master Password + that appears to fix the issue. I removed Startup Master and installed Master Password +. This one was last updated in Oct 2018. You must go into settings and turn on ask for master password at startup since it is not set by default. However, after doing that, I only get asked for my password once right before Thunderbird starts. This plugin has additional features such as an option to require one to re-enter the password after a given time, but I am not using any of the other features.
Mark Lang

Return to Thunderbird General


Who is online

Users browsing this forum: No registered users and 4 guests