MozillaZine

Enigmail and word wrapping issue

Discussion of general topics about Mozilla Thunderbird
drProzac

User avatar
 
Posts: 13
Joined: February 16th, 2007, 3:28 pm
Location: Poland

Post Posted February 17th, 2007, 7:49 am

Hi !

I was trying to register to mozdev.org forums but seems the registration engine fails and my account is still inactive though I have received an activation e-mail notification.

So I decided to write here and ask you for help.
Have you ever noticed any word wrapping problems when using Enigmail PGP extension ?
Even if PGP is not activated for a given account all my messages written in plain text have incorrect line-breaks.
I've noticed the line-break points are inserted automatically according to line ends in composed message. That's why all received messages have incorrect display.

I'll be glad if can share your own experiences concerning this subject.
Regards,
Prozac

Nikolaki
 
Posts: 4
Joined: August 25th, 2004, 2:40 pm
Location: New Orleans

Post Posted March 8th, 2007, 7:22 am

Did you ever find answer/solution ?
I've got similar problems

Orbital75

User avatar
 
Posts: 57
Joined: May 1st, 2006, 8:59 am
Location: Planet Earth

Post Posted March 8th, 2007, 8:09 am

I'm having the same issue.

I Have the Enigmail PGP extension installed but didn't even think that this may be causing it.
Now that you mention it, it started about the same time I installed it.
We may have found a bug.

When I send text to others, this is what they receive. ( look Below )
------------------------------------------------------------------
You know, I'm glad you wrote me on this. You made me think about
something.
If I add that 3rd party part, I bet it will VOID my frame warranty if
something bad happens.
Very Very Sneaky on Marin part. This would keep me from claiming anything
valid against them.

Thanks Dan. I just wrote and told them to put all this in
writing.
I'll print it out in case something happens.
--------------------------------------------------------------------

Is this the same as what your experiencing.

Here is the link to what I posted earlier about this Word Wrap issue.
http://forums.mozillazine.org/viewtopic ... 72#2786072
Last edited by Orbital75 on March 8th, 2007, 12:38 pm, edited 3 times in total.
Orbital

drProzac

User avatar
 
Posts: 13
Joined: February 16th, 2007, 3:28 pm
Location: Poland

Post Posted March 8th, 2007, 9:06 am

Hello friends !

Well, a few weeks ago I decided to post the same report at official 'Enigmail User Forums'. Have a look at this topic.
Unfortunately I didn't get any reply.
I think it would be good if you could also write something in that topic as it seems we are the only persons who discovered this bug.

Cheers !
Regards,
Prozac

Orbital75

User avatar
 
Posts: 57
Joined: May 1st, 2006, 8:59 am
Location: Planet Earth

Post Posted March 10th, 2007, 2:37 pm

I wrote the author of the Software and this is his reply.

I think that your problem is that you write HTML mails, even though the messages are simple plain text. Unfortunately, HTML mails are not compatible with inline PGP, such that several workarounds are needed. There is nothing I could do that I didn't try in the last 5 years to fix these issues. Just note that if you enable flowed mails, then your signatures are _very_ likely invalid if you send signed unencrypted inline PGP mails.

The only recommendation I have is:
* set message composition to NOT HTML mails
* set line wrapping to 72 characters or less
Orbital

drProzac

User avatar
 
Posts: 13
Joined: February 16th, 2007, 3:28 pm
Location: Poland

Post Posted March 10th, 2007, 2:56 pm

Thank you Orbital75.
Seems the author did not understand the real problem.
Even if a given message is not PGP encrypted and even if PGP is inactive for a given account there is a problem with wrapping lines, no matter if we use html or a plain text. The only solution is to completely uninstall the Enigmail extension. Then everything backs to a normal state. This is what I wrote at Enigmail's forum but did not receive any reply till now.
Seems the plugin (extension) - even if inactive - does something with each message and IMO it is a bug.
Regards,
Prozac

tanstaafl
Moderator

User avatar
 
Posts: 39092
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted March 10th, 2007, 5:35 pm

http://enigmail.mozdev.org/userprefs.html mentions

"Wrap HTML messages before sending inline PGP messages
user_pref("extensions.enigmail.wrapHtmlBeforeSend",true);

UI: Enigmail > Preferences > Sending; Rewrap signed HTML text before sending
On by default"

https://bugzilla.mozilla.org/show_bug.cgi?id=282378 states "tb 1.0 (20041215) with enigmail support signs mails before wrapping lines longer than 72 chars here, which breaks the signature. it should wrap the lines first. an annoying workaround is to wrap all lines manually." However, its marked resolved and expired.

http://mozdev.org/bugs/show_bug.cgi?id=11885 is the only one I found about wrapping and it doesn't seem relevant. Could somebody submit a bug report per the instructions at http://enigmail.mozdev.org/bugs.html ?

Return to Thunderbird General


Who is online

Users browsing this forum: Bing [Bot] and 4 guests