MozillaZine


TB3 "Classic" theme to restore old icon set and more...

Discussion about official Mozilla Thunderbird builds
zamula
 
Posts: 102
Joined: January 31st, 2009, 8:59 pm

Post Posted September 14th, 2009, 5:36 pm

jmozmoz wrote:
zamula wrote:So you want me to add it the primaryToolbar.css, with something like this, but with the old icons in my theme:
Code: Select all
#button-archive {
  -moz-image-region: rect(0px 480px 24px 456px);
}
#button-archive:hover {
  -moz-image-region: rect(24px 480px 48px 456px);
}
#button-archive[disabled] {
  -moz-image-region: rect(48px 480px 72px 456px) !important;
}

I'll try to do that in the next few days, but I've been quite busy and would like to wait until the last-minute flurry of changes settles down.

Exactly :D


It looks like the archive button code was added in the latest nightly. My latest version seems to work fine with 0.7.0 of CompactHeader.

zamula
 
Posts: 102
Joined: January 31st, 2009, 8:59 pm

Post Posted September 14th, 2009, 5:40 pm

Version 1.0.9 is now available!

Updated with latest changes from default theme (Gloda search results page fixed).
Updated primary toolbar icons to be compatible with latest changes to default theme (archive button restored).
Removed all CSS that modifies header pane to ensure compatibility with CompactHeader.

C@rb0n
 
Posts: 1428
Joined: February 19th, 2005, 11:22 am

Post Posted September 16th, 2009, 11:40 pm

Thanks, zamula. Updated and so far all is well.

TonyE

User avatar
 
Posts: 333
Joined: March 28th, 2004, 3:51 pm
Location: Australia

Post Posted September 25th, 2009, 1:13 am

For some reason I cannot get this theme to work on my TB 3B4 any suggestions. In fact when I went to restore the theme back to default my system locked up for a few minutes. The formatting icons are all blank with this theme, they are just greyed out and it does not change the default tool bar, I get no icons at all just like the default one??
"I want to know God's thoughts... ...the rest are details"
Albert Einstein

zamula
 
Posts: 102
Joined: January 31st, 2009, 8:59 pm

Post Posted September 25th, 2009, 1:16 pm

I have no idea what the issue could be. When I get a chance I'll update the theme again to incorporate any new changes to the default. Something you could try, is see if the same problem happens on a new profile with no extensions.

C@rb0n
 
Posts: 1428
Joined: February 19th, 2005, 11:22 am

Post Posted September 30th, 2009, 9:03 am

@zamula: FYI, a recent check-in has broken header icon display in today's Shredder nightly. Now all icons are showing up in the header. :(

Thanks

rsx11m
Moderator
 
Posts: 14430
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted September 30th, 2009, 9:50 am

Lots of patches were checked in last night due to the final string freeze taking effect (yes, no more label changes for the entire 3.0 release series), thus no surprise that this breaks various extensions.

zamula
 
Posts: 102
Joined: January 31st, 2009, 8:59 pm

Post Posted September 30th, 2009, 9:55 am

Hopefully soon I'll get a chance to fix my theme based on this last set of changes.

zamula
 
Posts: 102
Joined: January 31st, 2009, 8:59 pm

Post Posted September 30th, 2009, 2:28 pm

New version up that works again!

C@rb0n
 
Posts: 1428
Joined: February 19th, 2005, 11:22 am

Post Posted September 30th, 2009, 4:51 pm

Thanks, zamula. Working great so far.

OveSentlig
 
Posts: 2
Joined: December 7th, 2004, 6:27 am

Post Posted October 2nd, 2009, 11:27 pm

Hi,
I get a 403 Error when trying to download through the link in the first post. (WinXP, FF)
Any clues?

--
Ove S.
--
Ove Sentlig

zamula
 
Posts: 102
Joined: January 31st, 2009, 8:59 pm

Post Posted October 4th, 2009, 3:07 pm

Hmmm...just noticed a duplicate file, so I re-uploaded with a new link: http://www.sendspace.com/file/kt1io9

zamula
 
Posts: 102
Joined: January 31st, 2009, 8:59 pm

Post Posted October 6th, 2009, 10:49 am

Please note I just uploaded a new build that incorporates some of the most recent default theme changes in the nightly builds.

zamula
 
Posts: 102
Joined: January 31st, 2009, 8:59 pm

Post Posted October 6th, 2009, 3:12 pm

Yet another update because I noticed the right pane icons were truncated when clicking on items such as "Mail" etc. I used the new icons in the default theme since they fit.

C@rb0n
 
Posts: 1428
Joined: February 19th, 2005, 11:22 am

Post Posted October 29th, 2009, 6:05 am

Hi zamula,

Any chance of compatibility with CustomizeHeaders 0.99.2? I think the following incompatibility may be due to TB3 "Classic" theme. See post here: viewtopic.php?p=7856055#p7856055

Thanks

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 1 guest