MozillaZine


Not so new addon to compact header pane in Thunderbird

Discussion about official Mozilla Thunderbird builds
jmozmoz
 
Posts: 365
Joined: August 3rd, 2009, 12:28 pm

Post Posted November 15th, 2009, 5:59 am

Eriatile wrote:I stil have the forward button bigger than other with version 0.99.5.
Is it possible to fix it the same way than print and mark buttons ?

Image

What operating system are you using? Here the forward button has not drop down menu:

Image

Perhaps another add-on is changing the forward button?

lesm
 
Posts: 8
Joined: December 10th, 2005, 6:24 pm

Post Posted November 15th, 2009, 8:56 am

jmozmoz wrote:
lesm wrote:The Release Notes for version 0.99.0 says: ... This version works with Thunderbird 3.0pre. For older versions (Thunderbird 3.0 beta 4) use the version 0.8.x.

Something is wrong here. I tried version 0.8.x on TB 3.0beta4 and didn't work okay. Instead I use version 0.9.0 from http://www.stathy.com/mozdev/compactheader/ and works just fine.

I tried again with Thunderbird 3.0 beta 4 and a fresh profile. The version 0.8.3 of the add-on worked. Version 0.9.0 also works (somehow): The buttons in the header pane cannot be changed: Neither display the icons nor remove some or all of them.

Could you please try with a fresh profile.


I'm late. Sorry.
Yes, you're right. I forgot to mention that I use the "Phoenity Shredder" 3.3.85 theme and that my only interest is to make the headers short. So it doesn't matter what the icons behavior is (for a while). Actually I use TB to read NG's only.
Thanks.
Anyhow, I'm looking forward to the definitive TB 3.0 compliant version.

Eriatile
 
Posts: 84
Joined: December 27th, 2003, 7:28 am

Post Posted November 15th, 2009, 3:31 pm

jmozmoz wrote:What operating system are you using? Here the forward button has not drop down menu:

Image

Perhaps another add-on is changing the forward button?


You're right it was one of my addon : forwardas.
Disabling it solved the issue.

jmozmoz
 
Posts: 365
Joined: August 3rd, 2009, 12:28 pm

Post Posted November 15th, 2009, 4:41 pm

Eriatile wrote:You're right it was one of my addon : forwardas.
Disabling it solved the issue.

With the version 0.99.6 you should be able to use this add-on.

C@rb0n
 
Posts: 1428
Joined: February 19th, 2005, 11:22 am

Post Posted November 15th, 2009, 5:30 pm

@jmozmoz: Any chance of flat buttons option again?

GiraffePC

User avatar
 
Posts: 30
Joined: December 11th, 2008, 3:29 pm

Post Posted November 16th, 2009, 6:32 am

jmozmoz wrote:
Eriatile wrote:You're right it was one of my addon : forwardas.
Disabling it solved the issue.

With the version 0.99.6 you should be able to use this add-on.


Yes, updated Shredder yesterday and had to get 0.99.6 - now working perfectly.

rphunter
 
Posts: 7
Joined: November 29th, 2003, 1:46 pm

Post Posted November 25th, 2009, 5:31 pm

The 99.8 version of the compact header extension works fine with TB3.0RC1 on my Windows XP netbook, but fails on my desktop machine which runs Windows 7 64 bit. The failure is that when I click on the - icon, the header area disappears completely, and won't come back.
Is there anything I can do, or check to help resolve this problem?
Ron Hunter

Tuxman
 
Posts: 646
Joined: August 23rd, 2004, 11:53 am

Post Posted November 25th, 2009, 5:40 pm

With v0.99.8 (Tb3.0rc1, Silvermel theme), the Compact Header button looks broken:

Image

Image

Is that intended?

C@rb0n
 
Posts: 1428
Joined: February 19th, 2005, 11:22 am

Post Posted November 25th, 2009, 6:20 pm

Tuxman wrote:With v0.99.8 (Tb3.0rc1, Silvermel theme), the Compact Header button looks broken:
...
Is that intended?

Since it works properly with the default theme, you should be contacting the developer of the non-default theme you are using.

Tuxman
 
Posts: 646
Joined: August 23rd, 2004, 11:53 am

Post Posted November 25th, 2009, 6:33 pm

Since other add-ons work properly with Silvermel, I presume the add-on author could look at his styles again. :)

C@rb0n
 
Posts: 1428
Joined: February 19th, 2005, 11:22 am

Post Posted November 25th, 2009, 7:03 pm

Tuxman wrote:Since other add-ons work properly with Silvermel, I presume the add-on author could look at his styles again. :)

Maybe, but not necessarily. For example: I use the TB3 Classic theme, which was compatible with all my other extensions, but breaking with CompactHeader. It is now fully compatible, because the TB3 Classic author made the appropriate modifications to his theme.

Tuxman
 
Posts: 646
Joined: August 23rd, 2004, 11:53 am

Post Posted November 25th, 2009, 7:17 pm

Previous CH versions worked with Silvermel, so I also doubt that. :)

C@rb0n
 
Posts: 1428
Joined: February 19th, 2005, 11:22 am

Post Posted November 25th, 2009, 7:48 pm

Tuxman wrote:Previous CH versions worked with Silvermel, so I also doubt that. :)

Was the same kind of experience with TB3 Classic, but it's your choice.

CatThief

User avatar
 
Posts: 1854
Joined: January 19th, 2004, 12:19 am
Location: Northeast USA

Post Posted November 25th, 2009, 9:16 pm

C@rb0n wrote:
Tuxman wrote:With v0.99.8 (Tb3.0rc1, Silvermel theme), the Compact Header button looks broken:
...
Is that intended?

Since it works properly with the default theme, you should be contacting the developer of the non-default theme you are using.


We are going to see a lot of these issues with 3rd-party themes, including my own. Unless a theme uses the same code as the default theme for message headers, stuff is surely going to break. Any theme that heavily stylizes the headers will not be compatible with this extension.

Should we blame the extension developer? NO. Should we blame the theme developer? NO. It's a simple matter of conflicting code and has nothing to do with right or wrong. I intend to forewarn users of my own Tb3 theme that CompactHeader was developed for Tb's default theme, intended to enhance Tb's default theme headers code. Plain and simple, not all extensions work with all themes, and not all themes work with all extensions.
Still passionate for Mozilla themes and extensions, just not actively developing them for public release anymore.

jmozmoz
 
Posts: 365
Joined: August 3rd, 2009, 12:28 pm

Post Posted November 26th, 2009, 3:35 am

rphunter wrote:The 99.8 version of the compact header extension works fine with TB3.0RC1 on my Windows XP netbook, but fails on my desktop machine which runs Windows 7 64 bit. The failure is that when I click on the - icon, the header area disappears completely, and won't come back.
Is there anything I can do, or check to help resolve this problem?
Ron Hunter

I am using Windows 7 64 bit myself and it seems to work. So it's not the operating system.

Could you please check if you see any error messages in the error console (Tools->Error Console)?

Another thing to check is whether it works if you start with a fresh profile? If so the localstore.rdf of your old profile can be manually cleaned up (remove all references to "customizeToolbar").

Perhaps it is also enough to just uninstall and then install the add-on.

By the way: Did you upgrade from a previous version (which?)?

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 2 guests