MozillaZine

TotalMessage- experimental html5 rewrite of Tb message pane

Discussion about official Mozilla Thunderbird builds
alta88
 
Posts: 980
Joined: January 28th, 2006, 3:08 pm

Post Posted August 22nd, 2011, 3:57 pm

the header font size follows whatever you have set in Options->Display. note that the font size in the actual message body can be increased/reduced with ctrl+/- (which will specifically not affect the header size). i also use Image Zoom to mouse scroll image sizes.

alta88
 
Posts: 980
Joined: January 28th, 2006, 3:08 pm

Post Posted August 28th, 2011, 10:23 am

TotalMessage-1.0rc6 has been released. Also on AMO here.

See the homepage for details.

mgagnonlv
 
Posts: 611
Joined: February 12th, 2005, 8:33 pm

Post Posted September 2nd, 2011, 12:14 pm

Hello,
I just experimented lately with the TotalMessage extension on Windows-based systems. Overall, I find it interesting and appreciate how easy it is to customize headers. Compared to the standard behaviour of Thunderbird, there is just one issue I find annoying:

– Without TotalMessage, it is possible to save attachments by dragging them off the message pane. So I drag attachments to the desktop or to the destination folder. Quite useful when destination is at somewhere deep, such as: P:\\volume1\Training Session\Course 1\Version 2011\Support files. Much faster and much friendlier than going through the "save as" dialog box!
– With TotalMessage, when I try the same, I get a link instead. The link has the same name as the attachment, but is actually a shortcut called mailbox://xxx or imap://xxx. Double-clicking on it brings a Windows warning: "Impossible to open: no protocol associated with..."

Could it be possible to configure TotalMessage in such a way that it would be possible to drag attachments?

Thanks.
Michel Gagnon

alta88
 
Posts: 980
Joined: January 28th, 2006, 3:08 pm

Post Posted September 3rd, 2011, 7:15 am

thanks for the report, there are likely some remaining details to mop up..

it's an easy fix and will be in the next release.

mgagnonlv
 
Posts: 611
Joined: February 12th, 2005, 8:33 pm

Post Posted September 4th, 2011, 8:31 pm

Wonderful news!
Michel Gagnon

alta88
 
Posts: 980
Joined: January 28th, 2006, 3:08 pm

Post Posted September 27th, 2011, 12:35 pm

TotalMessage-1.0rc7 has been released. Also on AMO here.

See the homepage for details. If you've always wanted drag and drop message rethreading, take a look.

dnpyles
 
Posts: 8
Joined: July 1st, 2009, 6:33 am

Post Posted September 28th, 2011, 5:04 am

I upgraded to Thunderbird 7 yesterday and installed TotalMessage-1.0rc7. Now when I have a message selected in the header pane and displayed in the message pane and I delete or move the message, the header pane moves to the next message, but the message page does not load the new message. The only way I can get the message to load in the message pane is to click on another message in the header pane and then click on the message that did not originally load. Is anyone else seeing this problem.

alta88
 
Posts: 980
Joined: January 28th, 2006, 3:08 pm

Post Posted September 28th, 2011, 6:16 am

yes, that's a bug. to be fixed soon.

alta88
 
Posts: 980
Joined: January 28th, 2006, 3:08 pm

Post Posted September 29th, 2011, 9:22 am

A new TotalMessage-1.0rc7 has been uploaded to address some issues. Please redownload/reinstall.

dnpyles
 
Posts: 8
Joined: July 1st, 2009, 6:33 am

Post Posted September 29th, 2011, 9:42 am

Yes, that fixes the problem I mentioned above

mgagnonlv
 
Posts: 611
Joined: February 12th, 2005, 8:33 pm

Post Posted October 3rd, 2011, 10:00 am

Thanks for fixing the drag and drop feature. That's a wonderful improvement.

Now another problem, alas. Text-only and enriched messages (i.e. text with styles, but not full-HTML pages) display very quickly. However, some full-html messages that look like web pages take a really long time to appear.

For instance, my worst offender is the newsletter produced by Techrepublic. It takes almost 60 seconds to display, whether in the preview page or in a message window of its own. Sometimes it won't display at all (timeout error?); clicking on another message and clicking back on it will finally display the message after many seconds.
When I click on the message, I see a white rectangle where the preview should be (i.e. no headers, no footers, no nothing). Yet, if I press control-U, the full source of the message is displayed.

By comparison, when I disable the TotalMessage extension, the same messages load almost instantly. After reactivating the extension, Thunderbird has the same behaviour. All this with a POP account, so basic info of the message is already downloaded in my inbox.

If you want, I could post or email the source of the message (I'll edit my address and server name for obvious reasons).


EDIT. One last note – and that may be the problem – one of the images of that HTML-message doesn't download (broken link)
Michel Gagnon

alta88
 
Posts: 980
Joined: January 28th, 2006, 3:08 pm

Post Posted October 3rd, 2011, 1:34 pm

one thing i really dislike in native Tb is flickering of old messages when changing selection or tabs. so i made sure to immediately hide the old message, get the load, then show the new. there may be some tweaks in timing of various notifies etc. to display the pane better on new load.

if your particular email is very reproducible, please edit and pm me the .eml file. thanks for the well diagnosed report.

also, TM has very verbose logging. you can add/change pref TotalMessage.logging.console with value of either "debug" or "trace" if needed. but just the file will do this time.

anne.lavin
New Member
 
Posts: 1
Joined: October 4th, 2011, 9:46 am

Post Posted October 4th, 2011, 10:04 am

I'm using the latest TotalMessage (v1.0rc7) and Tb 6.0.2, and I'm still seeing the odd persistence of one message's attachment pane in other messages. I haven't managed to figure out if it's completely repeatable, but will keep poking at it; let me know if there's any particular info you want, or way you'd like me to test/report it.

And a related question: is there a way to specify that attachments be loaded in a helper application rather than in the attachment pane? (Is it picking up my firefox prefs?) Forgive me if it's obvious and I'm just missing it. I sometimes work on a netbook with a tiny screen, and loading, say, a whole PDF into a tiny skinny slip of a pane at the bottom of the window doesn't really work that well, I'd far prefer a separate window...

mgagnonlv
 
Posts: 611
Joined: February 12th, 2005, 8:33 pm

Post Posted October 4th, 2011, 1:57 pm

Anne,

Have you checked what is the "next" message you are trying to view when the old message remains visible? I wonder whether or not it is related to the bug I am describing two messages above yours.

As for the other question, the solution is relatively simple and doesn't depend on TotalMessage.
– Go under Tools –> Options and select the 5th tab: Attachments
– Normally, the extensions/mimetypes that are opened automatically by Firefox appear in that window.
So find the type of file extension you want, and modify its action.
Michel Gagnon

alta88
 
Posts: 980
Joined: January 28th, 2006, 3:08 pm

Post Posted October 4th, 2011, 2:09 pm

anne.lavin wrote:I'm using the latest TotalMessage (v1.0rc7) and Tb 6.0.2, and I'm still seeing the odd persistence of one message's attachment pane in other messages. I haven't managed to figure out if it's completely repeatable, but will keep poking at it; let me know if there's any particular info you want, or way you'd like me to test/report it.


i recall such an issue versions ago, but thought it fixed. is this in 3pane view or in a tab or message window? you could turn on logging (per above), and when it happens, copy the Error Console output (it's good to have Console2 so you can multiselect). one thing that is known, is if you (very) rapidly switch messages and time it just right, due to asynchronous loading of each pane and the fact that a switch doesn't cancel a prior select (yet), you may get headers mismatched with the body. but you almost have to try to get it to do that.

And a related question: is there a way to specify that attachments be loaded in a helper application rather than in the attachment pane? (Is it picking up my firefox prefs?) Forgive me if it's obvious and I'm just missing it. I sometimes work on a netbook with a tiny screen, and loading, say, a whole PDF into a tiny skinny slip of a pane at the bottom of the window doesn't really work that well, I'd far prefer a separate window...


TM lets you click on an attachment link and view the file inline in the pane (back button or alt-left arrow goes back), useful for fast preview (better in horizontal attachment view) of text and image files, but not for .pdf or .doc etc. to turn it off for pdf, disable the pdf plugin in addons manager. this isn't specific to TM.

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 1 guest