MozillaZine

TotalMessage- experimental html5 rewrite of Tb message pane

Discussion about official Mozilla Thunderbird builds
alta88
 
Posts: 998
Joined: January 28th, 2006, 3:08 pm

Post Posted October 4th, 2011, 8:12 pm

mgagnonlv wrote:Now another problem, alas. Text-only and enriched messages (i.e. text with styles, but not full-HTML pages) display very quickly. However, some full-html messages that look like web pages take a really long time to appear.
..
EDIT. One last note – and that may be the problem – one of the images of that HTML-message doesn't download (broken link)


i looked at this, with some feed messages that had heavy images (30s to load) and your NoGood.txt and GoodOne.txt. they took ~20s and 15s the first time and there was a broken image in NoGood. thereafter GoodOne took 1-2s and NoGood took ~20.

it worked about the same for both Tb w/wo TM. neither display any portion of the message until the load finishes completely. the big difference is that Tb always has a nice progress listener, so you know it's working or not, whereas with TM it's on for half the time and goes away and there is still a significant amount of time in limbo with a blank pane and no feedback (but it does come eventually after the broken image is given up on and the load event is received).

so, nothing to do (on the non core extension level), except having a more accurate progress feedback. note that only the first loads are slow if all images are successful (until a restart clears the cache) and if even 1 image is broken the rendering engine will try the full timeout length on each selection.

mgagnonlv
 
Posts: 713
Joined: February 12th, 2005, 8:33 pm

Post Posted October 5th, 2011, 10:01 am

Thanks for the feedback.
Michel Gagnon
Montréal (Québec, Canada)

alta88
 
Posts: 998
Joined: January 28th, 2006, 3:08 pm

Post Posted November 10th, 2011, 3:33 pm

TotalMessage-1.0rc8 has been released. Also on AMO here.

See the homepage for details.

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted November 10th, 2011, 6:33 pm

alta88 wrote:TotalMessage-1.0rc8 has been released. Also on AMO here.

See the homepage for details.

Not working in current trunk.
I never see the header view icon in the upper left of the header.
Error console:
Error: undefined entity
Source File: chrome://totalmessage/content/messenger.xul
Line: 88, Column: 7
Source Code:
<menuitem id="otherActionsOpenConversation"

Works fine in:
Mozilla/5.0 (Windows NT 5.0; rv:8.0) Gecko/20111103 Thunderbird/8.0 ID:20111103015904
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

alta88
 
Posts: 998
Joined: January 28th, 2006, 3:08 pm

Post Posted November 10th, 2011, 7:07 pm

JoeS wrote:
alta88 wrote:TotalMessage-1.0rc8 has been released. Also on AMO here.

See the homepage for details.

Not working in current trunk.
I never see the header view icon in the upper left of the header.
Error console:
Error: undefined entity
Source File: chrome://totalmessage/content/messenger.xul
Line: 88, Column: 7
Source Code:
<menuitem id="otherActionsOpenConversation"

Works fine in:
Mozilla/5.0 (Windows NT 5.0; rv:8.0) Gecko/20111103 Thunderbird/8.0 ID:20111103015904



right, there were a bunch of entity changes in Tb9 for this keystone kops fiasco, so rc8 and below are only for Tb8 and below.

i will be cutting 1.0 final shortly which will be for Tb9 and higher.

alta88
 
Posts: 998
Joined: January 28th, 2006, 3:08 pm

Post Posted November 11th, 2011, 1:24 pm

For Tb 9 and 10, TotalMessage v1.0 is here. It will be released officially when Tb 9 is released; this is meant for nightly compatibility only, which may change.

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted November 11th, 2011, 4:33 pm

I was aware of those needless entity changes and only tried 1.0rc8 because it was showing compatible with TB 11.0

Code: Select all
<em:minVersion>7.0</em:minVersion>
        <em:maxVersion>11.0a1</em:maxVersion>


You might want to change the maxVersion in those distributions, as it looks like the extension is broken.

The new nightly compatible build is working ok here, but after a false start where I had to disable extensions then switch from layout wide view to the classic view.
Starting with Layout>> wide showed a blank folderpane and messagepane.
Resetting to wide thereafter worked fine after a restart.
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

alta88
 
Posts: 998
Joined: January 28th, 2006, 3:08 pm

Post Posted November 11th, 2011, 6:34 pm

you're right. though, the AMO rc8 is fixed for maxVer of 8.* which is where most get it.. it's a drag because while AMO maxVer can be changed online for its update mechanism, hosting on mozdev requires a whole new update with new version.

are you using MoreLayouts? a Tb 10 change for CompactHeaders has broken it. independent of that, it's also broken TotalMessage if the initial layout on restart isn't Classic, though it can be changed later.

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted November 11th, 2011, 9:17 pm

alta88 wrote:are you using MoreLayouts? a Tb 10 change for CompactHeaders has broken it. independent of that, it's also broken TotalMessage if the initial layout on restart isn't Classic, though it can be changed later.


Yes, but I had it disabled for some testing. I see now it is broken as well.
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

alta88
 
Posts: 998
Joined: January 28th, 2006, 3:08 pm

Post Posted November 12th, 2011, 2:48 pm

TotalMessage v1.0 updated for Tb 9 and 10 compatibility is here. It will be released officially when Tb 9 is released; this is meant for unreleased version compatibility only, which may change, and works as of the date of this post.

kombra
 
Posts: 1
Joined: December 13th, 2011, 3:04 am

Post Posted December 13th, 2011, 3:21 am

alta88 wrote:
anne.lavin wrote:I'm using the latest TotalMessage (v1.0rc7) and Tb 6.0.2, and I'm still seeing the odd persistence of one message's attachment pane in other messages. I haven't managed to figure out if it's completely repeatable, but will keep poking at it; let me know if there's any particular info you want, or way you'd like me to test/report it.

i recall such an issue versions ago, but thought it fixed.

I have that problem with 1.0rc8. When an inline preview (image, html, text) is shown, it always persists when the message is switched. When 'back' is used to leave the inline view, the attachment is properly switched to the new message (happens with whatever the default config is after a clean installation).

The mouse back button isn't working to switch the view back, only the keyboard shortcut (which would make this less annoying).
And a related question: is there a way to specify that attachments be loaded in a helper application rather than in the attachment pane? (Is it picking up my firefox prefs?) Forgive me if it's obvious and I'm just missing it. I sometimes work on a netbook with a tiny screen, and loading, say, a whole PDF into a tiny skinny slip of a pane at the bottom of the window doesn't really work that well, I'd far prefer a separate window...

TM lets you click on an attachment link and view the file inline in the pane (back button or alt-left arrow goes back), useful for fast preview (better in horizontal attachment view) of text and image files, but not for .pdf or .doc etc. to turn it off for pdf, disable the pdf plugin in addons manager. this isn't specific to TM.

Yes, but is there a way to disable this for html/images/text, so that it's always opened in the appropriate external app? There isn't even a working context menu option to open those attachments with something else. There only is the 'Open link in browser' which doesn't do anything useful, since it's a "mailbox:..." link.

alta88
 
Posts: 998
Joined: January 28th, 2006, 3:08 pm

Post Posted December 15th, 2011, 7:51 pm

1. yes, if in inline attachment pane view, switching to another message, with an attachment, the pane will retain the prior message's attachment. going back first then selecting a message is fine.

as for mouse back, my mouse is set to do alt-left for fx and tb.

2. this will be enhanced in a future version. the (not perfect) idea was to make it 'link like' but that is handled specifically so the click will need to be intercepted and opened via external handlers if desired, as Tb will always do it internally otherwise if it can.

note that if an attachment is detached, file:// locations can be opened if network.protocol-handler.expose.file is true.

Hanki

User avatar
 
Posts: 1415
Joined: April 2nd, 2004, 11:52 pm
Location: Australia

Post Posted December 17th, 2011, 7:39 pm

1.0 will not install in TB9

WaltS48

User avatar
 
Posts: 3788
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted December 18th, 2011, 7:46 am

Hank- wrote:1.0 will not install in TB9


Installed in Daily TB 11.0a1 with no problem
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

alta88
 
Posts: 998
Joined: January 28th, 2006, 3:08 pm

Post Posted December 18th, 2011, 8:56 am

alta88 wrote:1. yes, if in inline attachment pane view, switching to another message, with an attachment, the pane will retain the prior message's attachment. going back first then selecting a message is fine.

as for mouse back, my mouse is set to do alt-left for fx and tb.

2. this will be enhanced in a future version. the (not perfect) idea was to make it 'link like' but that is handled specifically so the click will need to be intercepted and opened via external handlers if desired, as Tb will always do it internally otherwise if it can.

note that if an attachment is detached, file:// locations can be opened if network.protocol-handler.expose.file is true.


these 2 issues are fixed in 1.0; there is now a button for Open in external app.

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 1 guest