MozillaZine


LINUX: override add-on compatibility issue

Discussion about official Mozilla Thunderbird builds
ffextensionguru

User avatar
 
Posts: 518
Joined: May 11th, 2005, 9:08 pm
Location: Gilbert, Arizona

Post Posted June 17th, 2011, 5:02 pm

I am trying to override the add-on compatibility for Thunderbird on Mint like I have on my Windows builds for Thunderbird 5.0,6.0 and 7.0 using the about:config Boolean entries set to false:

extensions.checkCompatibility.5.0b
extensions.checkCompatibility.6.0a
extensions.checkCompatibility.nightly

When I go into the add-ons manager it does show addon compatibility checking is disabled and I have no add-ons currently installed.I go to install an add-on and restart and I end up with the image below. At first I thought it was one of two add-ons I was trying to force to work Personas Plus ChromEdit Plus, so I tried just installing an add-on that was compatible with Thunderbird 6. Same result after restart. I've done this on copied as well as fresh profiles and end up with the same result each time I make a change in the config editor.

Image

tanstaafl
Moderator

User avatar
 
Posts: 47935
Joined: July 30th, 2003, 5:06 pm

Post Posted June 17th, 2011, 6:54 pm

It wouldn't hurt to install the add-on compatibility reporter add-on and let it (automatically) add some more settings to disable version checking.

https://addons.mozilla.org/en-us/thunde ... -reporter/

ffextensionguru

User avatar
 
Posts: 518
Joined: May 11th, 2005, 9:08 pm
Location: Gilbert, Arizona

Post Posted June 18th, 2011, 12:32 pm

tanstaafl wrote:It wouldn't hurt to install the add-on compatibility reporter add-on and let it (automatically) add some more settings to disable version checking.

https://addons.mozilla.org/en-us/thunde ... -reporter/


Okay, I'll give that a go on Monday and report back as to what happens.

ffextensionguru

User avatar
 
Posts: 518
Joined: May 11th, 2005, 9:08 pm
Location: Gilbert, Arizona

Post Posted June 22nd, 2011, 1:34 pm

Tried today on Linux Mint 10 with Thunderbird 5 Beta 2 Pre with a clean profile (no prior extensions installed). Installed the add-on compatibility reporter and upon the second restart ended up with the same results as above. Same as that happens with Thunderbird 6 or 7. However, I did try this with Thunderbird 3.1.10 and the add-on installed and was fine after the second restart.

tanstaafl
Moderator

User avatar
 
Posts: 47935
Joined: July 30th, 2003, 5:06 pm

Post Posted June 22nd, 2011, 3:06 pm

I suggest you create another profile with just one account using the profile manager, and see if it has the same problem. You can switch back to your prior profile aftewards, and if you're using POP and configure "leave message on server" that shouldn't cause you to lose any messages when you switch back.

ffextensionguru

User avatar
 
Posts: 518
Joined: May 11th, 2005, 9:08 pm
Location: Gilbert, Arizona

Post Posted June 22nd, 2011, 5:02 pm

tanstaafl wrote:I suggest you create another profile with just one account using the profile manager, and see if it has the same problem. You can switch back to your prior profile aftewards, and if you're using POP and configure "leave message on server" that shouldn't cause you to lose any messages when you switch back.

I've already done that. Today was on a fresh profile with no accounts and no prior extensions installed. I install the Add-on Compatibility Reporter restart. I see the message that compatibility checking is disabled in the add-ons manager and I know from Firefox (as well as when I had tried another profile which had extensions already) it takes another restart to "kick-in". It is upon that second restart when I get the screen in my first post. Again, no accounts and the only extension is the Add-on Compatibility Reporter. This be the same thing that happens when I had manually gone in and changed the settings in about:config last week. The only fix I can do is to nuke that profile and create a new one for that build.

genec
 
Posts: 128
Joined: July 13th, 2004, 8:57 pm

Post Posted June 23rd, 2011, 6:19 am

This is working for me - I suspect I have too many of these but try this :

exit TB - append these to end of your ~/.thunderbird/<profilename>/prefs.js


user_pref("extensions.checkCompatibility", false);
user_pref("extensions.checkCompatibility.5.0b", false);
user_pref("extensions.checkCompatibility.7.0b", false);
user_pref("extensions.checkCompatibility.nightly", false);
user_pref("extensions.checkCompatibility.nightly.5.0b", "false");

Restart TB and see if its ok now.

My version: TB 5.0b2pre 20110620000006

ffextensionguru

User avatar
 
Posts: 518
Joined: May 11th, 2005, 9:08 pm
Location: Gilbert, Arizona

Post Posted June 23rd, 2011, 12:01 pm

I looked at the prefs.js for the Thunderbird profile (fresh with no accounts or add-ons) I killed yesterday by installing the add-on compatibility reporter and appears those entries are already in there. This is really driving me crazy ](*,)
Code: Select all
# Mozilla User Preferences

/* Do not edit this file.
 *
 * If you make changes to this file while the application is running,
 * the changes will be overwritten when the application exits.
 *
 * To make a manual change to preferences, you can visit the URL about:config
 * For more information, see http://www.mozilla.org/unix/customizing.html#prefs
 */

user_pref("app.update.lastUpdateTime.addon-background-update-timer", 1308774492);
user_pref("app.update.lastUpdateTime.background-update-timer", 1308774492);
user_pref("app.update.lastUpdateTime.blocklist-background-update-timer", 1308774492);
user_pref("app.update.lastUpdateTime.microsummary-generator-update-timer", 1308774492);
user_pref("app.update.lastUpdateTime.search-engine-update-timer", 1308774492);
user_pref("app.update.postupdate", true);
user_pref("browser.cache.disk.capacity", 1048576);
user_pref("browser.cache.disk.smart_size.first_run", false);
user_pref("browser.cache.disk.smart_size_cached_value", 1048576);
user_pref("extensions.acr.firstrun", false);
user_pref("extensions.acr.previousApplicationVersion", "5.0b2pre");
user_pref("extensions.blocklist.pingCountVersion", 0);
user_pref("extensions.bootstrappedAddons", "{}");
user_pref("extensions.checkCompatibility", false);
user_pref("extensions.checkCompatibility.3.0", false);
user_pref("extensions.checkCompatibility.3.1", false);
user_pref("extensions.checkCompatibility.3.1a", false);
user_pref("extensions.checkCompatibility.3.1b", false);
user_pref("extensions.checkCompatibility.3.1p", false);
user_pref("extensions.checkCompatibility.3.1pre", false);
user_pref("extensions.checkCompatibility.3.3", false);
user_pref("extensions.checkCompatibility.3.3a", false);
user_pref("extensions.checkCompatibility.3.3b", false);
user_pref("extensions.checkCompatibility.3.3p", false);
user_pref("extensions.checkCompatibility.3.3pre", false);
user_pref("extensions.checkCompatibility.5.0", false);
user_pref("extensions.checkCompatibility.5.0a", false);
user_pref("extensions.checkCompatibility.5.0b", false);
user_pref("extensions.checkCompatibility.5.0p", false);
user_pref("extensions.checkCompatibility.5.0pre", false);
user_pref("extensions.checkCompatibility.6.0", false);
user_pref("extensions.checkCompatibility.6.0a", false);
user_pref("extensions.checkCompatibility.7.0", false);
user_pref("extensions.checkCompatibility.7.0a", false);
user_pref("extensions.checkCompatibility.8.0", false);
user_pref("extensions.checkCompatibility.8.0a", false);
user_pref("extensions.checkCompatibility.nightly", false);
user_pref("extensions.databaseSchema", 3);
user_pref("extensions.enabledAddons", "langpack-en-US@thunderbird.mozilla.org:3.1,langpack-en-GB@thunderbird.mozilla.org:3.1.99,compatibility@addons.mozilla.org:0.8.5,{972ce4c6-7e08-4474-a285-3208198ce6fd}:5.0b2pre");
user_pref("extensions.installCache", "[{\"name\":\"app-system-share\",\"addons\":{\"langpack-en-US@thunderbird.mozilla.org\":{\"descriptor\":\"/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/langpack-en-US@thunderbird.mozilla.org\",\"mtime\":1307821229000},\"langpack-en-GB@thunderbird.mozilla.org\":{\"descriptor\":\"/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/langpack-en-GB@thunderbird.mozilla.org\",\"mtime\":1307821228000}}},{\"name\":\"app-global\",\"addons\":{\"{972ce4c6-7e08-4474-a285-3208198ce6fd}\":{\"descriptor\":\"/opt/thunderbird5/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}\",\"mtime\":1308774333000}}},{\"name\":\"app-profile\",\"addons\":{\"compatibility@addons.mozilla.org\":{\"descriptor\":\"/home/elguru/.thunderbird/b3cg47si.CRASH ME!/extensions/compatibility@addons.mozilla.org.xpi\",\"mtime\":1308774334000}}}]");
user_pref("extensions.lastAppVersion", "5.0b2pre");
user_pref("extensions.pendingOperations", false);
user_pref("mail.append_preconfig_smtpservers.version", 2);
user_pref("mail.attachment.store.version", 1);
user_pref("mail.folder.views.version", 1);
user_pref("mail.openMessageBehavior.version", 1);
user_pref("mail.rights.version", 1);
user_pref("mail.spam.version", 1);
user_pref("mailnews.quotingPrefs.version", 1);
user_pref("mailnews.start_page_override.mstone", "5.0b2pre");
user_pref("mailnews.tags.$label1.color", "#FF0000");
user_pref("mailnews.tags.$label1.tag", "Important");
user_pref("mailnews.tags.$label2.color", "#FF9900");
user_pref("mailnews.tags.$label2.tag", "Work");
user_pref("mailnews.tags.$label3.color", "#009900");
user_pref("mailnews.tags.$label3.tag", "Personal");
user_pref("mailnews.tags.$label4.color", "#3333FF");
user_pref("mailnews.tags.$label4.tag", "To Do");
user_pref("mailnews.tags.$label5.color", "#993399");
user_pref("mailnews.tags.$label5.tag", "Later");
user_pref("mailnews.tags.version", 2);
user_pref("network.cookie.prefsMigrated", true);
user_pref("xpinstall.whitelist.add", "");
user_pref("xpinstall.whitelist.add.36", "");

ffextensionguru

User avatar
 
Posts: 518
Joined: May 11th, 2005, 9:08 pm
Location: Gilbert, Arizona

Post Posted June 23rd, 2011, 2:52 pm

I did notice that user_pref("extensions.checkCompatibility.7.0b", false) was not in there. Added and tried Thunderbird again with no luck. Also I believe that is redundant or not needed as user_pref("extensions.checkCompatibility.nightly", false); is used for Thunderbird 7.

ffextensionguru

User avatar
 
Posts: 518
Joined: May 11th, 2005, 9:08 pm
Location: Gilbert, Arizona

Post Posted June 27th, 2011, 5:43 pm

I've gone ahead and filed Bug 667720

ffextensionguru

User avatar
 
Posts: 518
Joined: May 11th, 2005, 9:08 pm
Location: Gilbert, Arizona

Post Posted June 28th, 2011, 5:48 pm

A couple more things to add. I've tested moving from Thunderbird 3.1.x to 5.0 with a burner profile that has the Add-on Compatibility Reporter installed. The result was the same when I launched that profile in Thunderbird 5, blank UI and a dead profile. However, I have found a work-around for now, by going into the add-ons I wanted install and bumping the max version to 5.0.* in install.rdf file. I was able to install the add-ons and they work fine in Thunderbird 5.0 on Linux.

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 1 guest