MozillaZine

Daily Build Thread 2014-04-17 Through 2014-04-23

Discussion about official Mozilla Thunderbird builds
JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted April 18th, 2014, 4:51 pm

Daily Build Thread
[If you would like to volunteer to post this weekly thread on a rotational basis
Please go here: http://wiki.mozilla.org/Thunderbird:Nig ... ld_Threads for further instructions.]


Danger, Will Robinson, danger!
Current situations to be aware of
Running TB 12 with local mail folders and pop3 mail filters may produce summary files that aren't correctly read by previous versions of Thunderbird See: TB 12 Known Issues


Checkins This Week

Now posted in each channel's status section

Recent Bugs/Links of interest


Latest Tested Builds

The current nightly build, unless otherwise noted



Thunderbird-Beta Thunderbird 28.0 / Gecko 28.0 Status

Green


Latest-Betas:28.0b1-candidates
Tbpl l10n Dashboard
Tinderbox_Builds_win32

Checkins This Week
None Yet


Earlybird Thunderbird 30.0a2 / Gecko 30.0 Status

Green

Latest-Nightly Links en-US l10n
Tbpl l10n Dashboard
Tinderbox_Builds_win32

Checkins This Week
None Yet


Daily Thunderbird trunk 31.0a1 / Gecko 31.0 Status

Green

Latest-Nightly Links en-US l10n
Tbpl l10n Dashboard

Checkins This Week

[Apr 16 07:16:40 2014 PDT]#946279 [MailNews Core:Feed Reader]-Implement autotagging of feed <category> tags [All]
[Apr 16 07:16:40 2014 PDT]#961666 [Thunderbird:Instant Messaging]-Chat notification sound should be customizable [All]
[Apr 18 06:26:17 2014 PDT]#992127 [Thunderbird:Message Compose Window]-Add a LaTeX-to-MathML dialog box to the mail composer [All]



JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted April 18th, 2014, 6:34 pm

JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

Mouse5
 
Posts: 1323
Joined: April 11th, 2014, 7:34 pm
Location: Sydney Australia

Post Posted April 19th, 2014, 2:00 am

rsx11m wrote:Not really... :doubt:


someones gonna have to get rid of Dead Code from thunderbird eventually so why not now

rsx11m
Moderator
 
Posts: 14420
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted April 19th, 2014, 8:02 am

Because the devs' and volunteers' resources are better spent for more urgent things to do than reducing Thunderbird's footprint by a quarter of a Megabyte or so. Having said that, everybody is always invited to post a patch up for review, so feel free and go ahead!

Also, I was referring to your comment
ArchRival wrote:maybe its time someone/company forks Thunderbird using WebKit instead

Unless Webkit supports XUL code for the UI out of the box, you may find it to be a lot of work to port all the window elements and dialogs into the Webkit framework.

WaltS48

User avatar
 
Posts: 3473
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted April 20th, 2014, 6:07 am

I'm not seeing my signature appear when I compose a reply to an email or followups to newsgroup posts using the latest Daily.

They do appear in original compositions.

Intentional? Known bug?

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Thunderbird/31.0a1
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

rsx11m
Moderator
 
Posts: 14420
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted April 22nd, 2014, 5:27 am

Can someone reproduce # 999269, Forwarding a message without CC header inline gets an empty "CC:" line in header table, for me? Should work out of the box on any trunk or aurora nightly, at least on Windows, but jcranmer states that he can't trigger it.

Bozz
 
Posts: 2673
Joined: October 18th, 2007, 1:53 pm

Post Posted April 22nd, 2014, 5:46 am

^I was able to reproduce it only with one email that you had replied back to an email from me... Subject: Funky font display.

rsx11m
Moderator
 
Posts: 14420
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted April 22nd, 2014, 8:19 am

That's weird, because that specific e-mail actually had a Cc to JoeS in it, thus you shouldn't see an empty Cc line. :?

Edit: Even weirderer, when I forward that message it gets a "To:" heading to you but the "Cc:" is omitted in the table. Looks like the logic is upside-down somewhere?

rsx11m
Moderator
 
Posts: 14420
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted April 22nd, 2014, 10:23 am

That was the key - patch posted and already approved. 8-)

The logic whether or not to include the "CC:" line in the table for forwarding with the "Normal" header view was reversed (so in the "Micro" view, whatever that is).

xtrem
 
Posts: 36
Joined: November 27th, 2004, 4:29 am

Post Posted April 22nd, 2014, 11:20 am

since 2014-04-17 (both Win64 and OSX) latest Daily is not able to connect to my IMAP and SMTP-server.
no changes in settings on either client or server side

"Send of message failed....Please verify your SMTP settings are correct and try again...."

If I roll back to 2014-04-16 Daily (both Win 64 and OSX) it works without problems.

Bozz
 
Posts: 2673
Joined: October 18th, 2007, 1:53 pm

Post Posted April 22nd, 2014, 2:18 pm

rsx11m wrote:That was the key - patch posted and already approved. 8-)

The logic whether or not to include the "CC:" line in the table for forwarding with the "Normal" header view was reversed (so in the "Micro" view, whatever that is).

Glad you got it sorted out. :)

rsx11m
Moderator
 
Posts: 14420
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted April 23rd, 2014, 3:13 am

We have a million bugs! :banana:

  • Bug 1000000, Celebrate 1000000 bugs, bring your own drinks [2014-04-23 01:10:16 PDT]

So far no apparent B1M issues with the bugzilla software. ;-)

Nomis101
 
Posts: 1013
Joined: January 7th, 2008, 7:46 am
Location: Germany

Post Posted April 24th, 2014, 6:59 am

Yes, what a funny bug. :D

rsx11m
Moderator
 
Posts: 14420
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted April 24th, 2014, 7:53 am

Can't find pref("all.the.bugs.are.fixed", true); anywhere on trunk builds, though...
Did this land already? :biggrin:

Nomis101
 
Posts: 1013
Joined: January 7th, 2008, 7:46 am
Location: Germany

Post Posted April 24th, 2014, 4:19 pm

I think thats vor Firefox/Thunderbird 31. Maintenance will be much easier than. :D

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 2 guests