MozillaZine

Sharepoint support for Seamonkey?

Discussion of general topics about Seamonkey
jeffw_00
 
Posts: 448
Joined: August 23rd, 2003, 3:23 pm

Post Posted December 29th, 2016, 10:20 am

Hi - Using Seamonkey 2.46 inside my company, I often click on links that take me to a Sharepoint Server. However, Seamonkey never takes me there. Instead it tells me

"This Connection is Untrusted - You have asked Seamonkey to connect securely to owapp, but we can't confirm that your connection is secure. Normally when you try to connect securely, websites will present trusted identification to prove that you are going to the right place. This website's identity can't be verified...."

The only option it gives me under "What should I do?" is "This sounds bad take me to my home page instead". This happens in a new profile, but doesn't happen in IE. In fact, my workaround is to "Open the page in Internet Explorer". (Admittedly, if I try to "Open the page in Firefox" I get the same message).

SO -
1) Is there some hidden setting I can adjust to avoid this message? In this environment I'm not worried so much about actual "bad" webpages (within company firewall, no personal browsing, etc), I'd like to force it to either reduce security and let me through, or at least give me the "I understand the risks" option.

2) Is there some Add-on for SM that supports Sharepoint - or perhaps emulates IE within the browser? (A casual search was not fruitful for SM, but there is IE Tab for Firefox, FWIW).

3) Is there some other way to make this work?

Thanks in advance for your help!

Best
/j
Last edited by jeffw_00 on December 29th, 2016, 11:01 am, edited 1 time in total.

barbaz
 
Posts: 1680
Joined: October 1st, 2014, 3:25 pm

Post Posted December 29th, 2016, 10:28 am

There should be a text saying "Technical Details" somewhere on that page. Please click that and post that info here.
*Always* check the changelogs BEFORE updating that important software!

jeffw_00
 
Posts: 448
Joined: August 23rd, 2003, 3:23 pm

Post Posted December 29th, 2016, 11:00 am

owapp uses an invalid security certificate

The certificate is not trusted because the issuer certificate is unknown.
The server might not be sending the appropriate intermediate certificates.
An additional root certificate may need to be imported.

Error code: <a id="errorCode"
title="SEC_ERROR_UNKNOWN_ISSUER">SEC_ERROR_UNKNOWN_ISSUER</a>


Thanks!

isaacschemm
 
Posts: 240
Joined: January 20th, 2015, 12:29 pm

Post Posted December 29th, 2016, 11:39 am

It sounds like your workplace might have their own internal SSL certificate which they installed for IE on everyone's computers, but not for other browsers.

Fire IE supports SeaMonkey:
https://addons.mozilla.org/en-US/seamonkey/addon/fire-ie/
After you install it, turn on "use the existing Firefox status bar (if any)" in the extension settings.

I actually use it for SharePoint at work - using the IE engine means I don't have to re-enter my credentials.

jeffw_00
 
Posts: 448
Joined: August 23rd, 2003, 3:23 pm

Post Posted December 29th, 2016, 12:26 pm

That worked (although I had to "install anyway" since it's not approved for SM 2.46. Thanks!

Do you know how to create a rule so that my https://sp-sg/* automatically switches? The home page fireie.org appears unreachable today.

Thanks!
/j

isaacschemm
 
Posts: 240
Joined: January 20th, 2015, 12:29 pm

Post Posted December 29th, 2016, 1:12 pm

Try:
Code: Select all
||sp-sg/^

jeffw_00
 
Posts: 448
Joined: August 23rd, 2003, 3:23 pm

Post Posted December 29th, 2016, 1:19 pm

:-)

Pav78

User avatar
 
Posts: 116
Joined: October 30th, 2009, 10:58 am
Location: Milwaukee, WI

Post Posted December 30th, 2016, 8:44 am

jeffw_00 wrote:owapp uses an invalid security certificate

The certificate is not trusted because the issuer certificate is unknown.
The server might not be sending the appropriate intermediate certificates.
An additional root certificate may need to be imported.

Error code: <a id="errorCode"
title="SEC_ERROR_UNKNOWN_ISSUER">SEC_ERROR_UNKNOWN_ISSUER</a>


Thanks!


I had the same problem on a att GoPhone Site. I was able to fix it by going to Edit/Preferences/Privacy and Security/SSL/TLS and checking "Enable TLS 1.0 and TLS 1.2 Boxes. All other boxes on the page are UNchecked.

jeffw_00
 
Posts: 448
Joined: August 23rd, 2003, 3:23 pm

Post Posted December 30th, 2016, 9:06 am

thanks - already had that config though - didn't help

Return to SeaMonkey General


Who is online

Users browsing this forum: No registered users and 2 guests