MozillaZine

Themes 1.1 ?

Discussion of general topics about Seamonkey
ZonkSJx

User avatar
 
Posts: 433
Joined: February 7th, 2006, 1:51 pm
Location: USA

Post Posted January 19th, 2007, 9:41 am

Thanks Aaron!

I noticed something. When you have your user chrome set to have a square address bar, the security indicator "url bar color" stays white on secure sites. When this user chrome option is disabled, it works fine. (The default round url bar)

I tried this with:

Smoke
Nemesis

aaron

User avatar
 
Posts: 3130
Joined: November 4th, 2002, 8:49 pm
Location: Texas

Post Posted January 19th, 2007, 10:46 am

Yeah, that's one part I forgot to correct... if you have the square url option, put this in your userchrome.css file for the time being until I put it in the code (I'm not at home right now so can't do it at the moment).
Code: Select all
#urlbar[level="high"] > .autocomplete-textbox-container,
#urlbar[level="low"] > .autocomplete-textbox-container {
  -moz-appearance: none !important;
  background-color: InfoBackground !important;
  color: InfoText !important;
}


Does that solve the problem?

ZonkSJx

User avatar
 
Posts: 433
Joined: February 7th, 2006, 1:51 pm
Location: USA

Post Posted January 19th, 2007, 12:54 pm

Yup!

Now it works.

Thanks

Johannes
 
Posts: 85
Joined: May 11th, 2003, 7:25 am

Post Posted January 20th, 2007, 9:48 am

Pinball and GrayModern are compatible with Seamonkey 1.1. I've synced both themes with the changes that were made to the Modern theme in the Seamonkey 1.1 release.

<a href="http://mozilla-themes.schellen.net"><img src="http://mozilla-themes.schellen.net/img/pinball-preview-small.png"><br>Pinball</a>

<a href="http://mozilla-themes.schellen.net"><img src="http://mozilla-themes.schellen.net/img/graymodern-preview-small.png"><br>GrayModern</a>
<a href="http://www.fotoausflug.de/en-index.html">Fullscreen panorama pictures of Germany</a>

Lost User 9766
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted January 20th, 2007, 11:34 am

I updated some of my themes to recognize the new urlbar security background color. I have been trying to figure out how I can preserve the native rounded corner look of the urlbar on GTK linux and still get the background color to change. I have been only able to get it to work with -moz-appearance:none. I really want -moz-appearance:textfield to preserve the native look of the urlbar. Any ideas?

Also, I identified another area besides the urlbar code that needs updating. In the file navigator.css to get mutiline tooltips to work right in your theme you will need to add (near line 415):

Code: Select all
/* For multi-line tooltips, we need our own style */
.htmltooltip-label {
  max-width: 40em;
  margin: 0;
  white-space: -moz-pre-wrap;
}


Eyes-Only

User avatar
 
Posts: 1354
Joined: May 18th, 2003, 9:59 am
Location: La Confédération Abènaquaise

Post Posted January 20th, 2007, 3:17 pm

Removed by Eyes-Only
Last edited by Eyes-Only on January 20th, 2007, 9:40 pm, edited 1 time in total.
--
"We never know just how much a kind word, or a gesture, will lift the spirits of a person in need and heal them." KDpup-484, LucidPup-511, SM2+/FX4+/TB31+

Old incognu
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted January 20th, 2007, 4:27 pm

Buff, I've been doing it this way:
Code: Select all
#urlbar[level="high"] > .autocomplete-textbox-container  {
  background-color: InfoBackground;
  color: InfoText;
}
Joined: 15 Feb 2005

Lost User 9766
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted January 20th, 2007, 4:50 pm

I tried the code you suggested but the background color of the urlbar wouldn't change for secure sites unless I use:

Code: Select all
#urlbar[level="high"] > .autocomplete-textbox-container,
#urlbar[level="low"] > .autocomplete-textbox-container {
  -moz-appearance: none;
  background-color: InfoBackground;
  color: InfoText;
}

Old incognu
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted January 20th, 2007, 5:48 pm

Oops, yeah, I checked in my navigator.css and I've got the -moz-appearance: none; too. But for me, the urlbar keeps the native look, while switching backgrounds for ssl.
comparison pic: http://i16.tinypic.com/48xepet.png

I wonder if the difference lies in the way the .autocomplete-textbox-container is handled ... I just took a quick look in seafox. I see you've got code for that in global/autocomplete.css, whereas I don't (because, if I recall correctly, I didn't want to have a different version for 'tux and for windows).

edit2:
Did a little hacking on seafox ... I commented out the following parts of autocomplete.css:
under textbox, I removed:
-moz-appearance: none;
border: none !important;

and I removed all of the code for .autocomplete-textbox-container.

You end up with an urlbar that isn't 100% native, in that the dropmarker placement is inside the urlbar. But, it, and the urlbar, get a native look, and the background changes without changing the overall style.
Joined: 15 Feb 2005

Lost User 9766
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted January 20th, 2007, 7:25 pm

Thanks for the tip. I ended up looking at the Firefox code and copied how they did it. Now I have a native looking urlbar.

ZonkSJx

User avatar
 
Posts: 433
Joined: February 7th, 2006, 1:51 pm
Location: USA

Post Posted February 13th, 2007, 1:55 pm

aaron wrote:Yeah, that's one part I forgot to correct... if you have the square url option, put this in your userchrome.css file for the time being until I put it in the code (I'm not at home right now so can't do it at the moment).
Code: Select all
#urlbar[level="high"] > .autocomplete-textbox-container,
#urlbar[level="low"] > .autocomplete-textbox-container {
  -moz-appearance: none !important;
  background-color: InfoBackground !important;
  color: InfoText !important;
}


Does that solve the problem?


Did this ever get fixed?

When I add that code to the userchrome it looks great on the square url bar, but when i put it back on the the round url bar it ends up looking like this:

Image

The outer square boarder sticks outside of the round url bar

aaron

User avatar
 
Posts: 3130
Joined: November 4th, 2002, 8:49 pm
Location: Texas

Post Posted February 13th, 2007, 5:23 pm

Dang! I think I forgot to put that in the code when I did my last update..... I'm out of town all week so it will be a bit before that one gets fixed, sorry. The userchrome.css code you qouted still works, right?

ZonkSJx

User avatar
 
Posts: 433
Joined: February 7th, 2006, 1:51 pm
Location: USA

Post Posted February 13th, 2007, 9:34 pm

Well it works when its on the square url bar. but when i change it back to round.. the color expands outside the the url bar.. click on that image i uploaded above to see what I'm talking about.

It seems as if the theme is conflicting with the png image you gave it originally (for 1.1).

It is a png image right?

yea.. looks weird

aaron

User avatar
 
Posts: 3130
Joined: November 4th, 2002, 8:49 pm
Location: Texas

Post Posted February 14th, 2007, 4:31 pm

When you're using the round url bar, comment out that code. I use the Nemesis theme with SeaMonkey 1.1 and have no problems....

therube

User avatar
 
Posts: 18177
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 18th, 2007, 11:42 am

@Johannes

In ChatZilla, the "send" button does not display.
It is physically there - you can find it by hoovering, but otherwise it is missing.

(Could my older build, 20060919 have any bearing on this?)

(Could my older build, 20060919 have any bearing on this?)

I'll have to explore this further, as the "send/multi-line" buttons do display for me on another computer with SeaMonkey 1.1 release.


EDIT 02/25/2007:
Turns out I had an older version of Pinball installed - 2007-01-20.
Updated to the latest, 2007-02-02, & all is well.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to SeaMonkey General


Who is online

Users browsing this forum: No registered users and 1 guest