MozillaZine

Compose Window and "Smilies"

User Help for Mozilla Thunderbird
fawltyjacko
 
Posts: 16
Joined: January 24th, 2006, 2:41 pm
Location: Christchurch, NZ

Post Posted January 14th, 2019, 9:23 pm

I installed the latest version (60.4.0) a few days ago. On a mac, using Mojave 10.14.2.

On two separate instances in a Compose screen, I have inserted a "smilie", and continued entering text. However, when I try to edit any of the text (inserted after the smilie), clicking the trackpad in a/any position, highlights all the text between the smilie and before the "--" immediately before my signature. This is a Bug/issue - but if someone higher up the food chain suggests this "Topic" should move to a different forum, please do so.

As a work-around (in both instances), I've copied all the text that has been highlighted automatically, and pasted it into Word. Highlighted the text there, and selected <Clear Formatting>. I've then made my edits, copied all the text and gone back to TB...where I've pasted the text into the same Compose window.

BUT what is pasted is the text from the original Compose window, including the smilie, and not what was edited/copied in MS Word. It's as if the Copy command in Word is being ignored.

In an attempt to isolate the issue, I've also (1) tried to paste the edited (Word) text into a new Compose window (no success - a repeat of what I've described in the paragraph immediately above), (2) opened a new Compose window in another email account and tried to paste the text (no success - a repeat of what I've described in the paragraph immediately above), (3) shutdown/closed TB, reopened it and paste (no success - a repeat of what I've described in the paragraph immediately above).

The only other peculiarity I can add is this: After all of the above, I again copied the MS Word text, and pasted it into a new note in the Notes App (this worked), and then copied that (into the Tb Compose window). This worked! So yes, this suggests there is a linkage broken between Word and TB.

But that still doesn't explain what the problem is with smilies inserted into a Compose window!
MBP OS X 10.14 Tb60 FfQuantum

tanstaafl
Moderator

User avatar
 
Posts: 44898
Joined: July 30th, 2003, 5:06 pm

Post Posted January 15th, 2019, 3:34 am

Moved from Thunderbird Bugs to Thunderbird Support as you are not describing possible workarounds for a confirmed bug submitted to Bugzilla.

MS-Word includes proprietary HTML tags. Its useful to save it as filtered HTML in Microsoft Word to avoid that. Copying and pasting a Word document into Notepad converts it to plain text or RTF. That is safe to copy and paste into a compose message window. I assume the Notes App under OSX is similar to Notepad under Windows.

http://kb.mozillazine.org/SupportEmptyP ... L_messages

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 9 guests