MozillaZine


Deleting a Messages Causes All To Disappear

User Help for Mozilla Thunderbird
gunrunnerjohn
 
Posts: 63
Joined: January 23rd, 2007, 7:24 pm

Post Posted November 27th, 2021, 3:23 pm

Sometimes when I have a folder with a bunch of unread messages, deleting one that I've read (or don't want to read) causes the folder display of all posts to blank. If I move off that folder and come back, the messages are there. However, this is really annoying.

I'm pretty sure this is triggered by them being a filtered message, but I can't readily duplicate it.

Pretty sure this started happening a couple of versions ago, around a month or so. I figured it would be fixed, but that never happened.

DanRaisch
Moderator

User avatar
 
Posts: 125630
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 27th, 2021, 4:50 pm

Pretty sure this started happening a couple of versions ago, around a month or so. I figured it would be fixed, but that never happened.

Since I've seen no other reports of the same situation I'm inclined to doubt that it is a program issue. Moving to Thunderbird Support forum.

How is the account set up, as POP or IMAP? In Thunderbird the menu path is Tools->Account Settings->Server Settings->Server Type at the top right of the dialogue.

When you refer to this occurring with a "filtered message", how was that filtering done? Are you using the search function (Edit->Find->Search Messages) or some other functionality?

gunrunnerjohn
 
Posts: 63
Joined: January 23rd, 2007, 7:24 pm

Post Posted November 27th, 2021, 5:56 pm

POP Mail Server, Port: 995

I'm using Thunderbird filters, I look mainly at the FROM name or the subject contents. When TB filters the messages I can then look at the respective folders. However, when I hit delete for the highlighted message, the folder window goes blank. If I click on another folder and back, the messages are back. Notably, this only happens the first time I enter the folder.

There used to be a variant of this behavior that changed to this behavior. I would delete the first message and the folder would lose the focus and I'd have to click back into the folder. However previously, the window wouldn't go blank, the cursor would just no longer be in the folder.

Again, I have changed NOTHING about the accounts or how I filter that precipitated this behavior, it just came out of the blue, I'm guessing after one of the many updates.

DanRaisch
Moderator

User avatar
 
Posts: 125630
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 28th, 2021, 5:05 am

I still don't understand what filter functionality you are using.
Is it Message Filters? http://kb.mozillazine.org/Filters_%28Thunderbird%29
Or is it the filter bar above the message list pane? https://support.mozilla.org/en-US/kb/qu ... er-toolbar
Or something else?

In either case, are you seeing this issue only with the Thunderbird Inbox folder, or with any folders?

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 4 guests