The folder is being processed. Please wait until processing

Discussion of bugs in Mozilla Thunderbird
Posts: 113
Joined: November 27th, 2006, 12:26 pm

Post Posted October 26th, 2007, 11:57 am

i still have to wait about 20-30 seconds, until i can download email with thunderbird... says folder is being processed.. bla bla...
it is quite annoying...
any foreseeable fix?


Posts: 1
Joined: October 27th, 2007, 9:32 am

Post Posted October 27th, 2007, 9:43 am

FWIW, I had this problem and Tbird would never quit processing the folder. I am not using a Global Inbox. Each of the 3 accounts have their own with the spam filters all sending spam to unique junk folders as well. I don't filter mail otherwise into folders but just do it manually. The problem was only with the default account. Other accounts were working fine.

I disabled my virus scanner (AVG free version) and it worked. But I noticed I received one of those certificate warnings (certificate is for the machine my domain is hosted on by my mail server name is different) and I accepted the certificate. But as soon as I turned it back on again, the processing folder problem came back. (Note this problem only showed up yesterday morning)

Tried all the suggestions I could find about compacting, reindexing, moving all the mail out of Inbox to a different folder, turning off check on startup, etc..

Finally I thought maybe I'll just change the server name to match the actual computer name. I did that but then changed my mind and changed it back. Thunderbird reprompted me again for the login/password to the mail server and lo and behold it worked.

Virus Scanner is running. Autochecking of email for all 3 accounts is working. No delays. No problems.


Posts: 113
Joined: November 27th, 2006, 12:26 pm

Post Posted October 28th, 2007, 2:48 pm

i dont know what else i can try... i have tried everything suggested in this thread...


Posts: 113
Joined: November 27th, 2006, 12:26 pm

Post Posted January 26th, 2008, 9:49 am

no one knows how to fix this prob?? it is very bothersome having to wait 20 seconds, before i can download email.... (i am using mailwasher, is that a possible cause for the problem?)


Posts: 1
Joined: February 8th, 2008, 11:10 am

Post Posted February 8th, 2008, 11:19 am

I don't use the Global Inbox for any of my 4 email accounts and I still get this error when I use the Get all messages option, but not always. Can't figure out a pattern. I then have to exit and restart Thunderbird.

Posts: 113
Joined: November 27th, 2006, 12:26 pm

Post Posted February 9th, 2008, 11:03 am

happens everyday... i have to wait 30 seconds or so before i can even start downloading... been having problems with this and FF..

Posts: 113
Joined: November 27th, 2006, 12:26 pm

Post Posted February 11th, 2008, 7:03 pm

i disabled check mail at startup for my mail email, and that did it! now it opens and i can download instantly...
also, very odd, i uninstalled ZoneAlarm, and resinstalled the same one.. and now thunderbird opens VERY quickly... and i can hit download emails right away without being told "THIS FOLDER IS..."


EDIT: thats right, the reason i have the check mark next to 'check email on startup' is so when TB opens, it goes right to my inbox... with this UNCHECKED.. it goes to the default view, with

read messages
write a new message

View settings for this account etc...


Posts: 57
Joined: January 23rd, 2007, 7:24 pm

Post Posted February 27th, 2008, 6:41 am

I have the same issue, and it's getting to be annoying enough that I'm considering changing back to Eudora.

Yes, I have all the accounts directed to a global inbox and run the filters on that box. Otherwise, I'd have to have any identical filters replicated for each account, which is pretty kludgey.

I guess I can't see why TB couldn't simply add an option to not run the filters if there are any email accounts being actively processed. I also don't understand why the reply account would enter into this issue, since I'm not doing any replies when this happens, it's just fetching mail.

Is this really that hard to fix? Why wouldn't an option either defer filtering until on-line processing is done, or serialize the email fetch and filtering for an individual account and not try to overlap that processing work?

BTW, this happens when TB is just running minimized, it's not just a startup bug.

Posts: 2
Joined: March 11th, 2008, 10:58 pm

Post Posted March 11th, 2008, 11:47 pm

Here is how I fixed this.

For me the problem seemed to be related to Thunderbird not connecting to the server properly. The first time connection I made a mistake in my connection settings, after that I got "folder being processed" error until I carried out the following. I don't have a global folder setup, each email account has its own folder. I have a number of email accounts, more than 5.

The main fix for me seemed to be changing the server settings, exiting TB, and then re-entering. This seemed to fix something.

I think these are the minimal steps that are needed:

First change the server settings to something invalid:
- Change the server connection name (to anything, say an invalid value like dummy.comasdf )
- Also change the username to something invalid
- Also change the connection security to something other than what it should be (eg if its TLS change it to SSL)

Now exit Thunderbird and re-enter:
- Exit Thunderbird (This is important!)
- Enter Thunderbird again and try to Get mail. It should fail to find the server.
- Change the server name, username, connection security, etc, to the correct settings.
- Exit Thunderbird again

Now re-enter Thunderbird, with luck it will work. If not, repeat all the above, and then (I also did these, but I don't think they are necessary because I think I got it going in the past without doing these):
- Do all the above, exit Thunderbird, then:
- Delete the *.msf index files in the problem email account's profile folder. (For my profile, each account has a different folder, if you have a Global inbox you may need to delete just one big one, but take care... also it may take a while to rebuild). They are rebuilt automatically each time you re-enter Thunderbird. If you have a large email folder, I recommend doing this step last.
- Turn off AVG email certification for virus email checking (Email virus scanning is still ON, just the certification message no longer appears. If you don't use AVG, try temporarily turning off all email scanning. Turn it back on once you get mail working.)
- I rebooted (definitely not necessary, at least in my case, your mileage may vary)
- I turned off Zone Alarm email checking (turn back on once mail works)
- Turn off any applications that index the disk, (like Google Desktop or Copernic Desktop Search, etc)

Still no luck? Then while in Thunderbird also:
- Compact all accounts (Select account and choose File, Compact)
- Turn on automatic email compaction (Tools, Options, Network and Disk Space, tick Compact when...)
- Turned off "Check email at start up" for each of my email accounts

- Also repeat all steps above (messing with the server settings, exit, backin, exit again..)

.. and then restart Thunderbird and see if you can connect now.

I hope these instructions prove valuable for someone!


Posts: 8
Joined: March 21st, 2008, 9:59 am

Post Posted March 25th, 2008, 4:42 pm

Make sure that you on click on "Get Mail" once. If you double click, you will always get the Alert message of This folder is being processed.

Posts: 32
Joined: November 24th, 2006, 12:42 am

Post Posted May 10th, 2008, 5:36 pm

All my accounts go to their own inbox. I did not get the message when I had my accounts set to not get mail automatically. I just turned that back on for 2 of my accounts and got the message. So I compacted the folder then got my email, no problem.

I have two possible culprits as I didn't experience this problem before 2.0 nor before ZoneAlarm. I'd installed both at about the same time.

Posts: 1
Joined: May 18th, 2008, 12:39 am

Post Posted May 18th, 2008, 1:19 am

Hello all, this is what helped me:

I used to get this error message with AVG Anti-Virus Free 7.5 and 8.0 E-mail Scanner active and TB Account Settings >> Server Settings >> Security Settings set to "TLS, if available".

I could receive my e-mail normally if I disabled AVG e-mail scanner or set TB security setting to "Never" or "SSL", latter of course being the "final solution", as I could turn e-mail scanning back on. (TB restart was required.)

Win XP SP3, TB, AVG Free 8.0.100.

Posts: 2
Joined: February 11th, 2004, 6:16 pm

Post Posted June 25th, 2008, 6:19 am

I've seen this problem for ages, but seem to have fixed it. My inbox was a "Favorite Folder".

From the menu, I chose View / Favorite Folders
I then right-clicked on "Inbox" in the folder list (it was the only one) and unchecked "Favorite Folder".
I re-started Thunderbird.

I've now gone a week without seeing "...folder is being processed...", whereas before I saw it at least once an hour.

Hopefully, this helps someone else.

Old Grizz
Posts: 1
Joined: June 29th, 2008, 5:58 am

Post Posted June 29th, 2008, 6:45 am

I'm a fairly recent Thunderbird convert and the "processing folder" message (following clicking on the "Get Mail") began to appear 3 or 4 months into use. At first the delay lasted only a second or two but slowly grew to around 8 or 10 seconds. This occurred on just opening Thunderbird or waking the computer with Thunderbird already active. I concluded that what was being "processed" was likely the pile of emails being accumulated - especially those with multi-meg attachments.

After saving any attached photos worth keeping, I deleted every email with attachments. I also deleted about 95% of other email. It's been approximately a month now since doing this house cleaning and that irksome "processing folder" message has not returned.

By the way, it's Thunderbird V 2.0.0 on an Intel Mac running OS 10.5.3 with no multiple accounts or anything like that.

I hope this fix continues to work and possibly may help someone out there with a similar aggravation.


Posts: 113
Joined: November 27th, 2006, 12:26 pm

Post Posted August 10th, 2008, 5:43 pm

i just changed from satellite internet to DSL.. same speed, 1.5mbs/s but... much lower latency... from 1200 to 90ms
now, that doesnt happen for me anymore...
i can get mail almost instantly.. i wait 2 seconds.. and hit get mail, and works everytime... if i switch back to satellite... the 'processing" message comes back...
just thought id share

Return to Thunderbird Bugs

Who is online

Users browsing this forum: No registered users and 1 guest