MozillaZine

Thunderbird 3: About "receive but can't send smtp error"

Discussion of bugs in Mozilla Thunderbird
James Alex Gerard

User avatar
 
Posts: 3
Joined: January 4th, 2010, 7:00 pm

Post Posted January 4th, 2010, 9:24 pm

Thunderbird 3: About my "receive but can't send smtp error" experience
-------------------------------------------------------------------
I've discovered -- and fixed -- situations where a Thunderbird 3 email account can receive mail, but cannot send. Even though all the settings for both incoming (POP) and outgoing (smtp) are correct. Despite deleting the account and rebuilding it. :x

Nothing seems to work. Even when everything is set correctly and there appears to be no "sane reason" why it is not sending. I feel there's a glitch in Thunderbird 3 concerning the password management. Or the lack of it.

But there's an easy cure. 8-)

I've noted that when I have changed passwords for various email accounts from my ISP, Thunderbird 3 failed to "update" the outgoing password. Does that sound similar?

Now try the flawed email account using Sea Monkey 2.0.1. It works, doesn't it? But if it errs there too, take a look at the following

See what Sea Monkey has that Thunderbird doesn't. A "Password Manager" utility. :D

>"View Saved Passwords." "View Passwords." Sort by account name.

Take a look. The erroring accounts probably have conflicting passwords for the outgoing settings. At least mine did. In Sea Monkey, simply delete all passwords associated with the erroring accounts. It will leave your settings intact. Now restart Sea Monkey.

You'll get a prompt to enter the deleted password for the account. Now open "Password Manager" and look. The info has been rebuilt and both the incoming and outgoing passwords match.

Now try the account out. You should get and send email fine now. And a lot faster, too, I note.

For some reason, Thunderbird 3 holds older, outdated passwords per account email address -- concerning how it addresses the outgoing smtp server. To fix your outgoing email problem on Thunderbird 3, install the following add-on:

https://addons.mozilla.org/en-US/thunderbird/addon/2848

Password Exporter 1.2

See what Password Exporter 1.2 has that Thunderbird 3 doesn't. A "Password Manager" utility. :D

And once installed, go to Options with this add-on and follow the above steps for deleting the phantom passwords. Restart Thunderbird 3.

You'll get a prompt to enter the deleted password for the account. Now open "Password Manager" and look. The info has been rebuilt and both the incoming and outgoing passwords should match. Now try the account out. You should get and send email fine now. And a lot faster, too, I note.

It may not solve various "receive but cannot send email in Thunderbird 3" issues, but it solved mine. 8-)

I'll say Thunderbird 3 is the best email client app out there. It rules the planet. It does on mine -- once you get it tuned.
-----------------------------------
James Alex Gerard
Computer Specs:
Dell Studio XPS 435T/9000; Intel Core i7 CPU 920 (2.67GHz); ATI Radeon HD 4350 (with 3,323 MB graphics memory), 6 GB RAM, 684 GB Hard Drive; 64-bit operating system; Windows 7 Home Premium; Firefox 3.5.3; Thunderbird 3; Sea Monkey 2.0.1; CubeDesktop Pro 1.4.0
James Alex Gerard
Computer Specs:
Dell Studio XPS 435T/9000; Intel Core i7 CPU 920 (2.67GHz); ATI Radeon HD 4350 (with 3,323 MB graphics memory), 6 GB RAM, 684 GB Hard Drive; 64-bit operating system; Windows 7 Home Premium.

Chelmstone
 
Posts: 2
Joined: January 11th, 2010, 9:02 pm

Post Posted January 11th, 2010, 9:22 pm

Hi, Before I try your solution.
The error mesage that I'm getting is the following:-
Sending of message failed.
An error occurred sending mail: Unable to authenticate to SMTP server smtp.myusp.co.uk. The server does not support authentication (SMTP-AUTH) but you have chosen to use authentication. Untick 'Use name and password' for that server or contact your service provider.

There is no place to untick 'Use name and password' (which was never ticked anyway) I upgraded yesterday and this has happened since. Will the plugin you mention help in this instance. What do you think? Anyone....?
Finally, if it doesn't work can I go back to the previous version by uninstalling 3.0 and reinstalling 2.0.0.23.exe ? (I've still got it on my hard drive) I don't want to lose my emails etc.
I really don't need this! 2.0.0.23 worked fine!
Frank

makaiguy

User avatar
 
Posts: 15641
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted January 11th, 2010, 10:23 pm

Chelmstone wrote:Hi, Before I try your solution.
The error mesage that I'm getting is the following:-
Sending of message failed.
An error occurred sending mail: Unable to authenticate to SMTP server smtp.myusp.co.uk. The server does not support authentication (SMTP-AUTH) but you have chosen to use authentication. Untick 'Use name and password' for that server or contact your service provider.

There is no place to untick 'Use name and password' (which was never ticked anyway) I upgraded yesterday and this has happened since. Will the plugin you mention help in this instance. What do you think? Anyone....?
Finally, if it doesn't work can I go back to the previous version by uninstalling 3.0 and reinstalling 2.0.0.23.exe ? (I've still got it on my hard drive) I don't want to lose my emails etc.
I really don't need this! 2.0.0.23 worked fine!
Frank


Authentication means sending your login name and password to log into the server. This proves to the server that you are entitled to use it to process your mail.

In TBird 2 if you tried to authenticate on an SMTP server that didn't support it, TBird ignored the error message received. TBird 3 honors the error message. So you need to stop trying to authenticate.

Menu Path:
[In Windows & OSX]: Tools | Account Settings, or
[In *nix]: Edit | Account Settings
.. then, at the bottom of the left pane, click on Outgoing Server (SMTP).

Highlight the SMTP server you are using and press Edit.

Remove the check in the "Use name and password" box.
Doug Wilson, "The Makai Guy"
Win7 Home Prem (64bit): FF 38.0.2, TB 31.6.0║ Android 4.2.2/4.4.2: FF 38.0, no TB available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

Chelmstone
 
Posts: 2
Joined: January 11th, 2010, 9:02 pm

Post Posted January 11th, 2010, 11:51 pm

Thank You very much for your help Doug. It was the fact that the Outgoing Server (SMTP) text is right at the bottom and the address giving the problem is right at the top of a list of 5 addresses so I never actually scrolled to the very bottom! How dozy can you get? Lol. Anyway it's sorted now. Thanks again.
What a fool believes he sees...indeed! I certainly can't argue with that!

Kreistor
 
Posts: 2
Joined: January 13th, 2010, 9:40 pm

Post Posted January 13th, 2010, 9:53 pm

makaiguy wrote, "Highlight the SMTP server you are using and press Edit. Remove the check in the "Use name and password" box."

This did not work for me.

I did find a way to solve this problem without using a third party program. (Make certain you know your email password before doing this.)

Tools>Options>Outgoing Server (SMTP)
Select the account in the window on the right. (There should only be one, and if there's more, you probably don't need to read this.) "Edit..." the account and copy down all information. "Cancel" back to the previous page, leaving the account unchanged.

Now "Add..." a new account, and copy all information to make it identical to the previous one, except for the name which must be different. "OK" to previous screen. If you're paranoid, double check the accounts are identical in all but name.

Highlight the new account and "Set Default". You will see the new account cannot be deleted, but now the old one can. Highlight the old account and "Remove" it. "OK" the options window away.

Create a message, and send it. You will now be prompted to enter a password, and you should connect just fine.

Kreistor
 
Posts: 2
Joined: January 13th, 2010, 9:40 pm

Post Posted January 14th, 2010, 12:12 pm

Minor correction to my previous post. It's Tools > Account Settings > Outgoing Server (SMTP)

Sorry for any confusion.

DianeJohn
 
Posts: 2
Joined: July 28th, 2007, 7:10 am

Post Posted January 20th, 2010, 6:01 pm

I have tried using the suggested add-on, and I tried creating a new account. I still get this message when I try to send: An error occurred while sending mail. The mail server responded: 5.1.0 authentication required. Please verify that your email address is correct in your Mail Preferences and try again. I don't know where my Mail Preferences are. Any other suggestions? Please.

makaiguy

User avatar
 
Posts: 15641
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted January 20th, 2010, 8:13 pm

Diane - your problem is just the opposite of what is being discussed here. The server is telling you that authentication IS required for that server.

Menu Path:
[In Windows & OSX]: Tools | Account Settings, or
[In *nix]: Edit | Account Settings
.. then, at the bottom of the left pane, click on Outgoing Server (SMTP).

Highlight the SMTP server you are using and press Edit.

Place a check in the "Use name and password" box, and enter your server login name in the "User name" field. Be sure you enter the user name correctly, in the form required by the server. This is generally the name you would enter to log into your account via webmail (i.e. to view it as an online web page using your web browser) but not always. Many servers require your full email address, while some others want to see just your account name (the portion of the email address before the @). Some want the full email address but with the @ character replaced by another such as +. In some cases you may have been issued some other identifier, like an account number, to use here.

If that doesn't solve your problem, please start a new thread rather than continuing to post in this one, as it is unfair to the original poster to sidetrack the discussion into a different problem.
Doug Wilson, "The Makai Guy"
Win7 Home Prem (64bit): FF 38.0.2, TB 31.6.0║ Android 4.2.2/4.4.2: FF 38.0, no TB available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

DianeJohn
 
Posts: 2
Joined: July 28th, 2007, 7:10 am

Post Posted January 21st, 2010, 3:20 pm

Thank you for the solution to my problem. I apologize for being in the wrong thread.
Diane

LoudNoise
Moderator

User avatar
 
Posts: 38584
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted February 27th, 2010, 5:11 pm

Maniwar-
Since you started a new thread I split off your post. This thread is getting confused as it is.
Post wrangler
Notice: If you have a comment on moderation, please post here viewtopic.php?f=11&t=2706389 and don't private message a mod. I don't reply to private messages unless I have previously requested them

Maniwar
 
Posts: 5
Joined: February 26th, 2010, 10:09 pm

Post Posted February 27th, 2010, 7:43 pm

K, thanks! I wasn't sure anyone would see this since the last post was in January.

johngilberttyler
 
Posts: 1
Joined: May 3rd, 2010, 11:43 am

Post Posted May 3rd, 2010, 11:51 am

Go to Tools / accounts / outgoing server/edit box & then uncheck ']username & password'.
This will sort it [Mac OSX]

g37752
 
Posts: 3
Joined: July 19th, 2011, 11:11 pm

Post Posted September 13th, 2011, 11:06 am

i have had just about enough with thunderbird.

it did not work on computer A. cannot send mail. i couldnt find any solutions online, wasting all that time. suddenly, it started working again. and NOW? computer B is having the problem!

it's about time to change the mail agent! screw thunderbird!

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted September 13th, 2011, 4:01 pm

g37752 wrote:i have had just about enough with thunderbird.

it did not work on computer A. cannot send mail. i couldnt find any solutions online, wasting all that time. suddenly, it started working again. and NOW? computer B is having the problem!

it's about time to change the mail agent! screw thunderbird!

howdy g37752,

real life trumps all, doesn't it? as long as you can find a good enuf email client, then go for it. if you really like the new one, please post back here about it.

btw, this forum is NOT part of mozilla. it's a user owned and user supported forum.

good luck with the new app! [*grin*] that aint intended to be sarcastic. i really do wish you good luck.

take care,
lee

TaxmanBOL
 
Posts: 4
Joined: September 2nd, 2006, 6:56 am

Post Posted March 11th, 2012, 6:34 pm

Just started getting this error last night. I thought it was being caused by my ISP (I owe them an apology). But the fact that my Smartphone was able to send and receive as normal led me to investigate further. I ended up here and read about the fix and deselected the authentication on the outgoing server and voila.

You guys rule. =D>

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 1 guest